summaryrefslogtreecommitdiff
path: root/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild')
-rw-r--r--app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
index f350b7c57fac..aa17736fffbf 100644
--- a/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
+++ b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
@@ -1,38 +1,36 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=8
DESCRIPTION="Tables available for ophcrack"
HOMEPAGE="http://ophcrack.sourceforge.net/"
-SRC_URI="xpfast? ( mirror://sourceforge/ophcrack/tables_xp_free_fast.zip )
- xpsmall? ( mirror://sourceforge/ophcrack/tables_xp_free_small.zip )
- vistafree? ( mirror://sourceforge/ophcrack/tables_vista_free.zip )"
+SRC_URI="
+ xpfast? ( mirror://sourceforge/ophcrack/tables_xp_free_fast.zip )
+ xpsmall? ( mirror://sourceforge/ophcrack/tables_xp_free_small.zip )
+ vistafree? ( mirror://sourceforge/ophcrack/tables_vista_free.zip )"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+xpfast xpsmall +vistafree"
-
REQUIRED_USE="|| ( xpfast xpsmall vistafree )"
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-S=${WORKDIR}
+BDEPEND="app-arch/unzip"
src_unpack() {
- for i in ${A};
- do
+ local i table
+ for i in ${A}; do
table=${i#tables_}
table=${table%.zip}
- mkdir "${S}/${table}"
+ mkdir "${S}"/${table} || die
cd $_ || die
unpack "${i}"
done
}
src_install() {
- dodir /usr/share/ophcrack/
- cp -r "${S}"/* "${ED}"/usr/share/ophcrack/ || die
+ insinto /usr/share/ophcrack
+ doins -r .
}