summaryrefslogtreecommitdiff
path: root/app-crypt/moolticute/moolticute-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
commita833e3f4a431b8eea751b7420e127787f9c92117 (patch)
treeb941d23e9e3d5f070b01feb15ef927839af7456a /app-crypt/moolticute/moolticute-9999.ebuild
parent4cd2370bed609c118b6edfde5d3f116e5c35b897 (diff)
gentoo resync : 04.12.2017
Diffstat (limited to 'app-crypt/moolticute/moolticute-9999.ebuild')
-rw-r--r--app-crypt/moolticute/moolticute-9999.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/app-crypt/moolticute/moolticute-9999.ebuild b/app-crypt/moolticute/moolticute-9999.ebuild
index 8609d2fec945..6176b1bb8674 100644
--- a/app-crypt/moolticute/moolticute-9999.ebuild
+++ b/app-crypt/moolticute/moolticute-9999.ebuild
@@ -4,18 +4,18 @@
EAPI=6
if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/raoulh/moolticute.git"
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
inherit git-r3
KEYWORDS=""
else
- SRC_URI="https://github.com/raoulh/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
fi
inherit gnome2-utils qmake-utils udev
DESCRIPTION="Mooltipass crossplatform daemon/tools"
-HOMEPAGE="https://github.com/raoulh/moolticute"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
LICENSE="GPL-3"
SLOT="0"
@@ -34,6 +34,15 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${P/_/-}"
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
src_configure() {
eqmake5 PREFIX="/usr" Moolticute.pro
}