summaryrefslogtreecommitdiff
path: root/app-crypt/minisign
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /app-crypt/minisign
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'app-crypt/minisign')
-rw-r--r--app-crypt/minisign/Manifest4
-rw-r--r--app-crypt/minisign/metadata.xml17
-rw-r--r--app-crypt/minisign/minisign-0.8.ebuild25
-rw-r--r--app-crypt/minisign/minisign-9999.ebuild25
4 files changed, 71 insertions, 0 deletions
diff --git a/app-crypt/minisign/Manifest b/app-crypt/minisign/Manifest
new file mode 100644
index 000000000000..9b599be6e829
--- /dev/null
+++ b/app-crypt/minisign/Manifest
@@ -0,0 +1,4 @@
+DIST minisign-0.8.tar.gz 14045 BLAKE2B 3c0cb0ebaeeacee5f56c788a48eef8d0a324c2db2fe8f63fc16a197870c327ed2cacc618cb6422f8d7d7ef35860b58aa0a2769c851e8af9b1a7a7cd9d2ca3a07 SHA512 79bf626d0c15e39ce3bdf53600038028c0b22904b648074bf516a9ea6962c9486c41244e80637a5fbac090cce1ed9b4b3d57b8a02632646e01b43aa413cd8bd9
+EBUILD minisign-0.8.ebuild 558 BLAKE2B 9b6013af92efcea9b269f5672b858e904bc0cdf617d6c6839efed303272b095005d74d8c3883f52f8f5704c37a7a23c3e86bfdebe8a0e4d811f85deee767997a SHA512 8f8520a1311f2f553105c779bcbf15ab511e987219e600aceb3f4e6fc175edfbc8c17117c2666f1d1a7bad37ad9780bc7e44e018c5f7f5b8db7712c65b2dba63
+EBUILD minisign-9999.ebuild 558 BLAKE2B 9b6013af92efcea9b269f5672b858e904bc0cdf617d6c6839efed303272b095005d74d8c3883f52f8f5704c37a7a23c3e86bfdebe8a0e4d811f85deee767997a SHA512 8f8520a1311f2f553105c779bcbf15ab511e987219e600aceb3f4e6fc175edfbc8c17117c2666f1d1a7bad37ad9780bc7e44e018c5f7f5b8db7712c65b2dba63
+MISC metadata.xml 681 BLAKE2B 590bbd6d73e1a9d5ac5e3381ffa5f29e8f8a0f329874e5372f52425a679c8966211b689a699d75cd6bc299e6d670f7724284fd87fc8f6ce0f8038133dfcc33eb SHA512 2840cf105039a5bb4a7564f4d10f759c1cf0f7f183a9684fabc2a1a158ea01a8dc7c552bad57991b30bf676c88b2b00d1f7304a2c565d388e798cf931e566242
diff --git a/app-crypt/minisign/metadata.xml b/app-crypt/minisign/metadata.xml
new file mode 100644
index 000000000000..974452080b5e
--- /dev/null
+++ b/app-crypt/minisign/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <longdescription lang="en">
+ Minisign is a dead simple tool to sign files and verify signatures.
+ It is portable, lightweight, and uses the highly secure Ed25519 public-key signature system.
+ Signature written by minisign can be verified using OpenBSD's signify tool:
+ public key files and signature files are compatible.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jedisct1/minisign</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/minisign/minisign-0.8.ebuild b/app-crypt/minisign/minisign-0.8.ebuild
new file mode 100644
index 000000000000..da90d6d5d3f4
--- /dev/null
+++ b/app-crypt/minisign/minisign-0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Dead simple tool to sign files and verify signatures"
+HOMEPAGE="https://github.com/jedisct1/minisign"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
+else
+ SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=">=dev-libs/libsodium-1.0.16:=[-minimal]"
+RDEPEND="${DEPEND}"
diff --git a/app-crypt/minisign/minisign-9999.ebuild b/app-crypt/minisign/minisign-9999.ebuild
new file mode 100644
index 000000000000..da90d6d5d3f4
--- /dev/null
+++ b/app-crypt/minisign/minisign-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Dead simple tool to sign files and verify signatures"
+HOMEPAGE="https://github.com/jedisct1/minisign"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
+else
+ SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=">=dev-libs/libsodium-1.0.16:=[-minimal]"
+RDEPEND="${DEPEND}"