summaryrefslogtreecommitdiff
path: root/app-crypt/minisign
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /app-crypt/minisign
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'app-crypt/minisign')
-rw-r--r--app-crypt/minisign/Manifest4
-rw-r--r--app-crypt/minisign/minisign-0.10.ebuild31
-rw-r--r--app-crypt/minisign/minisign-9999.ebuild11
3 files changed, 40 insertions, 6 deletions
diff --git a/app-crypt/minisign/Manifest b/app-crypt/minisign/Manifest
index 4776d532d05a..4444cf5cc84c 100644
--- a/app-crypt/minisign/Manifest
+++ b/app-crypt/minisign/Manifest
@@ -1,4 +1,6 @@
+DIST minisign-0.10.tar.gz 18242 BLAKE2B 8b71f01ced4be00c38937e7db5ace2c7e348410a9381f6cc27374827fa0a9da70cca96153af199880ccd5f2265e18a7f21d074f877e0e21ca797bbba2bf5cbf5 SHA512 6a38500ed896c17b100bca47443f9806debe6e44d3ce09189f5f8913a41d4913434397175d1caa770fb0cc0918078dfc71c01b82b9bf919fdfba00434f4ce100
DIST minisign-0.9.tar.gz 15664 BLAKE2B f9f358a27b069e752894326932a8c5c51f308ade49ed7088a5f693b4e8327639fc5578607f348994a7ab7484091ed93190894c1965cadbbbf2a27e939ccc117b SHA512 7970f3e72ff759f3f02416de5d6035e1c8dd4e92ea718083cc5091c7e2355b59c4e178c60ca934985ba1e1afcd970967d4fb39a434ba54b140f3fc9be661253d
+EBUILD minisign-0.10.ebuild 733 BLAKE2B 5964c8b791b2aef2ab987f43e90228ecaf13fe43006e06b5e2b855f5aea2db6b1418f3f907cc2e7304757d0811eacded3fc8a51882deebfca6f3878d97b04e68 SHA512 f54b9f43eca688a7ded56ff9223d9d9751dccc5e228e2b9fccdff6d9319f87b610893ec9e93c84ce0e5649bac0cce0cb511b5b2263fba75593057a1993650ed6
EBUILD minisign-0.9.ebuild 725 BLAKE2B 798e077e132d183b8d40828c4c8d0b3f938fca4bba0e15eda0d91d6a6079feaba8776773fa4ef0f97949bf441156967484bed025abc0db8ce571f196472b915c SHA512 b165c58b237545ffa24aa670bb604b1bec3590543872611671c2a087af0b7045b264ac476eaea9a9ae47b82009b56eae5512e6f5fa0b7c410f9573fe22e1d6be
-EBUILD minisign-9999.ebuild 665 BLAKE2B 20395e22436151cbacb842badbf83ee829cdc278ac129b08db475cc87d35f7294097f87e4780a63a208d63b3f31edd244fb2da471d1de1dc95f744094c11f784 SHA512 b336ec7821b270de6f7b6a82d029cafde41ee685cd6a376d077e82451a6d223f0b0b5b6fbec6e994e009b8157b42d31c4ed7f0240b57a2877ffdb369742ff4a1
+EBUILD minisign-9999.ebuild 733 BLAKE2B 5964c8b791b2aef2ab987f43e90228ecaf13fe43006e06b5e2b855f5aea2db6b1418f3f907cc2e7304757d0811eacded3fc8a51882deebfca6f3878d97b04e68 SHA512 f54b9f43eca688a7ded56ff9223d9d9751dccc5e228e2b9fccdff6d9319f87b610893ec9e93c84ce0e5649bac0cce0cb511b5b2263fba75593057a1993650ed6
MISC metadata.xml 682 BLAKE2B a3a405073dbad7ea7c570ae8eccef230b2f3baf389d0210e6ba1afb57e0b3504172225b1cb3a957812ed08bf2b8080b1b4dcb13ab982eccc8bdc15377a90cffa SHA512 8e88cae8452b76db2c57e86f6c50a5859964cb3e7e3f6a574990fbebd74d512a57015ed53c966ca714c7545d43160412c8aca9e954180333c6ecce81df8c4b51
diff --git a/app-crypt/minisign/minisign-0.10.ebuild b/app-crypt/minisign/minisign-0.10.ebuild
new file mode 100644
index 000000000000..154ff1cfe795
--- /dev/null
+++ b/app-crypt/minisign/minisign-0.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Dead simple tool to sign files and verify signatures"
+HOMEPAGE="https://github.com/jedisct1/minisign"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
+else
+ SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/libsodium:=[-minimal]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_STRIP=OFF )
+ cmake_src_configure
+}
diff --git a/app-crypt/minisign/minisign-9999.ebuild b/app-crypt/minisign/minisign-9999.ebuild
index 6b1c1c8ca147..154ff1cfe795 100644
--- a/app-crypt/minisign/minisign-9999.ebuild
+++ b/app-crypt/minisign/minisign-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
@@ -13,7 +13,7 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/jedisct1/${PN}.git"
else
SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
LICENSE="ISC"
@@ -21,10 +21,11 @@ SLOT="0"
IUSE=""
-DEPEND=">=dev-libs/libsodium-1.0.16:=[-minimal]"
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/libsodium:=[-minimal]"
RDEPEND="${DEPEND}"
src_configure() {
- local mycmakeargs=( -DCMAKE_STRIP="${EPREFIX}/bin/true" )
+ local mycmakeargs=( -DCMAKE_STRIP=OFF )
cmake_src_configure
}