summaryrefslogtreecommitdiff
path: root/app-crypt/md6sum/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/md6sum/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/md6sum/files')
-rw-r--r--app-crypt/md6sum/files/md6sum-1.0-cflags.patch27
-rw-r--r--app-crypt/md6sum/files/md6sum-1.0-format-security.patch26
-rw-r--r--app-crypt/md6sum/files/md6sum-1.0-ldflags.patch12
3 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/md6sum/files/md6sum-1.0-cflags.patch b/app-crypt/md6sum/files/md6sum-1.0-cflags.patch
new file mode 100644
index 000000000000..b0bf8f01a327
--- /dev/null
+++ b/app-crypt/md6sum/files/md6sum-1.0-cflags.patch
@@ -0,0 +1,27 @@
+--- a/Makefile.in 2012-11-07 22:04:51.207982344 -0500
++++ b/Makefile.in 2012-11-07 22:06:00.905977580 -0500
+@@ -18,19 +18,19 @@
+ all: md6sum
+
+ md6sum: $(OBJS)
+- $(CC) $(OBJS) $(CXXFLAGS) $(LDFLAGS) -o $@
++ $(CC) $(OBJS) $(CFLAGS) $(LDFLAGS) -o $@
+
+ md6_compress.o: md6_compress.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ md6_mode.o: md6_mode.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ md6_nist.o: md6_nist.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ md6sum.o: md6sum.c inttypes.h md6.h md6_nist.h stdint.h
+- $(CC) $(CXXFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) -c $< -o $@
+
+ clean:
+ rm *.o
diff --git a/app-crypt/md6sum/files/md6sum-1.0-format-security.patch b/app-crypt/md6sum/files/md6sum-1.0-format-security.patch
new file mode 100644
index 000000000000..061ec7b5f1b4
--- /dev/null
+++ b/app-crypt/md6sum/files/md6sum-1.0-format-security.patch
@@ -0,0 +1,26 @@
+From 95833e409336bd0a4a656b7e2d0a9598dfe3f546 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 30 Aug 2014 21:25:23 +0300
+Subject: [PATCH] build: fix warning of format-security
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ md6sum.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/md6sum.c b/md6sum.c
+index 2401a5a..0338d30 100644
+--- a/md6sum.c
++++ b/md6sum.c
+@@ -428,7 +428,7 @@ void optd(char *optstr)
+
+ void opth()
+ { /* print md6sum help string */
+- printf(help_string);
++ printf("%s", help_string);
+ }
+
+ void optK(char *optstr)
+--
+1.8.5.5
+
diff --git a/app-crypt/md6sum/files/md6sum-1.0-ldflags.patch b/app-crypt/md6sum/files/md6sum-1.0-ldflags.patch
new file mode 100644
index 000000000000..23d37e192ea3
--- /dev/null
+++ b/app-crypt/md6sum/files/md6sum-1.0-ldflags.patch
@@ -0,0 +1,12 @@
+diff -Nru md6sum-1.0.orig/Makefile.in md6sum-1.0/Makefile.in
+--- md6sum-1.0.orig/Makefile.in 2011-01-09 02:12:09.000000000 +0000
++++ md6sum-1.0/Makefile.in 2011-02-01 04:41:35.000000000 +0000
+@@ -18,7 +18,7 @@
+ all: md6sum
+
+ md6sum: $(OBJS)
+- $(CC) $(OBJS) $(CXXFLAGS) -o $@
++ $(CC) $(OBJS) $(CXXFLAGS) $(LDFLAGS) -o $@
+
+ md6_compress.o: md6_compress.c inttypes.h md6.h md6_nist.h stdint.h
+ $(CC) $(CXXFLAGS) -c $< -o $@