summaryrefslogtreecommitdiff
path: root/app-crypt/libu2f-host
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/libu2f-host
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/libu2f-host')
-rw-r--r--app-crypt/libu2f-host/Manifest5
-rw-r--r--app-crypt/libu2f-host/libu2f-host-1.1.1.ebuild63
-rw-r--r--app-crypt/libu2f-host/libu2f-host-1.1.3.ebuild57
-rw-r--r--app-crypt/libu2f-host/metadata.xml18
4 files changed, 143 insertions, 0 deletions
diff --git a/app-crypt/libu2f-host/Manifest b/app-crypt/libu2f-host/Manifest
new file mode 100644
index 000000000000..f3724d79b5c5
--- /dev/null
+++ b/app-crypt/libu2f-host/Manifest
@@ -0,0 +1,5 @@
+DIST libu2f-host-1.1.1.tar.xz 455652 BLAKE2B f5cc4dd7752d66790b4139e5b8e9262f6622b9608bc8b220640db773ce1e794b58eb3fdf855df4e73417aabf5f8e979218dfd1b068111c66c6d830ef4b7ebb97 SHA512 1f6d26d47cabd44391a780f03d88b6ab9ed996bab26e2605f1942bfff2203aa9a8e90fa80c010ccf2e575dbfca3bd03d3322381343cdf6def3829bbe45db8693
+DIST libu2f-host-1.1.3.tar.xz 469480 BLAKE2B b2a002fa694972e71aef73191608d079f1c13d98a2f40e06d25a6e50a3175100099adbc5b5067e5f1fe027042f99e198a07282df735ab4ff2eec63a4f5daf59a SHA512 6729dd35beaae1c96283f81794ac6c058ed6446f935a5cee7dc1a3db594201c9f049de6a58ac2e544e1c6ac0c1e9815cce5e2e46a6e45372e419078307a57f55
+EBUILD libu2f-host-1.1.1.ebuild 1298 BLAKE2B 3eb0abee39181c3aea3cf63bbc59655732a0b8ec28bbc7260694e25f545749fcf0d7bd20aff6f7a3575d56d52c7ae8094dc7954ac76c5f9921ebd21a5a376248 SHA512 c5422305f55e948d20c2b954710b97a61a6b3e8ce48dca1950967c2a6c02e6d63b0530ab427fa5c48a90802544b4b13dcee8ccb88c9e1df814549219db1bed1f
+EBUILD libu2f-host-1.1.3.ebuild 1186 BLAKE2B 20a64efdf2fdb0e43778a726abaa6c57cb5dbe48063457f7a94592e75f033e60ff0f3b157b5f1057fbc372329b43939ee663d95509ccedf22ffa04ab2d06cc54 SHA512 5a32629523690898a179f86b92c472e8b84d45db95cc2541e988cfc7901c3d85ec82261c0eaf3f4756a47b0c3a1830c39af445a8a1beb616c183dd900e712bed
+MISC metadata.xml 550 BLAKE2B 992fdc0643bed1c1122b544947535745a7209552387c3e6917942eee04cd33bd613f78f5e447099493b56e133d88095d958a8816f1b1ba65d34944ddb3210eea SHA512 9970724fffe49705d8dedc85522cbe3040c4e542fa5a56c2cbc428df2540975e76a84fe8c4819bfaacc085cccdf6e5a996a058c14f561b9ef10c7d705f98bfa0
diff --git a/app-crypt/libu2f-host/libu2f-host-1.1.1.ebuild b/app-crypt/libu2f-host/libu2f-host-1.1.1.ebuild
new file mode 100644
index 000000000000..6d1773945177
--- /dev/null
+++ b/app-crypt/libu2f-host/libu2f-host-1.1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils linux-info udev user
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-host/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kernel_linux static-libs systemd"
+
+RDEPEND="
+ dev-libs/hidapi
+ dev-libs/json-c:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ systemd? ( sys-apps/systemd[acl] )"
+
+CONFIG_CHECK="~HIDRAW"
+
+pkg_setup() {
+ # The U2F device node will be owned by group 'plugdev'
+ # in non-systemd configurations
+ if ! use systemd; then
+ enewgroup plugdev
+ fi
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+
+ sed -e 's:TAG+="uaccess":MODE="0664", GROUP="plugdev":g' \
+ 70-u2f.rules > 70-u2f-udev.rules || die
+}
+
+src_configure() {
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use kernel_linux; then
+ if use systemd; then
+ udev_dorules 70-u2f.rules
+ else
+ udev_newrules 70-u2f-udev.rules 70-u2f.rules
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if ! use systemd; then
+ elog "Users must be a member of the 'plugdev' group"
+ elog "to be able to access U2F devices"
+ fi
+}
diff --git a/app-crypt/libu2f-host/libu2f-host-1.1.3.ebuild b/app-crypt/libu2f-host/libu2f-host-1.1.3.ebuild
new file mode 100644
index 000000000000..129a3f8c98c1
--- /dev/null
+++ b/app-crypt/libu2f-host/libu2f-host-1.1.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info udev user
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-host/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="kernel_linux static-libs systemd"
+
+RDEPEND="
+ dev-libs/hidapi
+ dev-libs/json-c:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ systemd? ( sys-apps/systemd[acl] )"
+
+CONFIG_CHECK="~HIDRAW"
+
+pkg_setup() {
+ # The U2F device node will be owned by group 'plugdev'
+ # in non-systemd configurations
+ if ! use systemd; then
+ enewgroup plugdev
+ fi
+}
+
+src_prepare() {
+ default
+ sed -e 's:TAG+="uaccess":MODE="0664", GROUP="plugdev":g' \
+ 70-u2f.rules > 70-u2f-udev.rules || die
+}
+
+src_install() {
+ default
+ if use kernel_linux; then
+ if use systemd; then
+ udev_dorules 70-u2f.rules
+ else
+ udev_newrules 70-u2f-udev.rules 70-u2f.rules
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if ! use systemd; then
+ elog "Users must be a member of the 'plugdev' group"
+ elog "to be able to access U2F devices"
+ fi
+}
diff --git a/app-crypt/libu2f-host/metadata.xml b/app-crypt/libu2f-host/metadata.xml
new file mode 100644
index 000000000000..e15cf03356a6
--- /dev/null
+++ b/app-crypt/libu2f-host/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <use>
+ <flag name="systemd">
+ Use user ACLs rather than plugdev group to give user access to the HIDRAW
+ device.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Yubico/libu2f-host</remote-id>
+ <bugs-to>https://github.com/Yubico/libu2f-host/issues</bugs-to>
+ </upstream>
+</pkgmetadata>