summaryrefslogtreecommitdiff
path: root/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild')
-rw-r--r--app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild b/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
index 6797a6c93d08..104c7ec0ef0d 100644
--- a/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
+++ b/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-info udev
+inherit linux-info udev user
DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
HOMEPAGE="https://developers.yubico.com/libu2f-host/"
@@ -16,15 +16,20 @@ IUSE="kernel_linux static-libs systemd"
DEPEND="dev-libs/hidapi
dev-libs/json-c:="
-# The U2F device node will be owned by group 'plugdev'
-# in non-systemd configurations
RDEPEND="${DEPEND}
- !systemd? ( acct-group/plugdev )
systemd? ( sys-apps/systemd[acl] )"
BDEPEND="virtual/pkgconfig"
CONFIG_CHECK="~HIDRAW"
+pkg_setup() {
+ # The U2F device node will be owned by group 'plugdev'
+ # in non-systemd configurations
+ if ! use systemd; then
+ enewgroup plugdev
+ fi
+}
+
src_install() {
default
if use kernel_linux; then