summaryrefslogtreecommitdiff
path: root/app-crypt/libsecret
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/libsecret
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/libsecret')
-rw-r--r--app-crypt/libsecret/Manifest6
-rw-r--r--app-crypt/libsecret/libsecret-0.18.5.ebuild67
-rw-r--r--app-crypt/libsecret/libsecret-0.18.6-r1.ebuild94
-rw-r--r--app-crypt/libsecret/libsecret-0.18.6.ebuild81
-rw-r--r--app-crypt/libsecret/metadata.xml8
5 files changed, 256 insertions, 0 deletions
diff --git a/app-crypt/libsecret/Manifest b/app-crypt/libsecret/Manifest
new file mode 100644
index 000000000000..05ec65f2b70d
--- /dev/null
+++ b/app-crypt/libsecret/Manifest
@@ -0,0 +1,6 @@
+DIST libsecret-0.18.5.tar.xz 508556 BLAKE2B e3410dd113dfa1f4ebb78a47f90e23455eb8f82466d4607aa469c04adc84aa3181bfdb7dcb4ff459fd2aa49c315ffd52fd2d3a4929694909fe65af637b65482b SHA512 4ee297b556d3b555b6ca9f5eb5cc87425b782491d0550a75873aac0f7019b123f437f0731c85bb058fc65b50a589d54d0697657a50bef4ac2952e9e40a916b5c
+DIST libsecret-0.18.6.tar.xz 487836 BLAKE2B d38a41743142d33e634d77bbf55ccab044def9658b3f50bd3f8cec9be6372ad1a56dcc4de58126cba1246c16da2863c003bf14ea6c8a90d8667658cf492f4b9a SHA512 4997519762f1470cfc0a4b3a791362d030af3c9b6ce6f58f8f8073b3a8adeea9b8caacedc884163997081dc39f395f9172330dbb41fed45d6c43ac5809de48e3
+EBUILD libsecret-0.18.5.ebuild 1587 BLAKE2B 5bc76ca976d6fb5747df1fc877a66789b2260322b40e4a0c01e125d35423f813d84964f0cd7e8ce24eca3a009d3071660037a5c40de1364f343bcb06272761fb SHA512 2b8a057d68fae082f3485e20f1e2c868842d23d2ea49b4e42f3e67d2a684581e517b6d9b4d9daa0a25799f560ce276feff6cdec064082ce38f3d364f7c32ec74
+EBUILD libsecret-0.18.6-r1.ebuild 2667 BLAKE2B ce87c3edccd6b4dc544581e35a8d4585f7307b874a3877d6b0eb0ab4d24219ebfb542138b2bb9af5a2344199a9cfd00aafba0c8b911be1b79af6334b7b7ca9e2 SHA512 0a2387d37fe23e652ed514fa01e7821fbe2be3d70fef1c4437b19965cfcb777fc0fd4d883198aec6bfb02ee1b2a25b0744932e2b389cc097274c37d6d2e0e32a
+EBUILD libsecret-0.18.6.ebuild 2117 BLAKE2B a84646e1f775dd6a3e4d2bc3bbb06a9e4a63cd363b71ddfc43feb46967486fe37dd322acd5f767d86f5e68bf2cce97a21d5bdbfb1f13b383ce59e3672fa4ff5a SHA512 9e6e9f150f3e2d8077f50c2bebf807f6785d3ca8ac230c71582521b817469cfb3b86ef71bdad14bea17896d6ef372dbe68672e63deca8be9c40ba980b3b8742a
+MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/app-crypt/libsecret/libsecret-0.18.5.ebuild b/app-crypt/libsecret/libsecret-0.18.5.ebuild
new file mode 100644
index 000000000000..aed7f8ac1079
--- /dev/null
+++ b/app-crypt/libsecret/libsecret-0.18.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+VALA_USE_DEPEND=vapigen
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libsecret"
+
+LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
+SLOT="0"
+
+IUSE="+crypt +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ crypt? ( >=dev-libs/libgcrypt-1.2.2:0= )
+ introspection? ( >=dev-libs/gobject-introspection-1.29:= )
+"
+PDEPEND=">=gnome-base/gnome-keyring-3
+"
+# PDEPEND to avoid circular dep (bug #547456)
+# gnome-keyring needed at runtime as explained at https://bugs.gentoo.org/475182#c2
+# Add ksecrets to PDEPEND when it's added to portage
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-python/mock
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gjs-1.32
+ dev-python/pygobject:3 )
+ )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-manpages \
+ --disable-strict \
+ --disable-coverage \
+ --disable-static \
+ $(use_enable crypt gcrypt) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild b/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild
new file mode 100644
index 000000000000..a28beccceb86
--- /dev/null
+++ b/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+VALA_USE_DEPEND=vapigen
+
+inherit gnome2 multilib-minimal python-any-r1 vala virtualx
+
+DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libsecret"
+
+LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
+SLOT="0"
+
+IUSE="+crypt +introspection test vala"
+# Tests fail with USE=-introspection, https://bugs.gentoo.org/655482
+REQUIRED_USE="test? ( introspection )
+ vala? ( introspection )"
+
+KEYWORDS="~alpha amd64 ~arm ~arm64 ia64 ~mips ~ppc ~ppc64 sparc x86 ~amd64-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.2.2:0=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.29:= )
+"
+PDEPEND=">=gnome-base/gnome-keyring-3
+"
+# PDEPEND to avoid circular dep (bug #547456)
+# gnome-keyring needed at runtime as explained at https://bugs.gentoo.org/475182#c2
+# Add ksecrets to PDEPEND when it's added to portage
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? (
+ $(python_gen_any_dep '
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ introspection? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )')
+ introspection? ( >=dev-libs/gjs-1.32 )
+ )
+ vala? ( $(vala_depend) )
+"
+
+python_check_deps() {
+ if use introspection; then
+ has_version --host-root "dev-python/pygobject:3[${PYTHON_USEDEP}]" || return
+ fi
+ has_version --host-root "dev-python/mock[${PYTHON_USEDEP}]" &&
+ has_version --host-root "dev-python/dbus-python[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+
+ # Drop unwanted CFLAGS modifications
+ sed -e 's/CFLAGS="$CFLAGS -\(g\|O0\|O2\)"//' -i configure || die
+}
+
+multilib_src_configure() {
+ local ECONF_SOURCE=${S}
+ gnome2_src_configure \
+ --enable-manpages \
+ --disable-strict \
+ --disable-coverage \
+ --disable-static \
+ $(use_enable crypt gcrypt) \
+ $(multilib_native_use_enable introspection) \
+ $(multilib_native_use_enable vala) \
+ LIBGCRYPT_CONFIG="${EPREFIX}/usr/bin/${CHOST}-libgcrypt-config"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/reference/libsecret/html docs/reference/libsecret/html || die
+ fi
+}
+
+multilib_src_test() {
+ # tests fail without gobject-introspection
+ multilib_is_native_abi && virtx emake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/app-crypt/libsecret/libsecret-0.18.6.ebuild b/app-crypt/libsecret/libsecret-0.18.6.ebuild
new file mode 100644
index 000000000000..5337020694d9
--- /dev/null
+++ b/app-crypt/libsecret/libsecret-0.18.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python3_{4,5,6} )
+VALA_USE_DEPEND=vapigen
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libsecret"
+
+LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
+SLOT="0"
+
+IUSE="+crypt +introspection test vala"
+# Tests fail with USE=-introspection, https://bugs.gentoo.org/655482
+REQUIRED_USE="test? ( introspection )
+ vala? ( introspection )"
+
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ~ppc ppc64 ~sparc x86 ~amd64-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ crypt? ( >=dev-libs/libgcrypt-1.2.2:0= )
+ introspection? ( >=dev-libs/gobject-introspection-1.29:= )
+"
+PDEPEND=">=gnome-base/gnome-keyring-3
+"
+# PDEPEND to avoid circular dep (bug #547456)
+# gnome-keyring needed at runtime as explained at https://bugs.gentoo.org/475182#c2
+# Add ksecrets to PDEPEND when it's added to portage
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep '
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ introspection? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )')
+ introspection? ( >=dev-libs/gjs-1.32 )
+ )
+ vala? ( $(vala_depend) )
+"
+
+python_check_deps() {
+ if use introspection; then
+ has_version --host-root "dev-python/pygobject:3[${PYTHON_USEDEP}]" || return
+ fi
+ has_version --host-root "dev-python/mock[${PYTHON_USEDEP}]" &&
+ has_version --host-root "dev-python/dbus-python[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-manpages \
+ --disable-strict \
+ --disable-coverage \
+ --disable-static \
+ $(use_enable crypt gcrypt) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/app-crypt/libsecret/metadata.xml b/app-crypt/libsecret/metadata.xml
new file mode 100644
index 000000000000..996e7cacd217
--- /dev/null
+++ b/app-crypt/libsecret/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>