summaryrefslogtreecommitdiff
path: root/app-crypt/libsecret
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /app-crypt/libsecret
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'app-crypt/libsecret')
-rw-r--r--app-crypt/libsecret/Manifest1
-rw-r--r--app-crypt/libsecret/libsecret-0.20.4-r1.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-crypt/libsecret/Manifest b/app-crypt/libsecret/Manifest
index 8a72ed75790a..d712c41642bb 100644
--- a/app-crypt/libsecret/Manifest
+++ b/app-crypt/libsecret/Manifest
@@ -1,4 +1,5 @@
AUX libsecret-0.20.4-meson-build-test-vala-unstable-with-DSECRET_WITH_UNS.patch 1316 BLAKE2B 0c0fb8c10d869ff98d0644067336e54f907904ed8c4899e58e5d65aa84406442a550a6d4d6939cc34d5f6a80ec5d1d96dc7dcc91e44e955a8eef9b272f2fef6f SHA512 e2e4474a2af3e6f8a5bde2eff58417991b3d85f3042fe77776815f86567094168ca01c25f101cbc82a5f66573b1bc4592e6dee6b1be082fb8ec612c1394a7ce9
DIST libsecret-0.20.4.tar.xz 529916 BLAKE2B d5922dcb1eb27e4cc6bc7770926fc3191c9f4634867ff9682fd33f9373d6fa2d334c9c1b995bd208bbf178af008ec7b224bd5388427617fbd7e48d05d2e35823 SHA512 599482796af001703c25d181a710c5a3207f44d4d0036ef2001cc541bde9ef453172b71df9bb214d27d1fbd2f28c1b5a5efdbd5faca3561188c07dccdc7d7c15
+EBUILD libsecret-0.20.4-r1.ebuild 2233 BLAKE2B ac39a86615aba133bea293e5bac5a5223f36f3e740e3b1ac607891030bc30ac6c99821dbd223f5ccde8890368a6659de6fc6e48a5224d7612b4a7d8eff64fec0 SHA512 f8107bc02a30aac063b459b2e3e6b5d8fe1be8707049e56f48ffbca5dad83f9c3edd9443b279c63abd1474edf6cdbd32adf82b885ee94f7845255e9ce964f29b
EBUILD libsecret-0.20.4.ebuild 2363 BLAKE2B b4682220dfa37898f0473580c554a547ab56b914287aea325f7ba2c7c96dfeff340be2173466706a9f6468d1dedf6d71e056567d8ce00f90b318447df99e6570 SHA512 c54fa657adae23150022ec1d8c117425eac1114656d76dd7201236f6ef4468d53008e8d7b04c06ff5ddcac6cda93ebfbecd1955ecaf7c5750f98ceccef053181
MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/app-crypt/libsecret/libsecret-0.20.4-r1.ebuild b/app-crypt/libsecret/libsecret-0.20.4-r1.ebuild
new file mode 100644
index 000000000000..e43ef9d0b726
--- /dev/null
+++ b/app-crypt/libsecret/libsecret-0.20.4-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+VALA_USE_DEPEND=vapigen
+
+inherit gnome2 meson-multilib python-any-r1 vala virtualx
+
+DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libsecret"
+
+LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
+SLOT="0"
+
+IUSE="+crypt gtk-doc +introspection test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ vala? ( introspection )
+ gtk-doc? ( crypt )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.2.2:0=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.29:= )
+"
+RDEPEND="${DEPEND}
+ virtual/secret-service"
+BDEPEND="
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep '
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ introspection? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )')
+ introspection? ( >=dev-libs/gjs-1.32 )
+ )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-meson-build-test-vala-unstable-with-DSECRET_WITH_UNS.patch
+)
+
+python_check_deps() {
+ if use introspection; then
+ has_version -b "dev-python/pygobject:3[${PYTHON_USEDEP}]" || return
+ fi
+ has_version -b "dev-python/mock[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/dbus-python[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ default
+
+ # Remove @filename@ from the header template that would otherwise cause
+ # differences dependent on the ABI
+ sed -e '/enumerations from "@filename@"/d' \
+ -i libsecret/secret-enum-types.h.template || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_use crypt gcrypt)
+
+ # Don't build docs multiple times
+ $(meson_native_true manpage)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+
+ $(meson_native_use_bool introspection)
+ $(meson_native_use_bool vala vapi)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}