summaryrefslogtreecommitdiff
path: root/app-crypt/libsecret
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-17 22:49:47 +0100
commit30c53e395853f5bfe805a1e429fcf26666eed8f8 (patch)
treea0670eaf9babda7b83503f7d36806a944bb49752 /app-crypt/libsecret
parentd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (diff)
gentoo resync : 17.05.2018
Diffstat (limited to 'app-crypt/libsecret')
-rw-r--r--app-crypt/libsecret/Manifest3
-rw-r--r--app-crypt/libsecret/libsecret-0.18.6-r1.ebuild94
-rw-r--r--app-crypt/libsecret/libsecret-0.18.6.ebuild4
3 files changed, 99 insertions, 2 deletions
diff --git a/app-crypt/libsecret/Manifest b/app-crypt/libsecret/Manifest
index 438c6e49ec34..2fbe4cfaa2d5 100644
--- a/app-crypt/libsecret/Manifest
+++ b/app-crypt/libsecret/Manifest
@@ -1,5 +1,6 @@
DIST libsecret-0.18.5.tar.xz 508556 BLAKE2B e3410dd113dfa1f4ebb78a47f90e23455eb8f82466d4607aa469c04adc84aa3181bfdb7dcb4ff459fd2aa49c315ffd52fd2d3a4929694909fe65af637b65482b SHA512 4ee297b556d3b555b6ca9f5eb5cc87425b782491d0550a75873aac0f7019b123f437f0731c85bb058fc65b50a589d54d0697657a50bef4ac2952e9e40a916b5c
DIST libsecret-0.18.6.tar.xz 487836 BLAKE2B d38a41743142d33e634d77bbf55ccab044def9658b3f50bd3f8cec9be6372ad1a56dcc4de58126cba1246c16da2863c003bf14ea6c8a90d8667658cf492f4b9a SHA512 4997519762f1470cfc0a4b3a791362d030af3c9b6ce6f58f8f8073b3a8adeea9b8caacedc884163997081dc39f395f9172330dbb41fed45d6c43ac5809de48e3
EBUILD libsecret-0.18.5.ebuild 1587 BLAKE2B 5bc76ca976d6fb5747df1fc877a66789b2260322b40e4a0c01e125d35423f813d84964f0cd7e8ce24eca3a009d3071660037a5c40de1364f343bcb06272761fb SHA512 2b8a057d68fae082f3485e20f1e2c868842d23d2ea49b4e42f3e67d2a684581e517b6d9b4d9daa0a25799f560ce276feff6cdec064082ce38f3d364f7c32ec74
-EBUILD libsecret-0.18.6.ebuild 2024 BLAKE2B e897dc5c03427a02a5520366cf2ec5a41d95396e218b5d793cc806400924bfb99a614737ba9450d444c89549d3293a4a3504eafc3467fb77c3261e28112f1cda SHA512 c648fb7da4cdd789f01c18d8289a4b79888a326c352b3242606788038fd51054cae03f4e03e39a8cded1f87beb64d9792abf1a72dcae1153ffbebad722741163
+EBUILD libsecret-0.18.6-r1.ebuild 2671 BLAKE2B d7a95fd30b35cb755b1459c0a01a743d39fcaa4e274cd90dfe88c3325e843ceb99bfbc3a5316f15fde241f7aa838c051fbb89c3c7c48a5b104ac18a6a027afee SHA512 9d17bb7fca1525a6037cc7251d822b23bcbbf3bdfd376d0b97f25c5925a92dd933fc9c676fb4fbce1a003c9e77645c76e155d8f845a597e0fd39bebc323324ad
+EBUILD libsecret-0.18.6.ebuild 2118 BLAKE2B 176a2449d4288c71d0e22caa82a9ea3ae1f33ad06154fa0aeba35d5d30fd6500401df2f3815b53e040feb54900220c3e46b7ae936e44f5a9c614309c152273d0 SHA512 b67859bdc619a3e72ece33e3d0258b1a1df33eb15ea09c2a890e0683c4b99af1d098ece8adbfac60b225055f81ce3db927dff927cbcb667671784e1c685d15a6
MISC metadata.xml 253 BLAKE2B a1efbd3751efaa83ee173f557ec1c8a4497a90b60896cf5a7a07da40b4f94a7a299ca0385477e82b2f5e5dbdf9afa482ccbe21f35ef44214e9c451d764b65529 SHA512 8d59f413993268ca783f7407b676900bb2d964754bf705d4175e2bafbe058a52af74f3928e4bd84d292518f8cf13fab7051486ab7cdc61d02fae6e0188d44442
diff --git a/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild b/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild
new file mode 100644
index 000000000000..fc25bbf62d16
--- /dev/null
+++ b/app-crypt/libsecret/libsecret-0.18.6-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+VALA_USE_DEPEND=vapigen
+
+inherit gnome2 multilib-minimal python-any-r1 vala virtualx
+
+DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libsecret"
+
+LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
+SLOT="0"
+
+IUSE="+crypt +introspection test vala"
+# Tests fail with USE=-introspection, https://bugs.gentoo.org/655482
+REQUIRED_USE="test? ( introspection )
+ vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.2.2:0=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.29:= )
+"
+PDEPEND=">=gnome-base/gnome-keyring-3
+"
+# PDEPEND to avoid circular dep (bug #547456)
+# gnome-keyring needed at runtime as explained at https://bugs.gentoo.org/475182#c2
+# Add ksecrets to PDEPEND when it's added to portage
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? (
+ $(python_gen_any_dep '
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ introspection? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )')
+ introspection? ( >=dev-libs/gjs-1.32 )
+ )
+ vala? ( $(vala_depend) )
+"
+
+python_check_deps() {
+ if use introspection; then
+ has_version --host-root "dev-python/pygobject:3[${PYTHON_USEDEP}]" || return
+ fi
+ has_version --host-root "dev-python/mock[${PYTHON_USEDEP}]" &&
+ has_version --host-root "dev-python/dbus-python[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+
+ # Drop unwanted CFLAGS modifications
+ sed -e 's/CFLAGS="$CFLAGS -\(g\|O0\|O2\)"//' -i configure || die
+}
+
+multilib_src_configure() {
+ local ECONF_SOURCE=${S}
+ gnome2_src_configure \
+ --enable-manpages \
+ --disable-strict \
+ --disable-coverage \
+ --disable-static \
+ $(use_enable crypt gcrypt) \
+ $(multilib_native_use_enable introspection) \
+ $(multilib_native_use_enable vala) \
+ LIBGCRYPT_CONFIG="${EPREFIX}/usr/bin/${CHOST}-libgcrypt-config"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/reference/libsecret/html docs/reference/libsecret/html || die
+ fi
+}
+
+multilib_src_test() {
+ # tests fail without gobject-introspection
+ multilib_is_native_abi && virtx emake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
diff --git a/app-crypt/libsecret/libsecret-0.18.6.ebuild b/app-crypt/libsecret/libsecret-0.18.6.ebuild
index 3574cf376218..bb2a01f9ac06 100644
--- a/app-crypt/libsecret/libsecret-0.18.6.ebuild
+++ b/app-crypt/libsecret/libsecret-0.18.6.ebuild
@@ -15,7 +15,9 @@ LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
SLOT="0"
IUSE="+crypt +introspection test vala"
-REQUIRED_USE="vala? ( introspection )"
+# Tests fail with USE=-introspection, https://bugs.gentoo.org/655482
+REQUIRED_USE="test? ( introspection )
+ vala? ( introspection )"
KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd"