summaryrefslogtreecommitdiff
path: root/app-crypt/libnitrokey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /app-crypt/libnitrokey
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'app-crypt/libnitrokey')
-rw-r--r--app-crypt/libnitrokey/Manifest2
-rw-r--r--app-crypt/libnitrokey/libnitrokey-9999.ebuild50
-rw-r--r--app-crypt/libnitrokey/metadata.xml12
3 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/libnitrokey/Manifest b/app-crypt/libnitrokey/Manifest
new file mode 100644
index 000000000000..60277f0dbbee
--- /dev/null
+++ b/app-crypt/libnitrokey/Manifest
@@ -0,0 +1,2 @@
+EBUILD libnitrokey-9999.ebuild 1145 BLAKE2B 01a32d7b4498ede0e645ed6747e5d2901bacfe8602d598be4b92ff7952597f430b4b68123d60d8dc4277af4bba88b3598e0dd52fe645862d0b470ef0c9c4fc74 SHA512 bd3ddfb326baf091cdd4062819e2cc5635c4aaeb1f4b9436465f89e1cbb58289ca9ca061a6c938ef711604879dbcdb32e475d22184f5480b0c42b67bc1499fb1
+MISC metadata.xml 397 BLAKE2B ec7996ade24566ed79175f047e18c18a7c51e3946c65c4b3cd986d3fe6372ed2a79ca13b6e2d0a21b5e907a2f8e27e7061ad9ce893ffbd93ead06c8814f4d00c SHA512 457d69deef3f3bcca1ac0b0a15d20ca03bf012523a03c311c5be065ad50a43ef5d7e0d7fb949a6a63f3198c35313d83e0e7a8ef882c1095234f93a2dd8be416e
diff --git a/app-crypt/libnitrokey/libnitrokey-9999.ebuild b/app-crypt/libnitrokey/libnitrokey-9999.ebuild
new file mode 100644
index 000000000000..32cf1940ee3a
--- /dev/null
+++ b/app-crypt/libnitrokey/libnitrokey-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils udev
+
+DESCRIPTION="Support library for the Nitrokey"
+HOMEPAGE="https://github.com/Nitrokey/libnitrokey"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nitrokey/libnitrokey.git"
+
+ # Disable pulling in bundled dependencies
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/hidapi:=
+ virtual/udev"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-cpp/catch-2.2.0 )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)"/rules.d
+ -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
+ -DBUILD_SHARED_LIBS=ON
+
+ # actual hardware tests
+ # 1. require a connected Nitrokey
+ # 2. may kill data on your Nitrokey
+ # hence the main testsuite is disabled
+ -DCOMPILE_TESTS=OFF
+ -DCOMPILE_OFFLINE_TESTS=$(usex test)
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-crypt/libnitrokey/metadata.xml b/app-crypt/libnitrokey/metadata.xml
new file mode 100644
index 000000000000..bea0c015c764
--- /dev/null
+++ b/app-crypt/libnitrokey/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ <name>David Seifert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Nitrokey/libnitrokey</remote-id>
+ <bugs-to>https://github.com/Nitrokey/libnitrokey/issues</bugs-to>
+ </upstream>
+</pkgmetadata>