summaryrefslogtreecommitdiff
path: root/app-crypt/libmd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /app-crypt/libmd
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'app-crypt/libmd')
-rw-r--r--app-crypt/libmd/Manifest3
-rw-r--r--app-crypt/libmd/libmd-1.0.3-r1.ebuild23
-rw-r--r--app-crypt/libmd/libmd-9999.ebuild14
3 files changed, 31 insertions, 9 deletions
diff --git a/app-crypt/libmd/Manifest b/app-crypt/libmd/Manifest
index c04accb5a12a..fd066b87f712 100644
--- a/app-crypt/libmd/Manifest
+++ b/app-crypt/libmd/Manifest
@@ -1,4 +1,5 @@
DIST libmd-1.0.3.tar.xz 258584 BLAKE2B 35b732800a4b0a7b8d0a88eeff5e7e80fe55ab5ed05b7a7a1ffe866e156cc6dc6daca95f865a56297857b10b1bdfc9815b5bf0b198e8284f217498265c08fcc9 SHA512 f4b5a86bea7b9fac9f7f173032ee436d1e7141f760c1a114a785d31644edbf6802fe8193cc4cf3b5c66d38963be919c05055780bdf6bf5a47927690490ff5966
+EBUILD libmd-1.0.3-r1.ebuild 623 BLAKE2B 4dda188f2893c042a22b6bca8112380ffc1cc601dda51b9f5b4fd49b693cc6f0ff6033c05444cb64c42a08c061f49e1b0cb13d34781dad0e0c7ab978b428feec SHA512 ca0cc1694628f2e3d157f970496b7f3ed856e328cc93841d59e494b16a613beeadaf44c85c4f93022993ce26ad1cfec62685a31dc3d77d2613de8ae7de786d82
EBUILD libmd-1.0.3.ebuild 563 BLAKE2B 0a43166defe23d160046741dd6811ccb897b4a27453c141dd854ce93b7134dc111bb0db9d4ab85592c0fc78e398fdf74dde2598e11092998a87f5557c033dcac SHA512 0b7b49b623b67ad57ef8f4eba25982f70eef5b378b03612a8cd4d9fdd566e1f618e81eb78ca06d010e7101bfdccbdf543bccaf460fc13149cd72f6aeb3e54ef7
-EBUILD libmd-9999.ebuild 523 BLAKE2B e512f27bd0203585b0e2f3eb11c6b38ea853949bdd5dfca7b2f744650b11a18994089bd847fd6a73c5a909ad7f7a9043c2421abaa811a7cf83ea9e4b5ba3ebad SHA512 0ff23822acfdf09f4ce1fa90184c64b58154fc0ab9d713424d32b120bc2670d63865b3be9c831c34c45a5afa308db9c5f5dc12753e9a4a7ff47b14d28eb0fe14
+EBUILD libmd-9999.ebuild 567 BLAKE2B c31c8d0780cd63516fae57497f80340712547fe78d17e16ad8d1c1f7320681ef914d0ffefc459593b2de6e0db054860296c72060bea33a4ef47de42dc3da8a14 SHA512 82345337a69a40c8f7199a3be295b18e530be415c712af1259b4e110f7cc80d50705559ad92ce0b7c001c8f6f95ad7d5fae3d09b3ec527a1b860e8577d078ed6
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-crypt/libmd/libmd-1.0.3-r1.ebuild b/app-crypt/libmd/libmd-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..eedd72789dfb
--- /dev/null
+++ b/app-crypt/libmd/libmd-1.0.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/app-crypt/libmd/libmd-9999.ebuild b/app-crypt/libmd/libmd-9999.ebuild
index 7ce508a893c1..b28c93edaff6 100644
--- a/app-crypt/libmd/libmd-9999.ebuild
+++ b/app-crypt/libmd/libmd-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools git-r3
+inherit autotools multilib-minimal git-r3
DESCRIPTION="Message Digest functions from BSD systems"
HOMEPAGE="https://www.hadrons.org/software/libmd/"
@@ -14,16 +14,14 @@ SLOT="0"
src_prepare() {
default
-
eautoreconf
}
-src_configure() {
- econf --disable-static
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
}
-src_install() {
+multilib_src_install() {
default
-
- find "${ED}" -name '*.la' -delete || die
+ find "${ED}" -type f -name "*.la" -delete || die
}