summaryrefslogtreecommitdiff
path: root/app-crypt/libb2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /app-crypt/libb2
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'app-crypt/libb2')
-rw-r--r--app-crypt/libb2/Manifest1
-rw-r--r--app-crypt/libb2/libb2-0.98.1-r2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-crypt/libb2/Manifest b/app-crypt/libb2/Manifest
index f1eec11229a7..ab80407e9500 100644
--- a/app-crypt/libb2/Manifest
+++ b/app-crypt/libb2/Manifest
@@ -1,5 +1,6 @@
DIST libb2-0.98.1.tar.gz 280826 BLAKE2B aa8c3dee3032f457410479be12d00c79a6ca6a7c0376a5c70265d30ff25b50663171f7096141834d4faa4dd5027f38b23b774e59be63475a3ecba855337fb1aa SHA512 a666fdbd1efa9cfff3028e953c62f21ba092c6733ccd12d4d04f1f836fc9747fc90053bc9166510d251d332b91e133853d2cc9b61c279517bd65b05e8483250b
DIST libb2-0.98.tar.gz 275076 BLAKE2B 7c0aa473a58a5ceb6e913487cc6f0078e6cab661bd26cb1f5611473b430213521a23adbde227da6d7561b4d581369e268308ae6b2a10da5399c0d2d6ab288b26 SHA512 be400d16ab00b3006ec7412dcbf580427600f4997cee19c0448d849ff8bbbb58bbb7be3d49e4052cb1b6791b6bed9c9cc48b51da3ec77b2fdf3d197ccf0c8073
EBUILD libb2-0.98.1-r1.ebuild 1744 BLAKE2B b2256260ca7312c87184a92e9b495fb7a7f4fed6353756f3c995c108f71b1abcb9dc304174760a8b624a743c3c39d9e4b275dc50c1daf3bfddfd18d100b0f2cc SHA512 73a90667e0786c443cccc566d43964ad78bfd10cd019f8d3544d2a3842721a58c225d509fedde0b34888da7031e04aabaac5f6311fe3f67ffa6034db646c4f01
+EBUILD libb2-0.98.1-r2.ebuild 1821 BLAKE2B bb078217affdae520fb4b1e57553d5fd65f7642939222193707f3b2501190721d932c86b3e83fa33540d5530c17381dd7ff493b18926670e36fd0abfbaea1012 SHA512 b96a72ee43d840105d72b6582e1c9f9ff71595b783a9011e2860320a224eddb2f283e410fc64f03db3dc1971f850b3d3c87c0c73fa9abec5dc80e28f325f5b15
EBUILD libb2-0.98.ebuild 1015 BLAKE2B 8f6fc70a953aea90fa5dbecd894dd5b1335fe9bf737547f8c2c42ab46cc8b718f0bf1ad941b54820b36ce62829a3d2d4d0de1d6e8c34c90c839d4019781a0765 SHA512 7d1a55ff33988e20ab4588f17dc0a1d982c02ea785e1d9535ff740b923129c5491282191e77d6a8dddcb500bce22626face82b40354fcb4da207a2bdcbbdab2b
MISC metadata.xml 688 BLAKE2B dafb52bda4cb5c27bbbb4cba85c178ce11e9511f0dedfed4ff3afe40789a28e4a8c9c275a1be7e86568419c29011c1a4ae5c67f7b778ece3c750d8a919d5d930 SHA512 a98e96312724a3af5d104e4adbb9f60cac16124c9beac2622045985c1b0c2276ff1d56561d59cfb5a24b57d29577312c7e73bdfe73bbe735c1c320b699065b11
diff --git a/app-crypt/libb2/libb2-0.98.1-r2.ebuild b/app-crypt/libb2/libb2-0.98.1-r2.ebuild
new file mode 100644
index 000000000000..5473f617de93
--- /dev/null
+++ b/app-crypt/libb2/libb2-0.98.1-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal toolchain-funcs
+
+DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
+HOMEPAGE="https://github.com/BLAKE2/libb2"
+GITHASH="73d41c8255a991ed2adea41c108b388d9d14b449"
+SRC_URI="https://github.com/BLAKE2/libb2/archive/${GITHASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs native-cflags openmp"
+
+DEPEND="
+ openmp? (
+ || ( >=sys-devel/gcc-4.2:*[openmp] sys-devel/clang-runtime:*[openmp] )
+ )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-${GITHASH}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use openmp && ! tc-has-openmp; then
+ ewarn "You are using a compiler without OpenMP support"
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_prepare() {
+ default
+ # fix bashism
+ sed -i -e 's/ == / = /' configure.ac || die
+ # https://github.com/BLAKE2/libb2/pull/28
+ echo 'libb2_la_LDFLAGS = -no-undefined' >> src/Makefile.am || die
+ eautoreconf # upstream doesn't make releases
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable native-cflags native) \
+ $(use_enable openmp)
+}
+
+do_make() {
+ # respect our CFLAGS when native-cflags is not in effect
+ local openmp=$(use openmp && echo -fopenmp)
+ emake $(use native-cflags && echo no)CFLAGS="${CFLAGS} ${openmp}" "$@"
+}
+
+multilib_src_compile() {
+ do_make
+}
+
+multilib_src_test() {
+ do_make check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -type f -delete || die
+}