summaryrefslogtreecommitdiff
path: root/app-crypt/kstart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
commitfbda87924e6faa7a1919f1a2b4182490bde5ec5c (patch)
treef3114a4ed212a754756adce027aeef3a4a1a2e2a /app-crypt/kstart
parent3b08f674e3f771b49370edb144dab0958c8cf721 (diff)
gentoo resync : 03.09.2021
Diffstat (limited to 'app-crypt/kstart')
-rw-r--r--app-crypt/kstart/Manifest2
-rw-r--r--app-crypt/kstart/kstart-4.3.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/kstart/Manifest b/app-crypt/kstart/Manifest
index 919275cb4547..698f3858aabd 100644
--- a/app-crypt/kstart/Manifest
+++ b/app-crypt/kstart/Manifest
@@ -1,3 +1,5 @@
DIST kstart-4.2.tar.gz 296651 BLAKE2B 127bf28ef538681d188ae79ed67cedaa7d9022c1fe6741b3486ce7d5901c4a77d0aec7d00164240a79ffc70b56dd7fdeaf42e76dd2b02effe79bcad41ad8e271 SHA512 7ce9c1f964c0d469b4b8a5de88ae83186e99116959941c4e7f69c59165d0c22aac432ac26dd5fe54f7c2f725048bb55b787107aea8408e2fd6c9ad02dcb31552
+DIST kstart-4.3.tar.gz 324005 BLAKE2B eb8a115e114f62ac93a84fcacd427cb0cb56241973747bb841d2263d6333ea670b5beb1421d6beca0366b8a444e7d24910fde1329c4a35a34190d9bf9e22b17d SHA512 a5d5e6f7428af82012d2935a05398336cfd7caf66243cce158930e7a9b79f444cf88f5f23ecbc2efe2432493440ef913f60f85820d5d9943687637935eee97fd
EBUILD kstart-4.2.ebuild 663 BLAKE2B 0732109be0c35d1517247151805af28863124cdab144aa9d76da0b7124a38c24050d0f3bb38159a8649982574da830ff2687f1f9b2431b929601fbbcae1b768c SHA512 2720add693aa5acbddacf27d1c167ea3622aeb757dec1721154cc1e2c0769872ef6700427ce6eb69977d5ff598afed2b12b3e14fb26dadb68b048f7f595c5648
+EBUILD kstart-4.3.ebuild 708 BLAKE2B df78dcf955d3c6a34904eb1b284c40447eaef8dfb4610632ac823757786117048d5e8630d68b043c59d6d7ec65ca06b089266876dd15ac854fa9f7e7d833f4b5 SHA512 6e0f9cb57e6ddc16335e9c8aa6b5840b3beea9f57a2daad5aa96712c822dcea52910e4464d77b2713162dcb6e69e002d436232615781a12e94e58a4da82ef8f0
MISC metadata.xml 807 BLAKE2B 9c7c0283dce5943b74d5d57b21fdfb11cd2f9b994ca1930e62997576e20e3a74cb468565824c44051b67fd87b44f70f08defcd834d2dc03e98b5de62289cf08c SHA512 d854205e8829d141c3cd94cc00db039fce23376cb4f75c2498ae46d714765103890329526d2fe85f2eeff238fe2620f616686e78c62c9a115051d5fc161d19b5
diff --git a/app-crypt/kstart/kstart-4.3.ebuild b/app-crypt/kstart/kstart-4.3.ebuild
new file mode 100644
index 000000000000..673a633213c6
--- /dev/null
+++ b/app-crypt/kstart/kstart-4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Modified versions of kinit for refreshing kerberos tickets automatically"
+HOMEPAGE="https://www.eyrie.org/~eagle/software/kstart/"
+SRC_URI="https://archives.eyrie.org/software/kerberos/${P}.tar.gz"
+
+LICENSE="|| ( MIT Stanford ISC )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="afs"
+
+DEPEND="virtual/krb5
+ sys-apps/keyutils
+ afs? ( net-fs/openafs )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-reduced-depends \
+ --with-libkeyutils \
+ "$(use_with afs)" \
+ "$(use_enable afs setpag)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README NEWS TODO examples/*
+}