summaryrefslogtreecommitdiff
path: root/app-crypt/kstart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/kstart
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/kstart')
-rw-r--r--app-crypt/kstart/Manifest5
-rw-r--r--app-crypt/kstart/kstart-4.1.ebuild33
-rw-r--r--app-crypt/kstart/kstart-4.2.ebuild30
-rw-r--r--app-crypt/kstart/metadata.xml20
4 files changed, 88 insertions, 0 deletions
diff --git a/app-crypt/kstart/Manifest b/app-crypt/kstart/Manifest
new file mode 100644
index 000000000000..71a99e1369e2
--- /dev/null
+++ b/app-crypt/kstart/Manifest
@@ -0,0 +1,5 @@
+DIST kstart-4.1.tar.gz 269215 BLAKE2B 0d979953206e1598c121e21b2c52a123a4b5d93872ce8292638e21c5d9a4c1be0345990f1a74fa60e9a5ce58d6f166cca5ae525f97c67f7a908d73e7657d6fe8 SHA512 74a8a3f2c8d2c95f166f5861fb05a2d659a31db3165e27e81e5cf216bde44809d937ebc00995f89fa3b9df68609e3081303eb30742f5c4d90151b1410f0bd3cc
+DIST kstart-4.2.tar.gz 296651 BLAKE2B 127bf28ef538681d188ae79ed67cedaa7d9022c1fe6741b3486ce7d5901c4a77d0aec7d00164240a79ffc70b56dd7fdeaf42e76dd2b02effe79bcad41ad8e271 SHA512 7ce9c1f964c0d469b4b8a5de88ae83186e99116959941c4e7f69c59165d0c22aac432ac26dd5fe54f7c2f725048bb55b787107aea8408e2fd6c9ad02dcb31552
+EBUILD kstart-4.1.ebuild 706 BLAKE2B 3f43a948aa353100c667e7629132bdbcf22d076d207442a7e0c97b690009dc4d3054811c1ea98af7046182227fb4d5024d1bb24b64e9848b7b983b4d8d6b7865 SHA512 2b8865c5460966d049363d1ddef18db1abbadb1c7e527b9a22dfcd4eac9eca6938485772756ad906183e076dee9d29ef459c2b877335196f81033bf1c5f01c98
+EBUILD kstart-4.2.ebuild 666 BLAKE2B ce11818d2327c2ca3d8ff561a5f22248523b1c13162dbec270eadc05667dfbedd262c5b3d7adba98486e93f2bbfe9a6f5de275516fac6d027a1b81db5d6f9605 SHA512 d267f318c97bb1843f9ce3da3f7af0fb5d2cb570037d4c2e3ea8edcfc446c69a027caa05c9d9523d2094949925afbf71b75efc913ac42d1fd5de953920414bad
+MISC metadata.xml 807 BLAKE2B 9c7c0283dce5943b74d5d57b21fdfb11cd2f9b994ca1930e62997576e20e3a74cb468565824c44051b67fd87b44f70f08defcd834d2dc03e98b5de62289cf08c SHA512 d854205e8829d141c3cd94cc00db039fce23376cb4f75c2498ae46d714765103890329526d2fe85f2eeff238fe2620f616686e78c62c9a115051d5fc161d19b5
diff --git a/app-crypt/kstart/kstart-4.1.ebuild b/app-crypt/kstart/kstart-4.1.ebuild
new file mode 100644
index 000000000000..c80974b18abb
--- /dev/null
+++ b/app-crypt/kstart/kstart-4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Modified versions of kinit for refreshing kerberos tickets
+automatically"
+HOMEPAGE="https://www.eyrie.org/~eagle/software/kstart/"
+SRC_URI="https://archives.eyrie.org/software/kerberos/${P}.tar.gz"
+
+LICENSE="|| ( MIT Stanford ISC )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="afs"
+
+DEPEND="virtual/krb5
+ afs? ( net-fs/openafs )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ econf \
+ --enable-reduced-depends \
+ "$(use_with afs)" \
+ "$(use_enable afs setpag)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman k5start.1 krenew.1
+ dodoc README NEWS TODO examples/*
+}
diff --git a/app-crypt/kstart/kstart-4.2.ebuild b/app-crypt/kstart/kstart-4.2.ebuild
new file mode 100644
index 000000000000..0f9b5ae1131c
--- /dev/null
+++ b/app-crypt/kstart/kstart-4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Modified versions of kinit for refreshing kerberos tickets
+automatically"
+HOMEPAGE="https://www.eyrie.org/~eagle/software/kstart/"
+SRC_URI="https://archives.eyrie.org/software/kerberos/${P}.tar.gz"
+
+LICENSE="|| ( MIT Stanford ISC )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="afs"
+
+DEPEND="virtual/krb5
+ afs? ( net-fs/openafs )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ econf \
+ --enable-reduced-depends \
+ "$(use_with afs)" \
+ "$(use_enable afs setpag)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README NEWS TODO examples/*
+}
diff --git a/app-crypt/kstart/metadata.xml b/app-crypt/kstart/metadata.xml
new file mode 100644
index 000000000000..0a3c1226d1c1
--- /dev/null
+++ b/app-crypt/kstart/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kerberos@gentoo.org</email>
+ <name>Kerberos</name>
+ </maintainer>
+ <longdescription>Modified versions of kinit that can use srvtabs or
+ keytabs to authenticate, can run as daemons and wake up periodically
+ to refresh a ticket, and can run single commands with their own
+ authentication credentials and refresh those credentials until the
+ command exits.</longdescription>
+ <use>
+ <flag name="afs">
+ Enables afs support which means you can acquire an afs token and
+ set PAGs. It's recommended to set this USE if you need
+ authenticated access to an AFS cell for your daemon/app.
+ </flag>
+ </use>
+</pkgmetadata>