summaryrefslogtreecommitdiff
path: root/app-crypt/johntheripper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-22 03:45:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-22 03:45:27 +0100
commit102518876412b49c154cd247f5891927304dd8cc (patch)
tree02ee78597f043d94b8f33d37622352c7d9c3276f /app-crypt/johntheripper
parentd51fe7680c5270ddf8d324bbe11caab6d1e27ade (diff)
gentoo auto-resync : 22:08:2023 - 03:45:27
Diffstat (limited to 'app-crypt/johntheripper')
-rw-r--r--app-crypt/johntheripper/Manifest2
-rw-r--r--app-crypt/johntheripper/johntheripper-1.9.0.ebuild137
2 files changed, 139 insertions, 0 deletions
diff --git a/app-crypt/johntheripper/Manifest b/app-crypt/johntheripper/Manifest
index 942a9de3a0d4..bea31c6e2325 100644
--- a/app-crypt/johntheripper/Manifest
+++ b/app-crypt/johntheripper/Manifest
@@ -1,3 +1,5 @@
DIST john-1.8.0.tar.xz 4468704 BLAKE2B 90d6acc03dc8d22ef869320723e4799e64e15b621cde327ad420595889a43242b182079fd306bb7741b766ddc5e1239e3bdd4f4e396a4ab1e86d635cbebf8f60 SHA512 e2820ecabd7ea4c7404c3d40f064994d0f5746b093c859a58fbf2588492ebcef411d9f3088c8e8ee726284ead969e26fdae834cdae3eb2d32408fc79ed906543
+DIST john-1.9.0.tar.xz 8944932 BLAKE2B 57f5b83a541a7048e34d87dbee2f8f56953ef8a98bf7163b981064289d38452d11e59f1fb48a98a4f5f61d5f33866987f7c8515bf9900d742c09b7ac3e61376e SHA512 26e9a245e9f050344ae8c3320e1e24dad6bc2b73e99cc041a50c2d124b2c898c93d048727451ab8a2ba1c8aa4d8d462a8c0c9fea7de39f3479a0c170a5e9ad60
EBUILD johntheripper-1.8.0-r2.ebuild 2869 BLAKE2B 970038b161660bc47a1a92279c911010fb77fa5008c4bcc8cc4f90ce7cb374629282943cf1742a542d14b5e62442bff431ad956826bb7e1b5498886aa42f03d9 SHA512 199605c25f5d02064f5df1a323099c065f916c66fcd9910c60c6c1c74c2419abe59f652496158e320e09b099b31c270f413de590ce480e9bef5ce8fa900c0181
+EBUILD johntheripper-1.9.0.ebuild 3162 BLAKE2B 77a3c530d1b658b6e646f4116485ddbc11606d3e6031f1958c7280c93e7af7261617c133c93f76adb46060c9e9e98d33e670fb31c3456fbf9d7e7777a436290b SHA512 c6dc7e4d90273749b17fa2a56910a4d77b7589ce7b7887f278eea20d20f60423e99923b2fdae08c821db22e3b73dc8a82ff30408ab997d1569dc2c99d4c81774
MISC metadata.xml 409 BLAKE2B f8d40635490b818425ab465d2d34e41c05881a51860e7714161c50af9b061bea3801aefcbad8edb403f3af753b919621b709d23b0a86a0b303b903653f273fd5 SHA512 ed0271486767ec9b53851b534179307b2f160aea50f3a071b9d68aaa21265f5e0e5d031be3b00580e8f706b944ab7ec7aaa7c325485acf73655d899a8787ba13
diff --git a/app-crypt/johntheripper/johntheripper-1.9.0.ebuild b/app-crypt/johntheripper/johntheripper-1.9.0.ebuild
new file mode 100644
index 000000000000..fabbd858c1cf
--- /dev/null
+++ b/app-crypt/johntheripper/johntheripper-1.9.0.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+MY_PN="john"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="fast password cracker"
+HOMEPAGE="https://www.openwall.com/john/"
+
+SRC_URI="https://www.openwall.com/john/k/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+CPU_FLAGS="cpu_flags_x86_mmx cpu_flags_x86_sse2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_avx512f cpu_flags_x86_xop"
+IUSE="custom-cflags openmp ${CPU_FLAGS}"
+
+DEPEND="virtual/libcrypt:="
+RDEPEND="${DEPEND}
+ !app-crypt/johntheripper-jumbo"
+
+S="${WORKDIR}/${MY_P}"
+
+get_target() {
+ if use alpha; then
+ echo "linux-alpha"
+ elif use amd64; then
+ if use cpu_flags_x86_avx512f; then
+ echo "linux-x86-64-avx512"
+ elif use cpu_flags_x86_avx2; then
+ echo "linux-x86-64-avx2"
+ elif use cpu_flags_x86_xop; then
+ echo "linux-x86-64-xop"
+ elif use cpu_flags_x86_avx; then
+ echo "linux-x86-64-avx"
+ else
+ echo "linux-x86-64"
+ fi
+ elif use ppc; then
+ echo "linux-ppc32"
+ elif use ppc64; then
+ echo "linux-ppc64"
+ elif use sparc; then
+ echo "linux-sparc"
+ elif use x86; then
+ if use cpu_flags_x86_avx512f; then
+ echo "linux-x86-64-avx512"
+ elif use cpu_flags_x86_avx2; then
+ echo "linux-x86-64-avx2"
+ elif use cpu_flags_x86_xop; then
+ echo "linux-x86-xop"
+ elif use cpu_flags_x86_avx; then
+ echo "linux-x86-avx"
+ elif use cpu_flags_x86_sse2; then
+ echo "linux-x86-sse2"
+ elif use cpu_flags_x86_mmx; then
+ echo "linux-x86-mmx"
+ else
+ echo "linux-x86-any"
+ fi
+ elif use ppc-macos; then
+ echo "macosx-ppc32-altivec"
+ elif use x64-macos; then
+ echo "macosx-x86-64"
+ else
+ echo "generic"
+ fi
+}
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ local OMP
+
+ use custom-cflags || strip-flags
+ cat <<- EOF >> config.gentoo || die
+ #define JOHN_SYSTEMWIDE 1
+ #define JOHN_SYSTEMWIDE_HOME "${EPREFIX}/etc/john"
+ #define JOHN_SYSTEMWIDE_EXEC "${EPREFIX}/usr/libexec/john"
+EOF
+
+ append-flags -fPIC -fPIE
+ #gcc-specs-pie && append-ldflags -nopie
+ use openmp && OMP="-fopenmp"
+
+ CPP="$(tc-getCXX)" CC="$(tc-getCC)" AS="$(tc-getCC)" LD="$(tc-getCC)"
+
+ emake -C src/ \
+ CPP="${CPP}" CC="${CC}" AS="${AS}" LD="${LD}" \
+ CFLAGS="-c -Wall -include ../config.gentoo ${CFLAGS} ${OMP}" \
+ LDFLAGS="${LDFLAGS} ${OMP}" \
+ OPT_NORMAL="" \
+ OMPFLAGS="${OMP}" \
+ $(get_target)
+}
+
+src_test() {
+ emake -C src/ check
+}
+
+src_install() {
+ # executables
+ dosbin run/john
+ newsbin run/mailer john-mailer
+
+ dosym john /usr/sbin/unafs
+ dosym john /usr/sbin/unique
+ dosym john /usr/sbin/unshadow
+
+ # config files
+ insinto /etc/john
+ doins run/*.chr run/password.lst
+ doins run/*.conf
+
+ # documentation
+ dodoc doc/*
+}
+
+pkg_postinst() {
+ if [ -n "${REPLACING_VERSIONS}" ] && [ "${REPLACING_VERSIONS}" != "1.8.0" ]; then
+ ewarn "This package no longer includes jumbo. If you want jumbo please install app-crypt/johntheripper-jumbo instead."
+ fi
+}