summaryrefslogtreecommitdiff
path: root/app-crypt/johntheripper-jumbo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /app-crypt/johntheripper-jumbo
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'app-crypt/johntheripper-jumbo')
-rw-r--r--app-crypt/johntheripper-jumbo/Manifest2
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0.ebuild123
2 files changed, 125 insertions, 0 deletions
diff --git a/app-crypt/johntheripper-jumbo/Manifest b/app-crypt/johntheripper-jumbo/Manifest
index b27ec0a7db63..779e7f1e0100 100644
--- a/app-crypt/johntheripper-jumbo/Manifest
+++ b/app-crypt/johntheripper-jumbo/Manifest
@@ -1,5 +1,7 @@
AUX 1.8.0-gcc5.patch 1793 BLAKE2B b25b356e68c5e210557373a3cf8e5543e8851f2d375fb72af82189bfb7c491826bc4fe092484e28031683d30a37863c20b6c36b19ca73ed133e77988dc4df188 SHA512 941a8fbe435d24287be158648d3083062806de639ce822645d949a171b2e662249bb13d9f5903017792cc979c7ff89615681adaed2afbf0d9c6ca5fe825e135a
DIST JohnTheRipper-1.8.0-jumbo-1.tar.gz 32533148 BLAKE2B 15929fa25314438619899582b209bee6902b1e53dc2df39ed6a686820665fd4d8e56d26b3f0082d05dc6be2f54add3526570d936c0a929641e33e6dcfb7a13b5 SHA512 8b7fad7a6330b5ff1afc306218ba698aaa27776b566f82c2e76102d5ceb10aeafa69d71fa6fff67c81996ea2c6a04384bab4696ed192306c6d074873562e7089
+DIST john-1.9.0-jumbo-1.tar.xz 33638768 BLAKE2B 2fd6813e234308408d42581705ee8b25f9217a3dfb43f05483156f7bb67d0ce0d6de9c3ce8c2e4a17bb99bb377119dae2897bc08c800e7bc80bc6cf245400df6 SHA512 c5cb5dc739ee4c666f8479cdf10511fddc391b590c59f90c060d3ccd8449b794ac7b831a6d1f7553883892499e709a66578cfa4d62caef9b7e0a831eb827e808
EBUILD johntheripper-jumbo-1.8.0.ebuild 2906 BLAKE2B 185b18965a00a4cc7eeedb6717a7140bef2dc34c42f0c570fb480ac03c64e15dba1cdafbb31114ad74998d7acc9d9bd351a2a5156b88a4f4d9de19ea3b8ce2f1 SHA512 cb7bd2f37e38a0ec6c5d5b472afd41734f446d45dd9796543f4bdfbf3f3fe11dd38cf4f87ebf73ed223a67c9bd40c348c5a21a11e79db70ff2811aa1b7c14ed8
+EBUILD johntheripper-jumbo-1.9.0.ebuild 2804 BLAKE2B 413c4384fa7f40a9f594b5f1430e71d668592b958c8afb52111a2f9cff11c901428ced115e1e3332da938cfcf277a61021d31604bebe5e6eb4af2e496741bf50 SHA512 25a6236275567739ee8ff9d4a4a785284e78e1214e07412d86f4fd8ce67a2a23614b8f61172c96ca5262dd93a93260bc2059ea874b504a9e7af44e638e62b73f
EBUILD johntheripper-jumbo-9999.ebuild 2841 BLAKE2B 9d2a9cd73d689e85dfc2a8e62513750cd36bc727ab7e57c58d8562b7796d434412f10ac262ed89186b8bd7eee593bb20d693f0588de4bb7c8b29d3826b333669 SHA512 47ab66206c497c344ce26b01eb4c4484551f631749001a9de9db9cf4f00224026cec1410c9d7a87767336554fe90f930fd028958685ad66fbdf2f1a3db70ed93
MISC metadata.xml 573 BLAKE2B bfe4625ed3871bcc6c083ce63f30b433c6904411db832f5833b753c02dda92d60086264b4167fc59c7b3130de2db73e4d8814c606f02372669c866c185d6477f SHA512 590ef9c3538bbda4e19f88acf78988510343771e4e764d68d0872add996bc041c28aa8f16efcb4b21232870ff7c3e768b3512f39f0da900fedeb99210c200fd6
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0.ebuild
new file mode 100644
index 000000000000..40128aaaf434
--- /dev/null
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-1.9.0.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs pax-utils
+
+DESCRIPTION="fast password cracker"
+HOMEPAGE="http://www.openwall.com/john/"
+
+MY_PN="JohnTheRipper"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/magnumripper/${MY_PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ JUMBO="jumbo-1"
+ MY_PV="${PV}-${JUMBO}"
+ MY_P="john-${MY_PV}"
+ SRC_URI="https://www.openwall.com/john/k/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+#removed rexgen and commoncrypto
+IUSE="custom-cflags kerberos mpi opencl openmp pcap"
+
+DEPEND=">=dev-libs/openssl-1.0.1:0
+ mpi? ( virtual/mpi )
+ opencl? ( virtual/opencl )
+ kerberos? ( virtual/krb5 )
+ pcap? ( net-libs/libpcap )
+ dev-libs/gmp:*
+ sys-libs/zlib
+ app-arch/bzip2"
+
+RDEPEND="${DEPEND}
+ !app-crypt/johntheripper"
+
+pkg_setup() {
+ if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_prepare() {
+ sed -i 's#$prefix/share/john#/etc/john#' src/configure || die
+ default
+}
+
+src_configure() {
+ cd src || die
+
+ use custom-cflags || strip-flags
+
+ econf \
+ --disable-native-march \
+ --disable-native-tests \
+ --without-commoncrypto \
+ --disable-rexgen \
+ --with-openssl \
+ --with-systemwide \
+ $(use_enable mpi) \
+ $(use_enable opencl) \
+ $(use_enable openmp) \
+ $(use_enable pcap)
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_test() {
+ pax-mark -mr run/john
+ #if use opencl; then
+ #gpu tests fail in portage, so run cpu only tests
+ # ./run/john --device=cpu --test=0 --verbosity=2 || die
+ #else
+ #weak tests
+ # ./run/john --test=0 --verbosity=2 || die
+ #strong tests
+ #./run/john --test=1 --verbosity=2 || die
+ #fi
+ ewarn "When built systemwide, john can't run tests without reading files in /etc."
+ ewarn "Don't bother opening a bug for this unless you include a patch to fix it"
+}
+
+src_install() {
+ # executables
+ dosbin run/john
+ newsbin run/mailer john-mailer
+
+ pax-mark -mr "${ED}/usr/sbin/john"
+
+ # grep '$(LN)' Makefile.in | head -n-3 | tail -n+2 | cut -d' ' -f3 | cut -d/ -f3
+ for s in \
+ unshadow unafs undrop unique ssh2john putty2john pfx2john keepass2john keyring2john \
+ zip2john gpg2john rar2john racf2john keychain2john kwallet2john pwsafe2john dmg2john \
+ hccap2john base64conv truecrypt_volume2john keystore2john
+ do
+ dosym john /usr/sbin/$s
+ done
+
+ insinto /usr/share/john
+ doins run/*.py
+
+ if use opencl; then
+ insinto /etc/john
+ doins -r run/kernels
+ fi
+
+ # config files
+ insinto /etc/john
+ doins run/*.chr run/password.lst
+ doins run/*.conf
+ doins -r run/rules run/ztex
+
+ # documentation
+ dodoc -r doc/*
+}