summaryrefslogtreecommitdiff
path: root/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild')
-rw-r--r--app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild78
1 files changed, 53 insertions, 25 deletions
diff --git a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
index 826ff08b2f51..d1fbfc6ec025 100644
--- a/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
+++ b/app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs pax-utils
+inherit autotools flag-o-matic toolchain-funcs pax-utils
DESCRIPTION="Fast password cracker"
HOMEPAGE="http://www.openwall.com/john/"
@@ -14,20 +14,22 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/magnumripper/${MY_PN}.git"
inherit git-r3
else
- JUMBO="jumbo-1"
+ JUMBO="jumbo-1.1"
MY_PV="${PV}-${JUMBO}"
- MY_P="${MY_PN}-${MY_PV}"
- SRC_URI="https://github.com/magnumripper/${MY_PN}/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ MY_P="john-${MY_PV}"
+ HASH_COMMIT="5d0c85f16f96ca7b6dd06640e95a5801081d6e20"
+
+ SRC_URI="https://github.com/openwall/john/archive/${HASH_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/john-${HASH_COMMIT}"
+
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
- S="${WORKDIR}/${MY_P}"
fi
LICENSE="GPL-2"
SLOT="0"
-#removed rexgen and commoncrypto
IUSE="custom-cflags kerberos mpi opencl openmp pcap"
-DEPEND=">=dev-libs/openssl-1.0.1:0=
+DEPEND=">=dev-libs/openssl-1.0.1:=
virtual/libcrypt:=
mpi? ( virtual/mpi )
opencl? ( virtual/opencl )
@@ -36,19 +38,30 @@ DEPEND=">=dev-libs/openssl-1.0.1:0=
dev-libs/gmp:=
sys-libs/zlib
app-arch/bzip2"
-
+# Missing (unpackaged):
+# - Digest::Haval256
+# - Digest::x
+# See bug #777369.
RDEPEND="${DEPEND}
- !app-crypt/johntheripper"
+ dev-perl/Digest-MD2
+ virtual/perl-Digest-MD5
+ dev-perl/Digest-SHA3
+ dev-perl/Digest-GOST
+ !app-crypt/johntheripper"
pkg_setup() {
if use openmp && [[ ${MERGE_TYPE} != binary ]]; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ tc-has-openmp || die "Please switch to an OpenMP compatible compiler"
fi
}
src_prepare() {
- sed -i 's#$prefix/share/john#/etc/john#' src/configure || die
default
+
+ cd src || die
+ eautoreconf
+
+ sed -i 's#$prefix/share/john#/etc/john#' configure || die
}
src_configure() {
@@ -57,9 +70,9 @@ src_configure() {
use custom-cflags || strip-flags
econf \
+ --enable-pkg-config \
--disable-native-march \
--disable-native-tests \
- --without-commoncrypto \
--disable-rexgen \
--with-openssl \
--with-systemwide \
@@ -70,54 +83,69 @@ src_configure() {
}
src_compile() {
- emake -C src
+ # Uses default LD=$(CC) but if the user's set LD, it'll call it
+ # bug #729432.
+ emake LD=$(tc-getCC) -C src
}
src_test() {
pax-mark -mr run/john
+
#if use opencl; then
- #gpu tests fail in portage, so run cpu only tests
+ # GPU tests fail in portage, so run cpu only tests
# ./run/john --device=cpu --test=0 --verbosity=2 || die
#else
- #weak tests
- # ./run/john --test=0 --verbosity=2 || die
- #strong tests
+ # Weak tests
+ #./run/john --test=0 --verbosity=2 || die
+ # Strong tests
#./run/john --test=1 --verbosity=2 || die
#fi
+
ewarn "When built systemwide, john can't run tests without reading files in /etc."
ewarn "Don't bother opening a bug for this unless you include a patch to fix it"
}
src_install() {
- # executables
+ # Executables
dosbin run/john
newsbin run/mailer john-mailer
pax-mark -mr "${ED}/usr/sbin/john"
# grep '$(LN)' Makefile.in | head -n-3 | tail -n+2 | cut -d' ' -f3 | cut -d/ -f3
+ local s
for s in \
unshadow unafs undrop unique ssh2john putty2john pfx2john keepass2john keyring2john \
zip2john gpg2john rar2john racf2john keychain2john kwallet2john pwsafe2john dmg2john \
hccap2john base64conv truecrypt_volume2john keystore2john
do
- dosym john /usr/sbin/$s
+ dosym john /usr/sbin/${s}
done
- insinto /usr/share/john
- doins run/*.py
+ # Scripts
+ exeinto /usr/share/john
+ doexe run/*.pl
+ doexe run/*.py
+ cd run || die
+
+ local s
+ for s in *.pl *.py; do
+ dosym ../share/john/${s} /usr/bin/${s}
+ done
+ cd .. || die
if use opencl; then
insinto /etc/john
- doins -r run/kernels
+ doins -r run/opencl
fi
- # config files
+ # Config files
insinto /etc/john
doins run/*.chr run/password.lst
doins run/*.conf
doins -r run/rules run/ztex
- # documentation
- dodoc -r doc/*
+ # Documentation
+ rm -f doc/README || die
+ dodoc -r README.md doc/*
}