summaryrefslogtreecommitdiff
path: root/app-crypt/jitterentropy-rngd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-crypt/jitterentropy-rngd
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-crypt/jitterentropy-rngd')
-rw-r--r--app-crypt/jitterentropy-rngd/Manifest4
-rw-r--r--app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-1.1.0-do-not-strip-and-compress.patch16
-rw-r--r--app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild24
-rw-r--r--app-crypt/jitterentropy-rngd/metadata.xml17
4 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy-rngd/Manifest b/app-crypt/jitterentropy-rngd/Manifest
new file mode 100644
index 000000000000..95d8051f36a3
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/Manifest
@@ -0,0 +1,4 @@
+AUX jitterentropy-rngd-1.1.0-do-not-strip-and-compress.patch 581 BLAKE2B ee6f98d762fea06504ea7157ea2b13ececeaef1ee204cf0e5d63fc0932e1c41da13b2a8ad0cb8564548fcabe1989693ed16c7d461f75844323864e457e8fb804 SHA512 7c42e8deebf0d36fdd91b879cbc28eab1a92d413f64ab5f19eeaa214b51f6e96866c1bd53fdd6c2c4e335ae156cef24d2bba4c1dd6b557d96e89b61618703241
+DIST jitterentropy-rngd-1.1.0.tar.gz 25891 BLAKE2B f711b173c68b74cbc0dbac1ae1b7a2beb5352b38e411f96172aa36ac7f720f05469f5fac2fa97b3514ec11fbe2ccfe0351ee7df8f51a8b36a566635ef93e4d08 SHA512 32835475b604e502caaab9b0d1cd9fe2920c126a27841669f6cf9c717094bfd4c11feab0f9f706ee4cf4caeedf26ced7039075499a3faaf41830c72968544646
+EBUILD jitterentropy-rngd-1.1.0.ebuild 530 BLAKE2B 0ad8384055a7405ab4e19cb57f5454b060f8b9fec3692ad8c00ff60822457a5810dce1f7654e61f2a061b5aac21a9280288eb7a2f48e2d5782bdecd7290c78d1 SHA512 080c4c3790641385159ec11f2ac1d6aa5321a54e84466ce179a38110ba5489a74811933218c2edff561fbaa6d6cf35bc8d835cd2d0eb90ad2e77ad57a6724772
+MISC metadata.xml 598 BLAKE2B 50854b04b1cf0b6370888000503a850d5a34b9cc49fbe917f26ff0a6d4fed2204e1b1921d06a1238c47d31fb92c82d8631a56c2fa60e6ef88b7d84aee4897aed SHA512 d13cb55c4649dff554018e04025e741c51397785f2951d1aa8ceb0f7712a2ed48c39b57ac4f6c197f8a4c96bfe8ba44023107201df5ab603d7ea2f11b0713227
diff --git a/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-1.1.0-do-not-strip-and-compress.patch b/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-1.1.0-do-not-strip-and-compress.patch
new file mode 100644
index 000000000000..069c005df3a6
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/files/jitterentropy-rngd-1.1.0-do-not-strip-and-compress.patch
@@ -0,0 +1,16 @@
+diff --git a/Makefile b/Makefile
+index 55b65b1..b04f270 100644
+--- a/Makefile
++++ b/Makefile
+@@ -36,10 +36,9 @@ $(NAME): $(OBJS)
+ strip: $(NAME)
+ $(STRIP) --strip-unneeded $(NAME)
+
+-install: strip
++install:
+ $(INSTALL) -D -m 0755 $(NAME) $(DESTDIR)$(PREFIX)/sbin/$(NAME)
+ $(INSTALL) -D -m 0644 $(NAME).1 $(DESTDIR)$(PREFIX)/share/man/man1/$(NAME).1
+- gzip -9 $(DESTDIR)$(PREFIX)/share/man/man1/$(NAME).1
+ sed "s|@PATH@|$(PREFIX)/sbin|" jitterentropy.service.in > jitterentropy.service
+ $(INSTALL) -D -m 0644 jitterentropy.service $(DESTDIR)$(UNITDIR)/jitterentropy.service
+
diff --git a/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
new file mode 100644
index 000000000000..bd3a671e48d4
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Jitter RNG daemon"
+HOMEPAGE="http://www.chronox.de/jent.html"
+SRC_URI="https://github.com/smuellerDD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-do-not-strip-and-compress.patch
+)
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
+ UNITDIR="$(systemd_get_systemunitdir)" install
+}
diff --git a/app-crypt/jitterentropy-rngd/metadata.xml b/app-crypt/jitterentropy-rngd/metadata.xml
new file mode 100644
index 000000000000..5db19de18fb4
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+</maintainer>
+<longdescription>
+ The Jitter RNG daemon provides an entropy source that feeds into the
+ Linux /dev/random device if its entropy runs low. It updates the
+ /dev/random entropy estimator such that the newly provided entropy
+ unblocks /dev/random.
+</longdescription>
+<upstream>
+ <remote-id type="github">smuellerDD/jitterentropy-rngd</remote-id>
+</upstream>
+</pkgmetadata>