summaryrefslogtreecommitdiff
path: root/app-crypt/hashcat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/hashcat
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/hashcat')
-rw-r--r--app-crypt/hashcat/Manifest4
-rw-r--r--app-crypt/hashcat/hashcat-3.5.0.ebuild49
-rw-r--r--app-crypt/hashcat/metadata.xml11
3 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/hashcat/Manifest b/app-crypt/hashcat/Manifest
new file mode 100644
index 000000000000..b1634b3c47ee
--- /dev/null
+++ b/app-crypt/hashcat/Manifest
@@ -0,0 +1,4 @@
+DIST hashcat-3.5.0.tar.gz 4103461 SHA256 af764698f48145ac96cf01c65cf76bcb88e205aeb4614025ae32d847571c4390 SHA512 7efc860461894a550fbacc406a40fec400232a120818180abba3d53f26bd3a503f58e7d189e4afad0f871c2244ff68371b145af58ab097478fe2d73f39c9a6b3 WHIRLPOOL 927ac7bfe902fcc9ead971f785f8231656335c1c190ffda1bb40b5affb8d7a3fb67d084102513a44e457a9d5ba1fba3969aa0e954669a33071fc65fba0b2424f
+EBUILD hashcat-3.5.0.ebuild 1281 SHA256 c485fd46eb57dd134d03b0f2c4ea08e0f1b42998e1f3e5802d2ba513e0558998 SHA512 a1fb965e13c1f72b340ce47b5993cd1323e01e02140da8072f75d312d1742d048eb8ddd9790507690bc089e27b3e0b21409be0b7dfe4fb71f82396d60116c0f3 WHIRLPOOL 9e8c164db1cc0a5dcf5eb87ae970547ff1c51f0a7326680726e9d64cb7ca9b7f027737cf167bea9a37375d6184176b5339d5b04810ab1be59b982b21e20bcc06
+MISC ChangeLog 474 SHA256 a9a08248c1c54431f0b8195351cdcc23b8cc38d5adc604a89eda25af1e2c69db SHA512 17ebcf872bc6746259a2c1356440d7ffd3d7c9e988bf3dec4e1e0bdc5023207b8db06fff2b4e3593d9b16778a782688dc7ce284856c07bd187a441c6729f5492 WHIRLPOOL a9099f55d14e4ef44d06754988f855b83c85f4d4a024a2e5085f030ef98b8dfaf4ef9bf7aaa248ae151206f2c88c0483e71b6253843dc7ccea349f090662ec15
+MISC metadata.xml 327 SHA256 de3c2f59eba3910a5b71700bce3f2e1b6e9f0e87c160f393a1d6543cfd728a74 SHA512 024401252f35e93caa0ec7a48a7df7b71c18e4c7e71eb495f3ee5598fec5f3332c44fd3cf5d6b86d3d885649e6da15a8e7b5bac4e9205f552f8c8ec3f0fcd496 WHIRLPOOL 1511b3bb00c72cae914a5a763101d87657ecc65908524b6cd1a4f730a118eaf2de6eefc160ec51e878427deb8c1a2d325e6fabdd200ee1ad34e2d3a3492c43ac
diff --git a/app-crypt/hashcat/hashcat-3.5.0.ebuild b/app-crypt/hashcat/hashcat-3.5.0.ebuild
new file mode 100644
index 000000000000..3d4a6f2cc029
--- /dev/null
+++ b/app-crypt/hashcat/hashcat-3.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils pax-utils multilib
+
+DESCRIPTION="World's fastest and most advanced password recovery utility"
+HOMEPAGE="https://github.com/hashcat/hashcat"
+SRC_URI="https://github.com/hashcat/hashcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="custom-cflags video_cards_nvidia video_cards_fglrx"
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ #do not strip
+ sed -i "/LFLAGS += -s/d" src/Makefile
+ #do not add random CFLAGS
+ sed -i "s/-O2//" src/Makefile || die
+ export PREFIX=/usr
+ export LIBRARY_FOLDER="/usr/$(get_libdir)"
+ eapply_user
+}
+
+src_compile() {
+ default
+ pax-mark -mr hashcat
+}
+
+src_test() {
+ if use video_cards_nvidia; then
+ addwrite /dev/nvidia0
+ addwrite /dev/nvidiactl
+ addwrite /dev/nvidia-uvm
+ if [ ! -w /dev/nvidia0 ]; then
+ einfo "To run these tests, portage likely must be in the video group."
+ einfo "Please run \"gpasswd -a portage video\" if the tests will fail"
+ fi
+ elif use vidia_cards_fglrx; then
+ addwrite /dev/ati
+ fi
+ #this always exits with 255 despite success
+ #./hashcat -b -m 2500 || die "Test failed"
+ ./hashcat -a 3 -m 1500 nQCk49SiErOgk
+}
diff --git a/app-crypt/hashcat/metadata.xml b/app-crypt/hashcat/metadata.xml
new file mode 100644
index 000000000000..2f9493fe8e46
--- /dev/null
+++ b/app-crypt/hashcat/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">hashcat/hashcat</remote-id>
+ </upstream>
+</pkgmetadata>