summaryrefslogtreecommitdiff
path: root/app-crypt/gnupg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /app-crypt/gnupg
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/Manifest1
-rw-r--r--app-crypt/gnupg/gnupg-2.2.16-r1.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/app-crypt/gnupg/Manifest b/app-crypt/gnupg/Manifest
index bd795d86bc93..59eb5f5e71c8 100644
--- a/app-crypt/gnupg/Manifest
+++ b/app-crypt/gnupg/Manifest
@@ -12,5 +12,6 @@ EBUILD gnupg-2.2.12.ebuild 3663 BLAKE2B ebc41be08f922215079e5f6975972a75355d0680
EBUILD gnupg-2.2.14.ebuild 3663 BLAKE2B 58a51005ce97906d7a8c051d88ecd0ec3ecdc627e146c424c446bba93a7b37ad93b6248be631d97c750c5b4e03f675d8f2c7355d306fcf219a03d19b71886bb5 SHA512 73ffb70a72e2936233596ef8dee2429abff9d97fb128b3c5e94fef862948ca65e964a95538e0722b7773fb0f08c7f27ad9eaabbc6ad7c140c826e9d16ba657ac
EBUILD gnupg-2.2.15-r1.ebuild 4510 BLAKE2B ace05abf02aa56cbceb46fd205398ca110b785c38889fea575a32dc4e21bff0933112ccf6c59acd5bc1cb700e33349d67ab2af900cd7098f6874e2bef5b9c4da SHA512 8289b2921ed18514a81d80b7c685e691de2c1c0aff6159a354f2e0e86a0d5b788099b98ed7b8770a5fe5372207cd9779b42d638a25e954f629a537f8a6f4e2c6
EBUILD gnupg-2.2.15.ebuild 3701 BLAKE2B 0ee776c3eaff7d3583159ec4714ccdb8fb3484fb20d8e61c4fcfe95486fc892c57ac080d1680b05f9fd3fd97c334f50a6026e8a74d80ba0f7c3bec6c13810da2 SHA512 3bffcd8049007bee7d89a506df583f9228c12ef037edd1211c3fcfb629a6557c793959f44d8d33e16350309020cb29af4204accb88e4f80bd2a59573c7eb82de
+EBUILD gnupg-2.2.16-r1.ebuild 4559 BLAKE2B 0296c31e7c20dc25a49de6f6cb23c393cccfa1dab610eead32fca98b09e37c1ab84d9bd00ca2c613b1444649f949cc725e4d9c99f83b809257bcd38f882df9dd SHA512 6b5b67d717a6a6c23bb2cf6dad7c746aa7d4a20bad767a3e7916fb2bda76710e3c3ebf33d6eb4e4dad8bcb58b054d6c3c7bcc0b586a180243f1a288af0f08f80
EBUILD gnupg-2.2.16.ebuild 4510 BLAKE2B ace05abf02aa56cbceb46fd205398ca110b785c38889fea575a32dc4e21bff0933112ccf6c59acd5bc1cb700e33349d67ab2af900cd7098f6874e2bef5b9c4da SHA512 8289b2921ed18514a81d80b7c685e691de2c1c0aff6159a354f2e0e86a0d5b788099b98ed7b8770a5fe5372207cd9779b42d638a25e954f629a537f8a6f4e2c6
MISC metadata.xml 1313 BLAKE2B 2bf26407bdea8af215d09d28640b961ee98c86c297595736fbe477c8b9cfaf0f8970982ce22038dabf0d8529e39032a3fec9da0c17a5acca0cf3cb197f31f1c0 SHA512 0500f03936eba67706cea87c1f5b16db280b159fc31780b93e696e8ab20e3dece90f0bd80af5aa9582cab557cc337c65e8e101daa935ba6ca31b7f126328c0ac
diff --git a/app-crypt/gnupg/gnupg-2.2.16-r1.ebuild b/app-crypt/gnupg/gnupg-2.2.16-r1.ebuild
new file mode 100644
index 000000000000..f559e78030f9
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-2.2.16-r1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic systemd toolchain-funcs
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="The GNU Privacy Guard, a GPL OpenPGP implementation"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/gnupg/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 doc ldap nls readline selinux +smartcard ssl tofu tools usb user-socket wks-server"
+
+# Existence of executables is checked during configuration.
+DEPEND="!app-crypt/dirmngr
+ >=dev-libs/libassuan-2.5.0
+ >=dev-libs/libgcrypt-1.7.3
+ >=dev-libs/libgpg-error-1.28
+ >=dev-libs/libksba-1.3.4
+ >=dev-libs/npth-1.2
+ >=net-misc/curl-7.10
+ bzip2? ( app-arch/bzip2 )
+ ldap? ( net-nds/openldap )
+ readline? ( sys-libs/readline:0= )
+ smartcard? ( usb? ( virtual/libusb:1 ) )
+ ssl? ( >=net-libs/gnutls-3.0:0= )
+ sys-libs/zlib
+ tofu? ( >=dev-db/sqlite-3.7 )"
+
+RDEPEND="${DEPEND}
+ app-crypt/pinentry
+ nls? ( virtual/libintl )
+ selinux? ( sec-policy/selinux-gpg )
+ wks-server? ( virtual/mta )"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( sys-apps/texinfo )
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(
+ ChangeLog NEWS README THANKS TODO VERSION
+ doc/FAQ doc/DETAILS doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.20-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch"
+ "${FILESDIR}/${PN}-2.2.14-quiet-sending.patch"
+)
+
+src_configure() {
+ local myconf=()
+
+ if use prefix && use usb; then
+ # bug #649598
+ append-cppflags -I"${EPREFIX}/usr/include/libusb-1.0"
+ fi
+
+ if use elibc_SunOS || use elibc_AIX; then
+ myconf+=( --disable-symcryptrun )
+ else
+ myconf+=( --enable-symcryptrun )
+ fi
+
+ #bug 663142
+ if use user-socket; then
+ myconf+=( --enable-run-gnupg-user-socket )
+ fi
+
+ # glib fails and picks up clang's internal stdint.h causing weird errors
+ [[ ${CC} == *clang ]] && \
+ export gl_cv_absolute_stdint_h=/usr/include/stdint.h
+
+ # Hardcode mailprog to /usr/libexec/sendmail even if it does not exist.
+ # As of GnuPG 2.3, the mailprog substitution is used for the binary called
+ # by wks-client & wks-server; and if it's autodetected but not not exist at
+ # build time, then then 'gpg-wks-client --send' functionality will not
+ # work. This has an unwanted side-effect in stage3 builds: there was a
+ # [R]DEPEND on virtual/mta, which also brought in virtual/logger, bloating
+ # the build where the install guide previously make the user chose the
+ # logger & mta early in the install.
+
+ econf \
+ "${myconf[@]}" \
+ $(use_enable bzip2) \
+ $(use_enable nls) \
+ $(use_enable smartcard scdaemon) \
+ $(use_enable ssl gnutls) \
+ $(use_enable tofu) \
+ $(use smartcard && use_enable usb ccid-driver || echo '--disable-ccid-driver') \
+ $(use_enable wks-server wks-tools) \
+ $(use_with ldap) \
+ $(use_with readline) \
+ --with-mailprog=/usr/libexec/sendmail \
+ --disable-ntbtls \
+ --enable-all-tests \
+ --enable-gpg \
+ --enable-gpgsm \
+ --enable-large-secmem \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config" \
+ KSBA_CONFIG="${EROOT}/usr/bin/ksba-config" \
+ LIBASSUAN_CONFIG="${EROOT}/usr/bin/libassuan-config" \
+ LIBGCRYPT_CONFIG="${EROOT}/usr/bin/${CHOST}-libgcrypt-config" \
+ NPTH_CONFIG="${EROOT}/usr/bin/npth-config" \
+ $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
+}
+
+src_compile() {
+ default
+
+ use doc && emake -C doc html
+}
+
+src_test() {
+ #Bug: 638574
+ use tofu && export TESTFLAGS=--parallel
+ default
+}
+
+src_install() {
+ default
+
+ use tools &&
+ dobin \
+ tools/{convert-from-106,gpg-check-pattern} \
+ tools/{gpg-zip,gpgconf,gpgsplit,lspgpot,mail-signed-keys} \
+ tools/make-dns-cert
+
+ dosym gpg /usr/bin/gpg2
+ dosym gpgv /usr/bin/gpgv2
+ echo ".so man1/gpg.1" > "${ED}"/usr/share/man/man1/gpg2.1 || die
+ echo ".so man1/gpgv.1" > "${ED}"/usr/share/man/man1/gpgv2.1 || die
+
+ dodir /etc/env.d
+ echo "CONFIG_PROTECT=/usr/share/gnupg/qualified.txt" >> "${ED}"/etc/env.d/30gnupg || die
+
+ use doc && dodoc doc/gnupg.html/* doc/*.png
+
+ systemd_douserunit doc/examples/systemd-user/*.{service,socket}
+}
+
+pkg_postinst() {
+ elog "See https://wiki.gentoo.org/wiki/GnuPG for documentation on gnupg"
+ elog
+ elog "If you wish to use 'gpg-wks-client --send', you must install an MTA!"
+}