summaryrefslogtreecommitdiff
path: root/app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild')
-rw-r--r--app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild b/app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild
new file mode 100644
index 000000000000..b6b52f863d31
--- /dev/null
+++ b/app-crypt/gkeys-gen/gkeys-gen-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit distutils-r1
+
+DESCRIPTION="Tool for generating OpenPGP/GPG keys using a specifications file"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ dev-python/snakeoil[${PYTHON_USEDEP}]
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ =app-crypt/gkeys-0.2*[${PYTHON_USEDEP}]
+ "
+
+pkg_postinst() {
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://bugs.gentoo.org"
+ einfo "We are also on IRC @ #gentoo-keys of the Freenode network"
+ einfo
+ ewarn "There may be some Python 3 compatibility issues still."
+ ewarn "Please help us debug, fix and report them in Bugzilla."
+}