summaryrefslogtreecommitdiff
path: root/app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild')
-rw-r--r--app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild b/app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild
new file mode 100644
index 000000000000..c2a8cfb2d9de
--- /dev/null
+++ b/app-crypt/gifshuffle/gifshuffle-2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="GIF colourmap steganography"
+HOMEPAGE="http://www.darkside.com.au/gifshuffle/"
+SRC_URI="http://www.darkside.com.au/gifshuffle/${PN}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ echo $(tc-getCC) -o ${PN} ${CFLAGS} ${LDFLAGS} *.c || die
+ $(tc-getCC) -o ${PN} ${CFLAGS} ${LDFLAGS} *.c || die "Cannot compile ${PN}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc gshuf.txt
+}