summaryrefslogtreecommitdiff
path: root/app-crypt/dieharder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/dieharder
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/dieharder')
-rw-r--r--app-crypt/dieharder/Manifest4
-rw-r--r--app-crypt/dieharder/dieharder-3.31.1-r1.ebuild50
-rw-r--r--app-crypt/dieharder/files/dieharder-3.31.1-build.patch27
-rw-r--r--app-crypt/dieharder/metadata.xml8
4 files changed, 89 insertions, 0 deletions
diff --git a/app-crypt/dieharder/Manifest b/app-crypt/dieharder/Manifest
new file mode 100644
index 000000000000..c5bb583afb67
--- /dev/null
+++ b/app-crypt/dieharder/Manifest
@@ -0,0 +1,4 @@
+AUX dieharder-3.31.1-build.patch 623 BLAKE2B a914f3b8f805725db9d30687b9265814661c9d00a5bc6246785eaab304e130dce417025153cd8b530ad0d3ed179583d865133c9bca3bee6ec2b427e78c1d527c SHA512 8d98efdcbfd4cea06d1cae1a1fbea1305e366c030c99b3abb944d1a47543e9b592304f60cd8dbfe9b3fa77ec9ee61c2537bf2390f072ced7d36ad7eb9550e4ea
+DIST dieharder-3.31.1.tgz 1149780 BLAKE2B 12937b54e713ce87d6cb815b9b1e00989085b7661538316649caea4a514518528039441d0d42f377c363c62db179f362feb9d64612a75f724ac363744f884a47 SHA512 e01ed4266b4fe5d5fadde3c92c30e430d0ca5f7fedd26b26ed2ab98b7602aa9c35bb5c8fd9314ef2f5235b5087645ab13e5e6550156e26643baa5aeb77088dc5
+EBUILD dieharder-3.31.1-r1.ebuild 925 BLAKE2B 0f2d51c0f5657b129ce0e8c5903f1e3b5186806cce815dfe1dc3db8a45350ad135e0edd618f7614019584a6930f37055a71a11eb246771fc1fc079737a854544 SHA512 c80e3e7ada89738c3cbed358859c8c89e8752c35b7a8c86a99a1417057f304517e1d8a056207907b664a4855e8eb2916d11efd7457196e82d9ed85715ca76675
+MISC metadata.xml 236 BLAKE2B a7bb92e6d53f7252ee56a885bf098930e228a76a75bca119358ca860901ceeecccc43efe5279c54250ebda58f77ae9c97d2ae540d8b399283cb3aa348111fcd2 SHA512 5f6cd6a85527534d5de7118de5af212ee3044c8c5530a7f7087a28074a2d4ab7be1728325bd985adc063dc795d3cf2b1c4e58a4c4c4ec02d739bd4bbc544ef08
diff --git a/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild b/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild
new file mode 100644
index 000000000000..7a783bb23e83
--- /dev/null
+++ b/app-crypt/dieharder/dieharder-3.31.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An advanced suite for testing the randomness of RNG's"
+HOMEPAGE="http://www.phy.duke.edu/~rgb/General/dieharder.php"
+SRC_URI="http://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="sci-libs/gsl"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/latex2html )"
+
+DOCS=(
+ NOTES
+)
+HTML_DOCS=()
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
+pkg_setup() {
+ use doc && DOCS+=(
+ ChangeLog
+ manual/dieharder.pdf manual/dieharder.ps
+ )
+ use doc && HTML_DOCS+=(
+ dieharder.html
+ )
+}
+
+src_compile() {
+ emake -j1
+ use doc && emake -C manual
+}
+
+src_install() {
+ default
+
+ docinto "dieharder"
+ dodoc dieharder/README dieharder/NOTES
+ docinto "libdieharder"
+ dodoc libdieharder/README libdieharder/NOTES
+}
diff --git a/app-crypt/dieharder/files/dieharder-3.31.1-build.patch b/app-crypt/dieharder/files/dieharder-3.31.1-build.patch
new file mode 100644
index 000000000000..4cbd5021c77c
--- /dev/null
+++ b/app-crypt/dieharder/files/dieharder-3.31.1-build.patch
@@ -0,0 +1,27 @@
+diff --git a/include/dieharder/libdieharder.h b/include/dieharder/libdieharder.h
+index 2138ebf..f6d471b 100644
+--- a/include/dieharder/libdieharder.h
++++ b/include/dieharder/libdieharder.h
+@@ -6,6 +6,8 @@
+
+ #include "copyright.h"
+
++#define _GNU_SOURCE
++
+ /* To enable large file support */
+ #define _FILE_OFFSET_BITS 64
+
+@@ -16,13 +18,11 @@
+ #include <sys/time.h>
+
+ /* This turns on uint macro in c99 */
+-#define __USE_MISC 1
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+
+ /* This turns on M_PI in math.h */
+-#define __USE_BSD 1
+ #include <math.h>
+ #include <limits.h>
+ #include <gsl/gsl_rng.h>
diff --git a/app-crypt/dieharder/metadata.xml b/app-crypt/dieharder/metadata.xml
new file mode 100644
index 000000000000..f1c3d59fb213
--- /dev/null
+++ b/app-crypt/dieharder/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+</maintainer>
+</pkgmetadata>