summaryrefslogtreecommitdiff
path: root/app-crypt/coolkey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /app-crypt/coolkey
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'app-crypt/coolkey')
-rw-r--r--app-crypt/coolkey/Manifest3
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r7.ebuild7
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r9.ebuild90
3 files changed, 98 insertions, 2 deletions
diff --git a/app-crypt/coolkey/Manifest b/app-crypt/coolkey/Manifest
index afca652e67a9..b5161042f5dc 100644
--- a/app-crypt/coolkey/Manifest
+++ b/app-crypt/coolkey/Manifest
@@ -1,4 +1,5 @@
DIST coolkey-1.1.0-patches-003.tar.gz 21263 BLAKE2B 27025b8aa24df45f8efa872122a1c3699db6d0d627861182c7eb1d61b921d026d7e3355d1b3d12608747ed1d214eee764b53dbbc5599c452b347e191e1516eca SHA512 25a5fac68ca041fcf9e927d134d0179fa286e6de75019e7bbf205edeaf73222d9fb9fd3861a8f6e0d933d1a09229e3e727278c3a9b3cc63390ef07774c46390d
DIST coolkey-1.1.0.tar.gz 432808 BLAKE2B 7e443cdb0dedcec5de32cf5c7cc5eb2d81f1d51fbc2e580fda302153d3f8a919bc89d2308b8799cf395c89d16150e09bd33bc76eacb8af855c54b961bb5d082a SHA512 4b61de9b40abcf620fbb519d5e3cf1e93ebdd0470854cb63a597fc91e0182998217353014327f7bc4f255d22515d8ea2b08d36b3a831f5f09134fdcd418bc08b
-EBUILD coolkey-1.1.0-r7.ebuild 1955 BLAKE2B e0aaf94e3d6a1ebd97d0a65933b3ba88508282768f7ba6bd446da4e46d2fc7b7ad874bce2c67d8ddfb5de83da34a8dad78c43c01e423dd1b5a3af966abacd6ee SHA512 e82f42b46efe278f5ab74b5205f451e4759c8701564d6132672bcc41e140fd4ad8817f047c900b09c5bc26b35e32b8197cbf2b4648475f43d83483c24873b129
+EBUILD coolkey-1.1.0-r7.ebuild 2019 BLAKE2B ded7d0f8142132e7c44702103e5f63d9bae0da84dbdd79b0a9977a221ee29644e10d8394e42d4b4b297e1bacea43a393ad890bf3f27ede7a797551b09d6ba58c SHA512 5bd6912bd7f9945e96995aaaa8794c151fed4d3a41e5ba2c86846bb0dbebe5c9fd09414cb5111bfaad98162bbe032683be0f7204fa07bd98878cf1f75e7de8f1
+EBUILD coolkey-1.1.0-r9.ebuild 2096 BLAKE2B cf968723617586ea25279011bdf3cb2de557be52f68e90d71500094f0e134c9b8f4601ff97d95231b6b5a15de5f425806e4980cfe830226bb9be6963aed9ffb2 SHA512 833e5196d2da412686ac4c89203bea7206e806bb7022fb1e7fcf68800bf94dacbc30d5e54e5f1b28be16bfa46faeddc8757d5fc35eb4ea7da21892160a909afd
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
index cbb3e7161b80..4a15201f3fba 100644
--- a/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
+++ b/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -47,6 +47,11 @@ src_compile() {
emake CFLAGS+="-fno-strict-aliasing" -j1
}
+src_install() {
+ emake DESTDIR="${D}" install -j1
+ einstalldocs
+}
+
pkg_postinst() {
if [[ -x $dbdir ]]; then
if ! $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
new file mode 100644
index 000000000000..cd3d7f1e434b
--- /dev/null
+++ b/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+PATCHVER="003"
+
+DESCRIPTION="Linux Driver support for the CoolKey and CAC products"
+HOMEPAGE="https://directory.fedora.redhat.com/wiki/CoolKey"
+SRC_URI="https://directory.fedora.redhat.com/download/coolkey/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCHVER}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.6.4
+ dev-libs/nss[utils]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=app-crypt/ccid-1.4.0"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${WORKDIR}/${PN}-patches"
+)
+
+pkg_setup() {
+ pk="pk11install"
+ dbdir="/etc/pki/nssdb"
+ ck_mod_name="CoolKey PKCS #11 Module"
+
+ if ! [[ -x $dbdir ]]; then
+ ewarn "No /etc/pki/nssdb found; check under \$HOME/.pki and"
+ ewarn "follow the suggested commands using the correct path."
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ econf \
+ --enable-pk11install \
+ $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install -j1
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -x $dbdir ]]; then
+ if ! $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
+ elog "You still need to install libcoolkey in your PKCS11 library:"
+ elog "$pk -p $dbdir 'name=$ck_mod_name library=libcoolkeypk11.so'"
+
+ fi
+ else
+ elog ""
+ elog "You still need to setup your PKCS11 library, or at least"
+ elog "find where it is (perhaps \$HOME/.pki/nssdb). Once you"
+ elog "find it, use 'modutil -rawlist -dbdir \$db' to look for"
+ elog "libcoolkeypk11.so, and if not found, add it using:"
+ elog ""
+ elog "$pk -p \$db 'name=$ck_mod_name library=libcoolkeypk11.so'"
+ elog ""
+ elog "where \$db is the full path to your pki/nssdb directory."
+ elog ""
+ fi
+}
+
+pkg_postrm() {
+ if [[ -x $dbdir ]]; then
+ if $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
+ elog "You should remove libcoolkey from your PKCS11 library."
+ fi
+ fi
+}