summaryrefslogtreecommitdiff
path: root/app-crypt/coolkey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/coolkey
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/coolkey')
-rw-r--r--app-crypt/coolkey/Manifest4
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r7.ebuild78
-rw-r--r--app-crypt/coolkey/metadata.xml8
3 files changed, 90 insertions, 0 deletions
diff --git a/app-crypt/coolkey/Manifest b/app-crypt/coolkey/Manifest
new file mode 100644
index 000000000000..e9d22c5ef9f1
--- /dev/null
+++ b/app-crypt/coolkey/Manifest
@@ -0,0 +1,4 @@
+DIST coolkey-1.1.0-patches-003.tar.gz 21263 BLAKE2B 27025b8aa24df45f8efa872122a1c3699db6d0d627861182c7eb1d61b921d026d7e3355d1b3d12608747ed1d214eee764b53dbbc5599c452b347e191e1516eca SHA512 25a5fac68ca041fcf9e927d134d0179fa286e6de75019e7bbf205edeaf73222d9fb9fd3861a8f6e0d933d1a09229e3e727278c3a9b3cc63390ef07774c46390d
+DIST coolkey-1.1.0.tar.gz 432808 BLAKE2B 7e443cdb0dedcec5de32cf5c7cc5eb2d81f1d51fbc2e580fda302153d3f8a919bc89d2308b8799cf395c89d16150e09bd33bc76eacb8af855c54b961bb5d082a SHA512 4b61de9b40abcf620fbb519d5e3cf1e93ebdd0470854cb63a597fc91e0182998217353014327f7bc4f255d22515d8ea2b08d36b3a831f5f09134fdcd418bc08b
+EBUILD coolkey-1.1.0-r7.ebuild 1947 BLAKE2B 679cfab4ae924f31d97aae3239fe459979aefeef778fbd7581ecc8e92dc1163f3fe2768b44016262fe34697b2561c912fca012d2b6083d5db8f1c3413db95d43 SHA512 7997511e43ffa4969a05523cbdfe5c757ed5bc80ca284bc072f5f78ba4ba9841df04835e2cf90a3142d8d2f8a2dde22becc37be3590462387c44aadcd09b8f35
+MISC metadata.xml 236 BLAKE2B a7bb92e6d53f7252ee56a885bf098930e228a76a75bca119358ca860901ceeecccc43efe5279c54250ebda58f77ae9c97d2ae540d8b399283cb3aa348111fcd2 SHA512 5f6cd6a85527534d5de7118de5af212ee3044c8c5530a7f7087a28074a2d4ab7be1728325bd985adc063dc795d3cf2b1c4e58a4c4c4ec02d739bd4bbc544ef08
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
new file mode 100644
index 000000000000..79c08285e155
--- /dev/null
+++ b/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PATCHVER="003"
+
+DESCRIPTION="Linux Driver support for the CoolKey and CAC products"
+HOMEPAGE="https://directory.fedora.redhat.com/wiki/CoolKey"
+SRC_URI="https://directory.fedora.redhat.com/download/coolkey/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCHVER}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.6.4
+ dev-libs/nss[utils]
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ >=app-crypt/ccid-1.4.0
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${WORKDIR}/${PN}-patches"
+)
+
+pkg_setup() {
+ pk="pk11install"
+ dbdir="/etc/pki/nssdb"
+ ck_mod_name="CoolKey PKCS #11 Module"
+
+ if ! [[ -x $dbdir ]]; then
+ ewarn "No /etc/pki/nssdb found; check under \$HOME/.pki and"
+ ewarn "follow the suggested commands using the correct path."
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-pk11install \
+ $(use_enable debug)
+}
+
+src_compile() {
+ emake CFLAGS+="-fno-strict-aliasing" -j1
+}
+
+pkg_postinst() {
+ if [[ -x $dbdir ]]; then
+ if ! $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
+ elog "You still need to install libcoolkey in your PKCS11 library:"
+ elog "$pk -p $dbdir 'name=$ck_mod_name library=libcoolkeypk11.so'"
+
+ fi
+ else
+ elog ""
+ elog "You still need to setup your PKCS11 library, or at least"
+ elog "find where it is (perhaps \$HOME/.pki/nssdb). Once you"
+ elog "find it, use 'modutil -rawlist -dbdir \$db' to look for"
+ elog "libcoolkeypk11.so, and if not found, add it using:"
+ elog ""
+ elog "$pk -p \$db 'name=$ck_mod_name library=libcoolkeypk11.so'"
+ elog ""
+ elog "where \$db is the full path to your pki/nssdb directory."
+ elog ""
+ fi
+}
+
+pkg_postrm() {
+ if [[ -x $dbdir ]]; then
+ if $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
+ elog "You should remove libcoolkey from your PKCS11 library."
+ fi
+ fi
+}
diff --git a/app-crypt/coolkey/metadata.xml b/app-crypt/coolkey/metadata.xml
new file mode 100644
index 000000000000..f1c3d59fb213
--- /dev/null
+++ b/app-crypt/coolkey/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+</maintainer>
+</pkgmetadata>