summaryrefslogtreecommitdiff
path: root/app-crypt/coolkey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-14 19:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-14 19:44:42 +0100
commit4392d53af7ce45ccfe6eb14146479ef0e2bd790a (patch)
tree505de6d6499defff572e53779c70f5fac1118499 /app-crypt/coolkey
parent926f46a6d07cdbc78d625b2dfca6a3c27a95b14a (diff)
gentoo auto-resync : 14:10:2022 - 19:44:42
Diffstat (limited to 'app-crypt/coolkey')
-rw-r--r--app-crypt/coolkey/Manifest3
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r9.ebuild3
-rw-r--r--app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch13
3 files changed, 17 insertions, 2 deletions
diff --git a/app-crypt/coolkey/Manifest b/app-crypt/coolkey/Manifest
index 6068b0598d20..e36d873fb90b 100644
--- a/app-crypt/coolkey/Manifest
+++ b/app-crypt/coolkey/Manifest
@@ -1,4 +1,5 @@
+AUX coolkey-1.1.0-clang16.patch 359 BLAKE2B 9d30f8e44bd7b418c43970e7a1b5cef281d1f8dffc6ddd8491b7e5b1ec5c4428620f4aa11dab95a8d1dd23477b8517841601f69d1c1352e8bd2644a8b39b2f48 SHA512 a97d0419bc962ee112db89e78494423f3cd99a617bbce5406a7a74579fdc4367662555a9b7ba21d90b9d59910619345a93d1bdc412f1657a4e82956753f82d8c
DIST coolkey-1.1.0-patches-003.tar.gz 21263 BLAKE2B 27025b8aa24df45f8efa872122a1c3699db6d0d627861182c7eb1d61b921d026d7e3355d1b3d12608747ed1d214eee764b53dbbc5599c452b347e191e1516eca SHA512 25a5fac68ca041fcf9e927d134d0179fa286e6de75019e7bbf205edeaf73222d9fb9fd3861a8f6e0d933d1a09229e3e727278c3a9b3cc63390ef07774c46390d
DIST coolkey-1.1.0.tar.gz 432808 BLAKE2B 7e443cdb0dedcec5de32cf5c7cc5eb2d81f1d51fbc2e580fda302153d3f8a919bc89d2308b8799cf395c89d16150e09bd33bc76eacb8af855c54b961bb5d082a SHA512 4b61de9b40abcf620fbb519d5e3cf1e93ebdd0470854cb63a597fc91e0182998217353014327f7bc4f255d22515d8ea2b08d36b3a831f5f09134fdcd418bc08b
-EBUILD coolkey-1.1.0-r9.ebuild 2096 BLAKE2B cf968723617586ea25279011bdf3cb2de557be52f68e90d71500094f0e134c9b8f4601ff97d95231b6b5a15de5f425806e4980cfe830226bb9be6963aed9ffb2 SHA512 833e5196d2da412686ac4c89203bea7206e806bb7022fb1e7fcf68800bf94dacbc30d5e54e5f1b28be16bfa46faeddc8757d5fc35eb4ea7da21892160a909afd
+EBUILD coolkey-1.1.0-r9.ebuild 2130 BLAKE2B fac9ed57d9ba491e41e23f5ed631d9158966fa19df61c962bc2673d1d36eba62a15ee5f3a9880299f98358af5af1b228a1770cf8d657b3f46c3ab66a712ad673 SHA512 71430308fb70d8bb1b164a4dbb8d6e2c2d0e5b7e80d6789f89e766a496a2d33acaa2fe19282b1646345bf0ab78b5ae22ac0a787640cd511c83dec8c9038f2676
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
index cd3d7f1e434b..d388df3391b7 100644
--- a/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
+++ b/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${WORKDIR}/${PN}-patches"
+ "${FILESDIR}/${P}-clang16.patch"
)
pkg_setup() {
diff --git a/app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch b/app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch
new file mode 100644
index 000000000000..88c3e11b53e8
--- /dev/null
+++ b/app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch
@@ -0,0 +1,13 @@
+Declaration taken from nss sources' lib/softoken/pkcs11i.h.
+Only needed with --enable-pk11install.
+
+https://bugs.gentoo.org/871585
+--- a/src/install/pk11install.c
++++ b/src/install/pk11install.c
+@@ -23,4 +23,6 @@
+ #include "pkcs11n.h"
+
++char **NSC_ModuleDBFunc(unsigned long function, char *parameters, void *args);
++
+ /*
+ * windows specific globing search