summaryrefslogtreecommitdiff
path: root/app-crypt/codecrypt/codecrypt-1.7.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
commit0bff53119f08d677db6c1a991bd30741682a8a08 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /app-crypt/codecrypt/codecrypt-1.7.6.ebuild
parent6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (diff)
Revert "gentoo resync : 02.06.2018"
This reverts commit 6c14fa2586d9e9c4427b5f727dc6c8ab77587cec.
Diffstat (limited to 'app-crypt/codecrypt/codecrypt-1.7.6.ebuild')
-rw-r--r--app-crypt/codecrypt/codecrypt-1.7.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/codecrypt/codecrypt-1.7.6.ebuild b/app-crypt/codecrypt/codecrypt-1.7.6.ebuild
new file mode 100644
index 000000000000..9a1a3f9e686d
--- /dev/null
+++ b/app-crypt/codecrypt/codecrypt-1.7.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Post-quantum cryptography tool"
+HOMEPAGE="http://e-x-a.org/codecrypt/"
+SRC_URI="http://e-x-a.org/codecrypt/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+cryptopp"
+
+DEPEND="dev-libs/gmp:=
+ cryptopp? ( dev-libs/crypto++ )
+ sci-libs/fftw:3.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ # workaround -- gentoo is missing crypto++ pkg-config file
+ sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/LDFLAGS="$LDFLAGS -lcrypto++"/' configure.ac
+ ./autogen.sh
+}
+
+src_configure() {
+ econf \
+ $(use_with cryptopp )
+}