summaryrefslogtreecommitdiff
path: root/app-crypt/ckpass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-10 19:28:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-10 19:28:02 +0100
commit62f7102650b24618880e8e6f08fcb8fbd235025b (patch)
tree914a3a8577147ada92d191ad5dd0c2b52d2673a5 /app-crypt/ckpass
parent0d7aefa5885e7552b4c2221df9f54e5930696228 (diff)
gentoo auto-resync : 10:07:2022 - 19:28:02
Diffstat (limited to 'app-crypt/ckpass')
-rw-r--r--app-crypt/ckpass/Manifest3
-rw-r--r--app-crypt/ckpass/ckpass-0.2-r2.ebuild (renamed from app-crypt/ckpass/ckpass-0.2-r1.ebuild)6
-rw-r--r--app-crypt/ckpass/files/ckpass-0.2-implicit-function-declaration.patch10
3 files changed, 16 insertions, 3 deletions
diff --git a/app-crypt/ckpass/Manifest b/app-crypt/ckpass/Manifest
index 9494131e603e..1c7afd419a27 100644
--- a/app-crypt/ckpass/Manifest
+++ b/app-crypt/ckpass/Manifest
@@ -1,4 +1,5 @@
+AUX ckpass-0.2-implicit-function-declaration.patch 199 BLAKE2B 385813cf9b2be96a21e5b66354698136969ad75bdfb6d24a418e1c5aa5b6620ca0f08516af13c39e4410fc977b1d760c62ca48fecf0456c7f923549eb583dca1 SHA512 925ed98c6300a76cc392928af71655caa27353f47a514184bc7fe0f480afe1d8d4d9533a56cba681b5a0f4658d8aa93eb0b9a6adbc278221f8396c2d9b06130b
AUX ckpass-0.2-tinfo.patch 417 BLAKE2B a99959b8c4430aa29868eee1a85d0a3868c73cab7e32861216391f73c4fcad02f3f37801aba7c33285da42208924f8e1b51b7439f87d40cfddb8cd2e565afd37 SHA512 172753fa8d0cc6050e06010e721a69c99aab3d743af80a9b63949ed0a79a4c39fefce9cc34fe711caab89c20715b982142379d57f6acac92a762d19fdb805220
DIST ckpass-0.2.tar.gz 95921 BLAKE2B f1a03e293bf9e2f26c28c63a41cfc319f938ef10bcbae1c578da5cdeb322c31649fd060e2f45a3144bee15fe6050d3f00f499f924c34305942cd6f79afdbfb87 SHA512 aca439caea2e3736539f5ec6bb235e51c59fed627eb9b414e629ad246c301e6f1dc90594826f6d95be9963aa4af0dae64419d08a44beb0a02d16a9fdf42a9a0b
-EBUILD ckpass-0.2-r1.ebuild 498 BLAKE2B bbd9a931609f6cb919dcbc6ca4e2e96fa05ffeb6026c55a9b44de3e401d62011d738c5476fd94911d2dab1c34bf536eb7f6ac0500c1b8e4df2395f5eaceaddac SHA512 24de0a86d026ae6e92fcc86dd725c7c03401bc6631ef54759bf5549dc1b2c739cdc7faa5eb3e4ec6a7cef4c8b247dda33bb7f3509929d06533181094ba7821e6
+EBUILD ckpass-0.2-r2.ebuild 552 BLAKE2B 838637f92ac61525c70d9fc7bf9e37dcee792b141d1b1dc75da3ee3087897049f48a2ab2dbd31c600ad151debc1220676a8f13492fe389e589d907d4bf1de8ae SHA512 37d9685a453aa42e90566c7f23ed285b52c2a9e07fd076458f4172302542df018f70f38c6a5f6d0e8e23230d3cb9071742ebf3e1f3901055e2f5fbee5eedabfe
MISC metadata.xml 244 BLAKE2B 9340f60d3e1c0c0d603371542505c673e20be8753b5288724b1567fd6c501264aeacc3bea1dbfd216f4be5ad91f1505b0b97466793d7dec7bc467cdddf7e2eec SHA512 9d383ee1aef15031352f3efc8d04fb0bf315b3592fbc95615abf78636806315654384fd43bc6698fef2ca6d8153ccf11681587753ab5ff1314fc84af9f5db1ee
diff --git a/app-crypt/ckpass/ckpass-0.2-r1.ebuild b/app-crypt/ckpass/ckpass-0.2-r2.ebuild
index 4b1f070d0852..48fc5954525f 100644
--- a/app-crypt/ckpass/ckpass-0.2-r1.ebuild
+++ b/app-crypt/ckpass/ckpass-0.2-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit autotools
DESCRIPTION="ncurses based password database client compatible with KeePass 1.x databases"
@@ -17,6 +18,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-implicit-function-declaration.patch
)
src_prepare() {
diff --git a/app-crypt/ckpass/files/ckpass-0.2-implicit-function-declaration.patch b/app-crypt/ckpass/files/ckpass-0.2-implicit-function-declaration.patch
new file mode 100644
index 000000000000..78dce6d1a3f3
--- /dev/null
+++ b/app-crypt/ckpass/files/ckpass-0.2-implicit-function-declaration.patch
@@ -0,0 +1,10 @@
+--- a/ckpass.c
++++ b/ckpass.c
+@@ -30,6 +30,7 @@
+ #include <string.h>
+ #include <sys/mman.h>
+ #include <sys/stat.h>
++#include <sys/wait.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <errno.h>