summaryrefslogtreecommitdiff
path: root/app-crypt/chntpw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/chntpw
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/chntpw')
-rw-r--r--app-crypt/chntpw/Manifest3
-rw-r--r--app-crypt/chntpw/chntpw-140201.ebuild52
-rw-r--r--app-crypt/chntpw/metadata.xml8
3 files changed, 63 insertions, 0 deletions
diff --git a/app-crypt/chntpw/Manifest b/app-crypt/chntpw/Manifest
new file mode 100644
index 000000000000..0db1319954b3
--- /dev/null
+++ b/app-crypt/chntpw/Manifest
@@ -0,0 +1,3 @@
+DIST chntpw-source-140201.zip 1404098 BLAKE2B 86c93861983613496fcd82879a5b000537d4a7ee2add466aa26c67feabefdb5363f610234f99615139997a04aedb448468ef8b29cc6c4bf49b2e295f41308644 SHA512 a26d747f6e077d1bb3e9b8077781f8c37dd978e07b7426495862f15c9004572b706c34736fc4d1ed8856b1a43335d726b4d87c688f7f9a11fd6cc3a74d71a7fa
+EBUILD chntpw-140201.ebuild 1043 BLAKE2B fb8c580f94825c28ceef29fd7a963b3735ec5bc1af862184afb3a471132c553c4f861ebafc65b3c166331427601f4dc54802743b06c40c4946fe91c942a54ff3 SHA512 606c62f15973aabbedf2a7912cb248ef0f53d5cc3975abe9003b239fb2e4393a7cb8033671457960d61d5fed665b001ca60c41183c84c4eb093194241e8e6557
+MISC metadata.xml 240 BLAKE2B 019d24354f525c2754c3fa8a9dfc0a35fbdf5ea285db4cbc20535f6123679544c06acae8c5ced17ae7c299318b6a0b9115b645188fccd5945ff47b6bf9cd1f1d SHA512 e94cdc08f1a8aafc0ec72615a476ed63dbacd22b48413a938f5bfbe9c2bda2cab2347465df3035b53031e0a4f935b47d22fad8c89a67e5780a5370ec9564d99d
diff --git a/app-crypt/chntpw/chntpw-140201.ebuild b/app-crypt/chntpw/chntpw-140201.ebuild
new file mode 100644
index 000000000000..f6c8a6b06250
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-140201.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libressl static"
+
+RDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ static? ( dev-libs/openssl:0[static-libs] )"
+
+DOCS=(
+ HISTORY.txt README.txt regedit.txt WinReg.txt
+)
+
+src_prepare() {
+ default
+ sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+
+ if ! use static ; then
+ sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
+ fi
+
+ emake clean
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto"
+}
+
+src_install() {
+ einstalldocs
+ dobin chntpw cpnt reged
+
+ if use static; then
+ dobin {chntpw,reged}.static
+ fi
+}
diff --git a/app-crypt/chntpw/metadata.xml b/app-crypt/chntpw/metadata.xml
new file mode 100644
index 000000000000..040cba5f7c5b
--- /dev/null
+++ b/app-crypt/chntpw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+</pkgmetadata>