summaryrefslogtreecommitdiff
path: root/app-crypt/chntpw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/chntpw
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/chntpw')
-rw-r--r--app-crypt/chntpw/Manifest5
-rw-r--r--app-crypt/chntpw/chntpw-140201.ebuild52
-rw-r--r--app-crypt/chntpw/metadata.xml8
3 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/chntpw/Manifest b/app-crypt/chntpw/Manifest
new file mode 100644
index 000000000000..952f0b1ea8eb
--- /dev/null
+++ b/app-crypt/chntpw/Manifest
@@ -0,0 +1,5 @@
+DIST chntpw-source-140201.zip 1404098 SHA256 96e20905443e24cba2f21e51162df71dd993a1c02bfa12b1be2d0801a4ee2ccc SHA512 a26d747f6e077d1bb3e9b8077781f8c37dd978e07b7426495862f15c9004572b706c34736fc4d1ed8856b1a43335d726b4d87c688f7f9a11fd6cc3a74d71a7fa WHIRLPOOL 87284c123d2ae1965d069d4d97cda23ce757305b3521f84089e43a9f1fa8aaa48f8fbad5bba19b3a439cfb16d270e0f77f528664fdba895c65c100492eb9e42a
+EBUILD chntpw-140201.ebuild 1043 SHA256 72d78850351c145b0963caf3153bcbdda05d5506d5635321a85ccfbc77c8ef2e SHA512 606c62f15973aabbedf2a7912cb248ef0f53d5cc3975abe9003b239fb2e4393a7cb8033671457960d61d5fed665b001ca60c41183c84c4eb093194241e8e6557 WHIRLPOOL 359ffda5869136cf75c790d08d4b89d695cf40122485d152d14e970452082864699e1f282c3a37d718b71e01766ff0a8274a83f3176e207e4c5ee725dea1bc19
+MISC ChangeLog 2732 SHA256 99f2f65bc545603743a39b7b9be747cce9eb866499f1596ae580deecf7d99367 SHA512 4b631faba991eb9cf84fc40ee5a8bfd292d1af63b45e3a7c4707772fb2a47dcb9f7c83d8ae535044a75c659ffebdb05edd7849b5bc1ed3a5760bd65132fcb06e WHIRLPOOL 80e7a0c144309e0627f3748df41aade0eccaaa49eaf14d258b3773527b98751eb8e0dcfcea97aad8e0f9ce867e1cd2653ea8377b3e0e0d010d2045d849fcec22
+MISC ChangeLog-2015 3321 SHA256 827aea09b5309de050099a1a9d578ab76b960c32666a2b78833a3aed8f5cfaf8 SHA512 c7657da1b5fa9da7ccbe1e72e9ce7bd54256d8a064307e882b5033d065492066a86b4cd24cd082029bfe3912c6335cf8ed287c81f7ed6870600e55cc617f1f05 WHIRLPOOL 2b8e5881a283c74d53e8f2c946d84e11541baaa88387793b470887f1893392eeb5f082675d7f20f2d1d309d1782256cadaf1b8fc17088b51a0294ab1748f6b3f
+MISC metadata.xml 240 SHA256 d1d2aa7abc46b180b2494a0cbb393768f12073097a3ddf9d118cb9e2cead8317 SHA512 e94cdc08f1a8aafc0ec72615a476ed63dbacd22b48413a938f5bfbe9c2bda2cab2347465df3035b53031e0a4f935b47d22fad8c89a67e5780a5370ec9564d99d WHIRLPOOL aad153df696809789d129412e71fd5eca91f7b230c22a10c70baa6f79e3ab57cf8890540fead3d9587f76b4396a7089921b207165fe0505917ad76b5cf86af90
diff --git a/app-crypt/chntpw/chntpw-140201.ebuild b/app-crypt/chntpw/chntpw-140201.ebuild
new file mode 100644
index 000000000000..f6c8a6b06250
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-140201.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libressl static"
+
+RDEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ static? ( dev-libs/openssl:0[static-libs] )"
+
+DOCS=(
+ HISTORY.txt README.txt regedit.txt WinReg.txt
+)
+
+src_prepare() {
+ default
+ sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+
+ if ! use static ; then
+ sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
+ fi
+
+ emake clean
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto"
+}
+
+src_install() {
+ einstalldocs
+ dobin chntpw cpnt reged
+
+ if use static; then
+ dobin {chntpw,reged}.static
+ fi
+}
diff --git a/app-crypt/chntpw/metadata.xml b/app-crypt/chntpw/metadata.xml
new file mode 100644
index 000000000000..040cba5f7c5b
--- /dev/null
+++ b/app-crypt/chntpw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+</pkgmetadata>