summaryrefslogtreecommitdiff
path: root/app-crypt/certbot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
commitf356af92b88d56b78588e81310493d4f5a2f6d18 (patch)
tree0326fb33173ae3d096527af28f85685515533fbb /app-crypt/certbot
parent560358ad7081e6bb2a4e097d4c442b0bab626163 (diff)
gentoo auto-resync : 10:05:2023 - 23:44:41
Diffstat (limited to 'app-crypt/certbot')
-rw-r--r--app-crypt/certbot/Manifest4
-rw-r--r--app-crypt/certbot/certbot-2.6.0.ebuild62
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild2
3 files changed, 66 insertions, 2 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index ebc56c6e8afa..1b6ad9e7abee 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.5.0.gh.tar.gz 1333903 BLAKE2B 2d30764616d2253fe320ad94182e64cc3e1ce75bd90322fcf7c303a52e32420a57cf84a3acf3f8f4825e058d6fe1e59438b728dacdf9032c4d8797312903825e SHA512 92313e352409d543f260fedee3f376c4750d9428cd39fde3518b162091667173ba6d582b4e91477f7122cf198f24119ecf34b2dce12734afbfc0ebedc395a49e
+DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
EBUILD certbot-2.5.0.ebuild 1542 BLAKE2B 6e26484fdaef390362347b41f1dc4962d56916f5c01fac9687dfd29604af2e34372fabd663e39dc010ad84ba909ddc7b32955cd17ce8161553160d2db9f26aff SHA512 9e7fe783fdd75b7b0724d9c2f2d86d6b033fe6dabb807513de676873cf111ec91c0ff23734d6120390b2b9640a087b9f61e3b99807c84985b930a23dace4ee99
-EBUILD certbot-9999.ebuild 1546 BLAKE2B b26f23c78d58387d48f22151be2a06a3fb746c061b6860fbc65c23edc9a348afa1e20adcec4570041a517c8d0ec51bdee833e8214ab8183b137920eb66355e6c SHA512 e208f49c909a75bf1cbecf9c8d8c987cdef255252d39e6a03a1c801b0a5939cbf819ef1424ddfa75acc5b91c9477351bd74d80956cb7277d88b4a7ad22fb34a8
+EBUILD certbot-2.6.0.ebuild 1546 BLAKE2B ab591380064d9b0bf1abe4556e553d407019e77e939b854f9b068de6aa7b075ff41e104da9d05612dacc25009bf3ebf2a8511104a3e428343553078ac18466cf SHA512 f4ed476e1058aad7f6fa7866abdb286ccf2e5c5352f3ec0e4e7e593c0d4bcab57281887bb5d7debfdba5fe7710434ea5c7fc80dcc4aedea275584028cacf4f2a
+EBUILD certbot-9999.ebuild 1546 BLAKE2B ab591380064d9b0bf1abe4556e553d407019e77e939b854f9b068de6aa7b075ff41e104da9d05612dacc25009bf3ebf2a8511104a3e428343553078ac18466cf SHA512 f4ed476e1058aad7f6fa7866abdb286ccf2e5c5352f3ec0e4e7e593c0d4bcab57281887bb5d7debfdba5fe7710434ea5c7fc80dcc4aedea275584028cacf4f2a
MISC metadata.xml 359 BLAKE2B 7f8ac46ecea304579baca80978cc35905720d1950caa183b5b5b297afab8bf6ea328324bacc438e9ecd91176230e42e55deda1c15e1ba73c63b2021ac2842c0f SHA512 a50b1db5a30eac290ac6645fcb30b0d5c4d8e51d83cff284e76358ee4fe7cef9366e40b06f532ba64a2131672972ea10b73541a9bd42cc323c17f6d26f6b0197
diff --git a/app-crypt/certbot/certbot-2.6.0.ebuild b/app-crypt/certbot/certbot-2.6.0.ebuild
new file mode 100644
index 000000000000..31a618c23d65
--- /dev/null
+++ b/app-crypt/certbot/certbot-2.6.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+S="${WORKDIR}/${P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index a8c222abcae4..31a618c23d65 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -49,7 +49,7 @@ RDEPEND="
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
>=dev-python/ConfigArgParse-0.9.3[${PYTHON_USEDEP}]
>=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
>=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
>=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
>=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]