summaryrefslogtreecommitdiff
path: root/app-crypt/certbot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-05 05:53:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-05 05:53:25 +0100
commit3f5490a92f684d302af15210584c70ed8ea3fab4 (patch)
tree641a95536c4796f995e98f72b6c4cc833c94bfac /app-crypt/certbot
parent1b2c0d19f75523db182b267901484f87abf732cf (diff)
gentoo auto-resync : 05:10:2023 - 05:53:25
Diffstat (limited to 'app-crypt/certbot')
-rw-r--r--app-crypt/certbot/Manifest4
-rw-r--r--app-crypt/certbot/certbot-2.7.0.ebuild62
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild2
3 files changed, 66 insertions, 2 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index dda83f6ca50c..361326b6b2f8 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
+DIST certbot-2.7.0.gh.tar.gz 1336481 BLAKE2B 224f26819ee55b99a26540e7f56a8466c806d08149cce511d28d77ce9f5fb8073ec65e6cfa3e0c168ca84ddcbf85478ff335b84feaadee66db6c5a811be202be SHA512 1e1defcd143f804a36b50e3104d239bf20873545474ceb654269a5879e15cfbb76a18bd569f5e6e12de1036779e72c74d9896707daabc314fc5d67acc1c5180d
EBUILD certbot-2.6.0.ebuild 1542 BLAKE2B 10c66c7271531f24633aac1c6449255f2d69c3326de897419ed47aad915856b6ab032e6411b606d8f3494553e7d5218e13f23a2dc9dbdaed0299bd6d6373cf12 SHA512 ce9805f2b4e3fb87d5786a82ff00f59c57380acaf3ff71a69ceec2b158915297075d7028ecd10b5659c16c924ca4b283b8d7703440728c637e9b6591963a17e4
-EBUILD certbot-9999.ebuild 1546 BLAKE2B ab591380064d9b0bf1abe4556e553d407019e77e939b854f9b068de6aa7b075ff41e104da9d05612dacc25009bf3ebf2a8511104a3e428343553078ac18466cf SHA512 f4ed476e1058aad7f6fa7866abdb286ccf2e5c5352f3ec0e4e7e593c0d4bcab57281887bb5d7debfdba5fe7710434ea5c7fc80dcc4aedea275584028cacf4f2a
+EBUILD certbot-2.7.0.ebuild 1546 BLAKE2B babd7b37f08f1bec100a6c677e7c2b91c8f93b8c60407991fb2bc582ce98079168412dc64ae137d0298b61ad360d4aef9b6720ec1ff120bf2c6f08f17138a6d3 SHA512 20d19fb38e4feb7999bf5d393b89596e8654d728f0027328ad6382e1bf12275034fc6cacca0732468ddba6dcec2d40a335d253b05f8302e438dd4c3c5638aca7
+EBUILD certbot-9999.ebuild 1546 BLAKE2B babd7b37f08f1bec100a6c677e7c2b91c8f93b8c60407991fb2bc582ce98079168412dc64ae137d0298b61ad360d4aef9b6720ec1ff120bf2c6f08f17138a6d3 SHA512 20d19fb38e4feb7999bf5d393b89596e8654d728f0027328ad6382e1bf12275034fc6cacca0732468ddba6dcec2d40a335d253b05f8302e438dd4c3c5638aca7
MISC metadata.xml 359 BLAKE2B 7f8ac46ecea304579baca80978cc35905720d1950caa183b5b5b297afab8bf6ea328324bacc438e9ecd91176230e42e55deda1c15e1ba73c63b2021ac2842c0f SHA512 a50b1db5a30eac290ac6645fcb30b0d5c4d8e51d83cff284e76358ee4fe7cef9366e40b06f532ba64a2131672972ea10b73541a9bd42cc323c17f6d26f6b0197
diff --git a/app-crypt/certbot/certbot-2.7.0.ebuild b/app-crypt/certbot/certbot-2.7.0.ebuild
new file mode 100644
index 000000000000..28d628bba116
--- /dev/null
+++ b/app-crypt/certbot/certbot-2.7.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+S="${WORKDIR}/${P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 31a618c23d65..28d628bba116 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -47,7 +47,7 @@ BDEPEND="
# See certbot/setup.py for acme >= dep
RDEPEND="
>=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
- >=dev-python/ConfigArgParse-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-1.5.3[${PYTHON_USEDEP}]
>=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
>=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
>=dev-python/distro-1.0.1[${PYTHON_USEDEP}]