summaryrefslogtreecommitdiff
path: root/app-crypt/certbot/certbot-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /app-crypt/certbot/certbot-9999.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'app-crypt/certbot/certbot-9999.ebuild')
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index ec673774775d..c81039179f59 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -38,14 +38,12 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
-DEPEND="
- ${CDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- # acme is not installed, removing it here is fine, the dir just confuses tests
- rm -R ../acme
- pytest -vv ${PN} || die
+DEPEND="${CDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # required as deps of deps can trigger this too...
+ echo ' ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
+ distutils-r1_python_prepare_all
}