summaryrefslogtreecommitdiff
path: root/app-crypt/certbot-nginx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
commitf356af92b88d56b78588e81310493d4f5a2f6d18 (patch)
tree0326fb33173ae3d096527af28f85685515533fbb /app-crypt/certbot-nginx
parent560358ad7081e6bb2a4e097d4c442b0bab626163 (diff)
gentoo auto-resync : 10:05:2023 - 23:44:41
Diffstat (limited to 'app-crypt/certbot-nginx')
-rw-r--r--app-crypt/certbot-nginx/Manifest2
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-2.6.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 6808aac02b0e..fad948e06e0f 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.5.0.gh.tar.gz 1333903 BLAKE2B 2d30764616d2253fe320ad94182e64cc3e1ce75bd90322fcf7c303a52e32420a57cf84a3acf3f8f4825e058d6fe1e59438b728dacdf9032c4d8797312903825e SHA512 92313e352409d543f260fedee3f376c4750d9428cd39fde3518b162091667173ba6d582b4e91477f7122cf198f24119ecf34b2dce12734afbfc0ebedc395a49e
+DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
EBUILD certbot-nginx-2.5.0-r1.ebuild 1184 BLAKE2B 6c732ea779afcb9913a2869f0b8b7f8d8a21c1604f96598b57de17eca68eb89df1b178f6189de3560e5530c501797524f5fc7a567a6b55195c2936e6a9476470 SHA512 0d816b6d331691f1ace1429d937a128d4b49217077c6004a2ac2fcec8ab27157e5ed5d45dc08b908aff8a0327e9952ce79207770278a5b093d4f1636aeae479b
+EBUILD certbot-nginx-2.6.0.ebuild 1186 BLAKE2B 65530ebcce256a39830ef523a31cfc8ee371b7e0331a618d65d8351fa3bc2819bfe5b8941f5a2a10664ddfb66d40fb9e16e9250ed00323ebaf0996893c44a966 SHA512 89c10ba181f1f83e04ad06e05db20dea7bec7b1943fd69d07f5bce8a9544f798272f458c381ca357c7e7e22c62cd2dec6c6972c68938895263bec0041e2cd792
EBUILD certbot-nginx-9999.ebuild 1186 BLAKE2B 65530ebcce256a39830ef523a31cfc8ee371b7e0331a618d65d8351fa3bc2819bfe5b8941f5a2a10664ddfb66d40fb9e16e9250ed00323ebaf0996893c44a966 SHA512 89c10ba181f1f83e04ad06e05db20dea7bec7b1943fd69d07f5bce8a9544f798272f458c381ca357c7e7e22c62cd2dec6c6972c68938895263bec0041e2cd792
MISC metadata.xml 335 BLAKE2B 048854ec6bc919f9bf9b0bc74e7c291841cbfea0e571f43437937c5dd78cc65f9df53463adcf313441e01323491709b462bd9bc364876eb1508a83b3426b6b78 SHA512 25ac45574a568e362c419dfbeade4a977afa2885e7b32fb4c3d4c765450b09aa98cf419df1a39ab194518ad6f2b582e162d4dd4eec14f278635d63bf66352523
diff --git a/app-crypt/certbot-nginx/certbot-nginx-2.6.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-2.6.0.ebuild
new file mode 100644
index 000000000000..681a2d89b66e
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-2.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-nginx}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Nginx plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
+# to avoid broken 23.1.0.
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest