summaryrefslogtreecommitdiff
path: root/app-crypt/certbot-apache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 23:44:42 +0100
commitf356af92b88d56b78588e81310493d4f5a2f6d18 (patch)
tree0326fb33173ae3d096527af28f85685515533fbb /app-crypt/certbot-apache
parent560358ad7081e6bb2a4e097d4c442b0bab626163 (diff)
gentoo auto-resync : 10:05:2023 - 23:44:41
Diffstat (limited to 'app-crypt/certbot-apache')
-rw-r--r--app-crypt/certbot-apache/Manifest2
-rw-r--r--app-crypt/certbot-apache/certbot-apache-2.6.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 5bc3c28c6046..86a207743e88 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.5.0.gh.tar.gz 1333903 BLAKE2B 2d30764616d2253fe320ad94182e64cc3e1ce75bd90322fcf7c303a52e32420a57cf84a3acf3f8f4825e058d6fe1e59438b728dacdf9032c4d8797312903825e SHA512 92313e352409d543f260fedee3f376c4750d9428cd39fde3518b162091667173ba6d582b4e91477f7122cf198f24119ecf34b2dce12734afbfc0ebedc395a49e
+DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
EBUILD certbot-apache-2.5.0.ebuild 1076 BLAKE2B 08b8fd1aa6726099790797ecc9d8a943aab30e3101b5a6c8a86f10025edcdb2094f63b663d81d83327552e4fd974a2c9c26b2f60fda699f4d131ae8f397dfac4 SHA512 2212ce672ea10a1bc8449f158470feeac543f9a4ea3c1ebcf0c0b4d01d89e17ef3601f1c1ba415fdeb8104b4dab570ca6877c8d99193722047b76bbae3cb848e
+EBUILD certbot-apache-2.6.0.ebuild 1078 BLAKE2B 4c6a746c517a83b34a69b3501317ccf29a341c5c5e02e8a0129992e53c757af939582566694a3c927801bfdc0d8a743a83b81ac76a523a0a7be0bc283eb0e747 SHA512 776da4da5cee6e6840e323aab45f741e16821ed5231f600fe7454016de55c040863bdaa70f5f4f8cb4f88e8d8d5f123d51487268dc15770e4496267990a41992
EBUILD certbot-apache-9999.ebuild 1078 BLAKE2B 4c6a746c517a83b34a69b3501317ccf29a341c5c5e02e8a0129992e53c757af939582566694a3c927801bfdc0d8a743a83b81ac76a523a0a7be0bc283eb0e747 SHA512 776da4da5cee6e6840e323aab45f741e16821ed5231f600fe7454016de55c040863bdaa70f5f4f8cb4f88e8d8d5f123d51487268dc15770e4496267990a41992
MISC metadata.xml 359 BLAKE2B 7f8ac46ecea304579baca80978cc35905720d1950caa183b5b5b297afab8bf6ea328324bacc438e9ecd91176230e42e55deda1c15e1ba73c63b2021ac2842c0f SHA512 a50b1db5a30eac290ac6645fcb30b0d5c4d8e51d83cff284e76358ee4fe7cef9366e40b06f532ba64a2131672972ea10b73541a9bd42cc323c17f6d26f6b0197
diff --git a/app-crypt/certbot-apache/certbot-apache-2.6.0.ebuild b/app-crypt/certbot-apache/certbot-apache-2.6.0.ebuild
new file mode 100644
index 000000000000..4d1707d36f00
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-2.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-apache}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ # Only for amd64, arm64 and x86 because of dev-python/python-augeas
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Apache plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest