summaryrefslogtreecommitdiff
path: root/app-crypt/bcwipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/bcwipe
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/bcwipe')
-rw-r--r--app-crypt/bcwipe/Manifest6
-rw-r--r--app-crypt/bcwipe/bcwipe-1.9.13.ebuild46
-rw-r--r--app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch20
-rw-r--r--app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch11
-rw-r--r--app-crypt/bcwipe/metadata.xml8
5 files changed, 91 insertions, 0 deletions
diff --git a/app-crypt/bcwipe/Manifest b/app-crypt/bcwipe/Manifest
new file mode 100644
index 000000000000..1aaeb251bda6
--- /dev/null
+++ b/app-crypt/bcwipe/Manifest
@@ -0,0 +1,6 @@
+AUX bcwipe-1.9.7-fix_warnings.patch 415 BLAKE2B ae41040cbc9343e06eaee372b8bdb656eaac711faa2cc437ac59043c9dd58950234ff67637d5e8b0faba4c9a18bba270f53255fd87590ed7ee753d47b3818630 SHA512 504487c91ba3ed47f5d32ff5c4084bfcc10999d5ab42018d233ca160f55631daf466015e8aa81f644b834c00529a984ec026a05f28d7401162bc786a8bdcd5ad
+AUX bcwipe-1.9.8-fix-flags.patch 603 BLAKE2B 094af104ff114c4fce3907215ab06db51af2fad2f000f9bfc391dd056432a2c6c5a988561d7c462f6fc99411fc26c9445f81a250db29899f76ee1c0672b9e602 SHA512 9141f81dd722bfe59466bab3d547869aca9178d27912edc61f9ab95044d0e57151870400a1550fe59e0f3c252878b6971486d0b38e2fb24da3241b0dca00ca87
+DIST BCWipe-1.9-13.tar.gz 141092 BLAKE2B 0d7e8f5841b388bb9e200ae533f8706d951e017923a69314173d44fcbec2ac2f3ab8c0c97de9054e12f1560f075e5af0e32ddac855df8f9bc28fb1bb637edbc6 SHA512 801b6d3c55d82915da14b3136c9ddba7fc947b40c07ba135c410e1e2703f74735d32ebb043d44325f615005631930ce48b4075885f1a928cf8f4a2d4c67ca5cc
+DIST BCWipe.doc.tgz 21218 BLAKE2B 02ce8b5c767ed9d45615fa26b5c0172c5431209cbd7ca94bfed4345206b401db50e02a163eef14359a01d16cc4a1b26b121081611cc7854833e7cbd917ae947c SHA512 5aa402669ded46b6dc680293f18aea4ab20a7d6b7d9d7bf8e63003e557b953e8f8019431ea69d96d2236121e754bc456b3700a0895f4fff0573d2e9bac2e2ee3
+EBUILD bcwipe-1.9.13.ebuild 1036 BLAKE2B 4c4c433068bfe57df1c4d0e6bf03c4f84b9e8082740bdf06b03bf8d3a2b26faf00b5915f5554927261838c3533fce2e46488d960a3c185609e3e2453ed29793a SHA512 7a68bfbf12923948a6bebf5ddd1f6d111f2c3d2870a2f4e7f40b67179cd1aca58e6d8e9de01c3705eb7118cbcd8e2059908e5d3297f4753a134e509f4c5fb38a
+MISC metadata.xml 240 BLAKE2B 019d24354f525c2754c3fa8a9dfc0a35fbdf5ea285db4cbc20535f6123679544c06acae8c5ced17ae7c299318b6a0b9115b645188fccd5945ff47b6bf9cd1f1d SHA512 e94cdc08f1a8aafc0ec72615a476ed63dbacd22b48413a938f5bfbe9c2bda2cab2347465df3035b53031e0a4f935b47d22fad8c89a67e5780a5370ec9564d99d
diff --git a/app-crypt/bcwipe/bcwipe-1.9.13.ebuild b/app-crypt/bcwipe/bcwipe-1.9.13.ebuild
new file mode 100644
index 000000000000..21e09193785c
--- /dev/null
+++ b/app-crypt/bcwipe/bcwipe-1.9.13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit versionator
+
+MY_PV="$(replace_version_separator 2 -)"
+
+DESCRIPTION="Secure file removal utility"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="https://www.jetico.com/linux/BCWipe-${MY_PV}.tar.gz
+ doc? ( http://www.jetico.com/linux/BCWipe.doc.tgz )"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="amd64 ~arm ppc x86"
+
+DEPEND=""
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.9.7-fix_warnings.patch"
+ "${FILESDIR}/${PN}-1.9.8-fix-flags.patch"
+)
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_test() {
+ echo "abc123" >> testfile
+ ./bcwipe -f testfile || die "bcwipe test failed"
+ [[ -f testfile ]] && die "test file still exists. bcwipe should have deleted it"
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r ../bcwipe-help
+}
+
+pkg_postinst() {
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn "full details /usr/share/doc/${PF}/bcwipe-help/wu_licen.htm"
+}
diff --git a/app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch b/app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch
new file mode 100644
index 000000000000..e2b9eed3b3eb
--- /dev/null
+++ b/app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch
@@ -0,0 +1,20 @@
+--- a/schemes.c
++++ b/schemes.c
+@@ -15,6 +15,7 @@
+ *
+ *******************************************************************/
+ #include "config.h"
++#include <ctype.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <errno.h>
+--- a/wipe.c
++++ b/wipe.c
+@@ -42,6 +42,7 @@
+ #include <sys/ioctl.h>
+ #include <signal.h>
+ #include <time.h>
++#include <sys/time.h>
+ #include <ctype.h>
+
+ #if HAVE_SYS_DISKIO_H /* HP-UX */
diff --git a/app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch b/app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch
new file mode 100644
index 000000000000..e4c5cff39ed1
--- /dev/null
+++ b/app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in 2011-02-23 01:07:29.841894634 +0100
++++ b/Makefile.in 2011-02-23 01:07:46.626793943 +0100
+@@ -174,7 +174,7 @@
+ bcwipe_SOURCES = wipe.c wipe.h options.c options.h schemes.c schemes.h sha1.c sha1.h sha1random.c sha1random.h log.c log.h standard.h rand.h rand.c prng.c
+ man_MANS = bcwipe.1
+ EXTRA_DIST = $(man_MANS) bcwipe.spec.in osxpkg.sh.in
+-AM_CFLAGS = -g -D_LARGE_FILES -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++AM_CFLAGS = -D_LARGE_FILES -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
diff --git a/app-crypt/bcwipe/metadata.xml b/app-crypt/bcwipe/metadata.xml
new file mode 100644
index 000000000000..040cba5f7c5b
--- /dev/null
+++ b/app-crypt/bcwipe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+</pkgmetadata>