summaryrefslogtreecommitdiff
path: root/app-crypt/asekey
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/asekey
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/asekey')
-rw-r--r--app-crypt/asekey/Manifest4
-rw-r--r--app-crypt/asekey/asekey-3.7.ebuild34
-rw-r--r--app-crypt/asekey/files/asekey-3.7-bundle.patch24
-rw-r--r--app-crypt/asekey/metadata.xml8
4 files changed, 70 insertions, 0 deletions
diff --git a/app-crypt/asekey/Manifest b/app-crypt/asekey/Manifest
new file mode 100644
index 000000000000..1927e64c6c94
--- /dev/null
+++ b/app-crypt/asekey/Manifest
@@ -0,0 +1,4 @@
+AUX asekey-3.7-bundle.patch 727 BLAKE2B 0758992095369eadb49e4daec62a0786e790acf7e39f980f74627440b53a4eae8ac57be07cb0cabbb898e207adda3e543631e9b398770e72cc4e38fd1e153a16 SHA512 4cc556687f59371d0f1919f8649b705801da4427cdc011a40b9627601e90cd27f3a06684a721cb25f1c51b10ec28f6ae728e33fbc30217716250d42c6c15efe2
+DIST asekey-3.7.tar.bz2 33304 BLAKE2B 95bba8ded9557105dba50a587665ee638162ae6eefe1017a4ed272364eec1da7154b21833ed2f08fa7f4c3d570971795a0a6f65efebe517124da572d0b9b7d91 SHA512 29a01f8250d5fb26a4ba2aca562211cadf403c9e986f9fa6930faf477c374e13095c025b2917e6e837cbe8d83f3a3e023a527598b151ef1c704247c7e7c40647
+EBUILD asekey-3.7.ebuild 695 BLAKE2B 6300b3cd2068f97b05a58ad5f80ed14607f983d31ca30b14e964ecb9870210658246a27cce5da5e42436ccef5467dc32619dcdc57820e27e1c7d81045026a8f7 SHA512 ce08ce55c3469ffeea99c6b9532cae49abd820b473f659ed0a15ead69629774a2aceb25a8007935616e52c3fd6eeb90c071f24a320fe6199905f6fe8aca2f047
+MISC metadata.xml 240 BLAKE2B 019d24354f525c2754c3fa8a9dfc0a35fbdf5ea285db4cbc20535f6123679544c06acae8c5ced17ae7c299318b6a0b9115b645188fccd5945ff47b6bf9cd1f1d SHA512 e94cdc08f1a8aafc0ec72615a476ed63dbacd22b48413a938f5bfbe9c2bda2cab2347465df3035b53031e0a4f935b47d22fad8c89a67e5780a5370ec9564d99d
diff --git a/app-crypt/asekey/asekey-3.7.ebuild b/app-crypt/asekey/asekey-3.7.ebuild
new file mode 100644
index 000000000000..4c35c71eb638
--- /dev/null
+++ b/app-crypt/asekey/asekey-3.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit udev
+
+DESCRIPTION="ASEKey USB SIM Card Reader"
+HOMEPAGE="http://www.athena-scs.com/"
+SRC_URI="${HOMEPAGE}/docs/reader-drivers/${PN}-${PV/./-}-tar.bz2 -> ${P}.tar.bz2"
+LICENSE="BSD LGPL-2.1"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-apps/pcsc-lite[udev]"
+RDEPEND="${RDEPEND}
+ virtual/libusb:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-bundle.patch"
+)
+
+src_prepare() {
+ default
+ sed -i -e 's/GROUP="pcscd"/ENV{PCSCD}="1"/' "92_pcscd_${PN}.rules" || die
+}
+
+src_configure() {
+ econf --with-udev-rules-dir="$(get_udevdir)/rules.d"
+}
diff --git a/app-crypt/asekey/files/asekey-3.7-bundle.patch b/app-crypt/asekey/files/asekey-3.7-bundle.patch
new file mode 100644
index 000000000000..fd233001718e
--- /dev/null
+++ b/app-crypt/asekey/files/asekey-3.7-bundle.patch
@@ -0,0 +1,24 @@
+diff --git a/Info.plist b/Info.plist
+index ed473da..9d59815 100644
+--- a/Info.plist
++++ b/Info.plist
+@@ -14,6 +14,7 @@
+ <string>ASEKey</string>
+ <string>ASEKey</string>
+ </array>
++ <key>CFBundleExecutable</key>
+ <array>
+ <string>libASEKey.so</string>
+ <string>libASEKey.so</string>
+diff --git a/Makefile b/Makefile
+index 285ceff..1b06fd1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,7 +28,6 @@ clean:
+
+ install: all
+ install -c -d "${DRIVER_DIR}/Contents/${KERNEL_NAME}"
+- install -c -m 0755 libASEKey.so "${DRIVER_DIR}"
+ install -c -m 0644 Info.plist "${DRIVER_DIR}/Contents/"
+ install -c -m 0755 libASEKey.so "${DRIVER_DIR}/Contents/${KERNEL_NAME}"
+ install -c -d "${UDEV_DIR}"
diff --git a/app-crypt/asekey/metadata.xml b/app-crypt/asekey/metadata.xml
new file mode 100644
index 000000000000..040cba5f7c5b
--- /dev/null
+++ b/app-crypt/asekey/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+</pkgmetadata>