summaryrefslogtreecommitdiff
path: root/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild')
-rw-r--r--app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild b/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild
new file mode 100644
index 000000000000..f4fe0e818025
--- /dev/null
+++ b/app-crypt/asedriveiiie-serial/asedriveiiie-serial-3.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="ASEDriveIIIe Serial Card Reader"
+HOMEPAGE="http://www.athena-scs.com"
+SRC_URI="http://www.athena-scs.com/downloads/${P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+RDEPEND=">=sys-apps/pcsc-lite-1.3.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_install() {
+ default
+
+ local conf="/etc/reader.conf.d/${PN}.conf"
+
+ dodir "$(dirname "${conf}")"
+ insinto "$(dirname "${conf}")"
+ newins "etc/reader.conf" "$(basename "${conf}")"
+}
+
+pkg_postinst() {
+ elog "NOTICE:"
+ elog "1. Update ${conf} file"
+ elog "2. Run update-reader.conf, yes this is a command..."
+ elog "3. Restart pcscd"
+}
+
+pkg_postrm() {
+ #
+ # Without this, pcscd will not start next time.
+ #
+ local conf="/etc/reader.conf.d/${PN}.conf"
+ if ! [ -f "$(grep LIBPATH "${conf}" | sed 's/LIBPATH *//' | sed 's/ *$//g' | head -n 1)" ]; then
+ rm "${conf}"
+ update-reader.conf
+ elog "NOTICE:"
+ elog "You need to restart pcscd"
+ fi
+}