summaryrefslogtreecommitdiff
path: root/app-crypt/argon2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/argon2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/argon2')
-rw-r--r--app-crypt/argon2/Manifest6
-rw-r--r--app-crypt/argon2/argon2-20161029-r1.ebuild34
-rw-r--r--app-crypt/argon2/argon2-20171227.ebuild27
-rw-r--r--app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch28
-rw-r--r--app-crypt/argon2/metadata.xml19
5 files changed, 114 insertions, 0 deletions
diff --git a/app-crypt/argon2/Manifest b/app-crypt/argon2/Manifest
new file mode 100644
index 000000000000..a32f455556de
--- /dev/null
+++ b/app-crypt/argon2/Manifest
@@ -0,0 +1,6 @@
+AUX argon2-20161029-makefile-soname-symlinks.patch 807 BLAKE2B 128d7f8db6bc85839ba243a821ab4ba2a40708e8a4dd30be4f264b6280375defa716b430cd4a029f047e08a06a8a29ab4a07abbec50619155fa5e015bd59b48e SHA512 de2e9e0f5b378700aa01004684f7aa9fc60d6e49cd6f994663bb8bb7c357732cbf19c31a563c44b485d5b85a75ea76c283f606ce1d453864b987febd2cbeaa27
+DIST argon2-20161029.tar.gz 1506864 BLAKE2B fbb0588439e811666af027710d1e5ef182b4d1c9012ca2c60d22ce103ceca14bb392dd8916b37c1c07799dc97f9401aa66d3bd08b250dd48314aa57a8599dff5 SHA512 e1f947a97e8b5f292dd32a6f1ea0ef3f2e411629218653821886ec4e1d5f8289d5b8f4b8bf0a37e69c344a83b975c695947d6b49fd2001a0e4273bebd4792892
+DIST argon2-20171227.tar.gz 1503745 BLAKE2B 70171ce1b446974e18e6f7077f436c6b78f29fd3eb075314014219280fd984e51b00137d901175da5fcb8a8472df0cbb16ff0333a2f2f098e52d3e0ea496e2cc SHA512 9c9e1a3905e61ac6913d1e073c104477e419ddd0506adc4487e88e98d19165ed8901fe8bb11246ed0cc71b3523c190da9692d5926642f86be09c3e67510afe4d
+EBUILD argon2-20161029-r1.ebuild 1059 BLAKE2B 5af6cfcc657b155477979103e641b1449c3c95430aed7594d5a7678b6c1622672e4b8581b6465721a8645065dd3bbf8c9be9bcd6d58f8f44c8844c9a4de09992 SHA512 bf74945ccbea5cd3017a91502a4ce67c5b39b02df1882b175c9d3c857b70914f3f91d41b10c7c46fc82ee4ab8e03b4b0b291e9f16a3a41f8f54f28216533ffec
+EBUILD argon2-20171227.ebuild 870 BLAKE2B 0e6bb20eabc41ff739bf3d391a2166e768fe3d5153a24f9d8a2bc2d324f140da294b5a08befd06cbfab7147b264a4a6206122eba39d4c067bd0d279e1484e458 SHA512 8f1b1188e72c257b545a76b6a5497c93cb7eba9e4a2afd3ab5e1822b67027fbff98ae983b5fcdbb0a964960132d21a24529487296b4e134a9b8d7c9797ca895e
+MISC metadata.xml 660 BLAKE2B 1843f019c2cf7e8438209df6d90a20a9bcc88f5346aa02c953a28d84d712983fe3880b39b4b1766819bb88c670245447c37dc0c1da3b02b3f800a3d9706c4287 SHA512 76c1048a35a75b60d9e5fd56da50ba4bfe9537457e2021c226671d72e0456d2533f05361cad607cc86b8e01fd00a137a4cbc26a6d70c122918fe4e0f2ae3bee5
diff --git a/app-crypt/argon2/argon2-20161029-r1.ebuild b/app-crypt/argon2/argon2-20161029-r1.ebuild
new file mode 100644
index 000000000000..1af92a371835
--- /dev/null
+++ b/app-crypt/argon2/argon2-20161029-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Password hashing software that won the Password Hashing Competition (PHC)"
+HOMEPAGE="https://github.com/P-H-C/phc-winner-argon2"
+SRC_URI="https://github.com/P-H-C/phc-winner-argon2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 CC0-1.0 )"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="static-libs"
+
+S="${WORKDIR}/phc-winner-${P}"
+PATCHES=(
+ "${FILESDIR}/${P}-makefile-soname-symlinks.patch"
+ )
+src_prepare() {
+ default
+ if ! use static-libs; then
+ sed -i -e 's/LIBRARIES = \$(LIB_SH) \$(LIB_ST)/LIBRARIES = \$(LIB_SH)/' Makefile || die "sed failed!"
+ fi
+ sed -i -e 's/-O3 //' Makefile || die "sed failed"
+ sed -i -e 's/-g //' Makefile || die "sed failed"
+ sed -i -e "s/-march=\$(OPTTARGET) /${CFLAGS} /" Makefile || die "sed failed"
+ sed -i -e 's/CFLAGS += -march=\$(OPTTARGET)//' Makefile || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBRARY_REL=$(get_libdir) install || die
+}
diff --git a/app-crypt/argon2/argon2-20171227.ebuild b/app-crypt/argon2/argon2-20171227.ebuild
new file mode 100644
index 000000000000..cba8e3f4d236
--- /dev/null
+++ b/app-crypt/argon2/argon2-20171227.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Password hashing software that won the Password Hashing Competition (PHC)"
+HOMEPAGE="https://github.com/P-H-C/phc-winner-argon2"
+SRC_URI="https://github.com/P-H-C/phc-winner-argon2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 CC0-1.0 )"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="static-libs"
+
+S="${WORKDIR}/phc-winner-${P}"
+
+src_prepare() {
+ default
+ if ! use static-libs; then
+ sed -i -e 's/LIBRARIES = \$(LIB_SH) \$(LIB_ST)/LIBRARIES = \$(LIB_SH)/' Makefile || die "sed failed!"
+ fi
+ sed -i -e 's/-O3 //' -e 's/-g //' -e "s/-march=\$(OPTTARGET) /${CFLAGS} /" -e 's/CFLAGS += -march=\$(OPTTARGET)//' Makefile || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBRARY_REL="$(get_libdir)" install || die
+}
diff --git a/app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch b/app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch
new file mode 100644
index 000000000000..11892de11158
--- /dev/null
+++ b/app-crypt/argon2/files/argon2-20161029-makefile-soname-symlinks.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index 1838c13..85aa710 100644
+--- a/Makefile
++++ b/Makefile
+@@ -87,8 +87,10 @@ endif
+ endif
+
+ LIB_SH := lib$(LIB_NAME).$(LIB_EXT)
++LIB_SH_VERSION := $(LIB_SH).0
+ LIB_ST := lib$(LIB_NAME).a
+ LIBRARIES = $(LIB_SH) $(LIB_ST)
++INSTALL_LIBRARIES = $(LIBRARIES) $(LIB_SH_VERSION)
+ HEADERS = include/argon2.h
+
+ INSTALL = install
+@@ -153,9 +155,11 @@ format:
+ -i include/*.h src/*.c src/*.h src/blake2/*.c src/blake2/*.h
+
+ install: $(RUN) libs
++ mv $(LIB_SH) $(LIB_SH_VERSION)
++ ln -sf $(LIB_SH_VERSION) $(LIB_SH)
+ $(INSTALL) -d $(INST_INCLUDE)
+ $(INSTALL) $(HEADERS) $(INST_INCLUDE)
+ $(INSTALL) -d $(INST_LIBRARY)
+- $(INSTALL) $(LIBRARIES) $(INST_LIBRARY)
++ $(INSTALL) $(INSTALL_LIBRARIES) $(INST_LIBRARY)
+ $(INSTALL) -d $(INST_BINARY)
+ $(INSTALL) $(RUN) $(INST_BINARY)
diff --git a/app-crypt/argon2/metadata.xml b/app-crypt/argon2/metadata.xml
new file mode 100644
index 000000000000..b877484ca660
--- /dev/null
+++ b/app-crypt/argon2/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>simon-bgo@slevermann.de</email>
+ <name>Simon Levermann</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Argon2 is a password hashing tool and library that won the Password Hashing Competition (PHC)</longdescription>
+ <slots>
+ <subslots>Reflect ABI of libargon2.so.</subslots>
+ </slots>
+ <upstream>
+ <remote-id type="github">P-H-C/phc-winner-argon2</remote-id>
+ </upstream>
+</pkgmetadata>