summaryrefslogtreecommitdiff
path: root/app-crypt/af_alg/af_alg-0.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/af_alg/af_alg-0.0.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/af_alg/af_alg-0.0.1.ebuild')
-rw-r--r--app-crypt/af_alg/af_alg-0.0.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-crypt/af_alg/af_alg-0.0.1.ebuild b/app-crypt/af_alg/af_alg-0.0.1.ebuild
new file mode 100644
index 000000000000..5494c4339d9c
--- /dev/null
+++ b/app-crypt/af_alg/af_alg-0.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+MY_PN="af_alg"
+
+inherit autotools eutils libtool linux-info versionator
+
+DESCRIPTION="af_alg is an openssl crypto engine kernel interface thing"
+HOMEPAGE="https://github.com/sarnold/af_alg"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+DEPEND="virtual/linux-sources
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND=""
+
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+CONFIG_CHECK="~CRYPTO_USER_API"
+WARNING_CRYPTO_USER_API="You need to enable CONFIG_CRYPTO_USER_API in order to use this package."
+
+src_prepare() {
+ sed -i -e "s|ssl/engines|engines|" "${S}"/configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pic
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README.rst
+
+ prune_libtool_files --modules
+}