summaryrefslogtreecommitdiff
path: root/app-crypt/aespipe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/aespipe
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/aespipe')
-rw-r--r--app-crypt/aespipe/Manifest3
-rw-r--r--app-crypt/aespipe/aespipe-2.4e.ebuild28
-rw-r--r--app-crypt/aespipe/metadata.xml16
3 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/aespipe/Manifest b/app-crypt/aespipe/Manifest
new file mode 100644
index 000000000000..2649a85bc577
--- /dev/null
+++ b/app-crypt/aespipe/Manifest
@@ -0,0 +1,3 @@
+DIST aespipe-v2.4e.tar.bz2 107741 BLAKE2B 9331441214b495f042f8ac41b57203057e762156aa7b6bd9fcb8d55b3e149fb79dd0d7c06358599fefd6662d797baf4cf9ba84fc4425e637c9fef0abf1b254c7 SHA512 e038f710ac971e5ba740648c0f255e8bc9fcea9be1a6b76208a453f21f013e1662c006d4f4495fa2b2560fd9b0c236947462a9b337a120073c6a5335b29f077e
+EBUILD aespipe-2.4e.ebuild 749 BLAKE2B bcd83aee8746f3f8715bcf91f356deb535cddd59a56552157f5ad34e0fb701bfd468d8b1e5afacb8946c6d54d6a95266f255f15284267189c60a479435c44400 SHA512 aee20bf51f635afc122eb35e88038cf0441d5bc80cd13d676d2877644422dc762f9a5f73c253d235367a2a06a5e6ece931be14d55fb842f7b89861ba8b6fbac2
+MISC metadata.xml 524 BLAKE2B fa8c7f3af8af1e270a415b22b8d79ba56968a4796f8aadb6891bde03dfb1bd00f970bcd6625f44d0d85af033c5e70cdd89be85aec0fdea953d455009d9c2bf1e SHA512 f4f83f8a2e74c242163be7fc553e522b0fc6c910718658d1ffce1767193a042c5a4e86bd7ccbf8bc6cd37d68f71ee763dd02bf4df2a73845e83eee0dac6db8b5
diff --git a/app-crypt/aespipe/aespipe-2.4e.ebuild b/app-crypt/aespipe/aespipe-2.4e.ebuild
new file mode 100644
index 000000000000..56384993c289
--- /dev/null
+++ b/app-crypt/aespipe/aespipe-2.4e.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="Encrypts data from stdin to stdout"
+HOMEPAGE="http://loop-aes.sourceforge.net"
+SRC_URI="http://loop-aes.sourceforge.net/aespipe/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="+asm cpu_flags_x86_aes cpu_flags_x86_padlock static"
+DEPEND=""
+RDEPEND="app-arch/sharutils
+ app-crypt/gnupg"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf \
+ $(use_enable asm) \
+ $(use_enable cpu_flags_x86_aes intelaes) \
+ $(use_enable cpu_flags_x86_padlock padlock)
+}
diff --git a/app-crypt/aespipe/metadata.xml b/app-crypt/aespipe/metadata.xml
new file mode 100644
index 000000000000..f7a9049e7d05
--- /dev/null
+++ b/app-crypt/aespipe/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <use>
+ <flag name="asm">Enable assembly modules</flag>
+ <flag name="cpu_flags_x86_padlock">Use VIA padlock instructions,
+ detected at run time, code still works on non-padlock processors</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">loop-aes</remote-id>
+ </upstream>
+</pkgmetadata>