summaryrefslogtreecommitdiff
path: root/app-crypt/aescrypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/aescrypt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/aescrypt')
-rw-r--r--app-crypt/aescrypt/Manifest5
-rw-r--r--app-crypt/aescrypt/aescrypt-3.0.6b.ebuild31
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch62
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch40
-rw-r--r--app-crypt/aescrypt/metadata.xml8
5 files changed, 146 insertions, 0 deletions
diff --git a/app-crypt/aescrypt/Manifest b/app-crypt/aescrypt/Manifest
new file mode 100644
index 000000000000..bc126f16a159
--- /dev/null
+++ b/app-crypt/aescrypt/Manifest
@@ -0,0 +1,5 @@
+AUX aescrypt-3.0.6b-build.patch 1711 BLAKE2B df5eccdc516e0314a137b1c51e5ae05fe5e66c8defe892599b295d5720e26b3a5cde9e262b7f09faf9db0a57bc0479f3be1481b65c0f62ffcdb404db90051e5e SHA512 b19e4eba11753bb8929d14eddc4ef391c8ec62b2bb57cf63b1a74b9a27250b4719ece8f1a6b790c1f662738b92bb37da96c973dd38cdf059c7482edb3dbd0f0e
+AUX aescrypt-3.0.6b-iconv.patch 1096 BLAKE2B 91d6e74ea8b760e81887a799ee5e8709ea7afc7f499842879091dcffdca76f24cc9191ac438c03b9f7f4970f55beca1586d56f3262e5d0f1de53366464141c2e SHA512 bf8d564493ae9396f024c1e33a775a53833da9d984ff059f714362a2cc112c3e6bd575c5d64fc0f7118fd578af645f386d649483ab56c2a0cb8d9b0795161409
+DIST aescrypt-3.0.6b.tar.gz 28272 BLAKE2B ce5347b77d974c76dadaa820b5b90a56015019f846bbc61560c33032adad08576d5e5ddd7d9e1020878e35b40173a2c5e29578e2f6e98631725442beac6f19ac SHA512 4c88abc9bff50ae5d310be7dad8f29843941843f9b484d9846b08dc76c605940adbb375f7e8ffefd6e8236f35ff860a745f89226e9c171bfa70c28c16aa6626a
+EBUILD aescrypt-3.0.6b.ebuild 638 BLAKE2B 2b7d10d3a0fde0d8a98c991328a694906a90613b63bfed50db342f66071d45e09a642bc1974bd8a1d98868b6888cdeda9cfa3591525438206dc46d12a39ec1cc SHA512 00bce3b1a9526fa1144e234cd4326ea4afdcaec7a9f29d62e1f532bfd2f6dec19ecf868fa92ce7c1dfbf66e5063d0762037c6b1b267857280158b57562842993
+MISC metadata.xml 236 BLAKE2B a7bb92e6d53f7252ee56a885bf098930e228a76a75bca119358ca860901ceeecccc43efe5279c54250ebda58f77ae9c97d2ae540d8b399283cb3aa348111fcd2 SHA512 5f6cd6a85527534d5de7118de5af212ee3044c8c5530a7f7087a28074a2d4ab7be1728325bd985adc063dc795d3cf2b1c4e58a4c4c4ec02d739bd4bbc544ef08
diff --git a/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild b/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild
new file mode 100644
index 000000000000..73d76b66a2db
--- /dev/null
+++ b/app-crypt/aescrypt/aescrypt-3.0.6b.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Advanced file encryption using AES"
+HOMEPAGE="https://www.aescrypt.com/"
+SRC_URI="https://www.aescrypt.com/download/v3/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-iconv.patch"
+)
+
+src_compile() {
+ if use static; then
+ append-cflags "-DDISABLE_ICONV"
+ append-ldflags "-static"
+ fi
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
diff --git a/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch b/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch
new file mode 100644
index 000000000000..8dac5b4e6f47
--- /dev/null
+++ b/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch
@@ -0,0 +1,62 @@
+From ab74ea544739ab044af1e9b398770d31add3b435 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 2 Feb 2013 01:16:03 +0200
+Subject: [PATCH 1/2] build: respect CFLAGS, DESTDIR and permissions
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ Makefile | 18 ++++++++++--------
+ 1 file changed, 10 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ac661a8..abcdcc4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -17,7 +17,8 @@ CC=gcc
+
+ #The below line is for debugging
+ #CFLAGS=-I. -ggdb -Wall -D_FILE_OFFSET_BITS=64
+-CFLAGS=-Wall -D_FILE_OFFSET_BITS=64
++CFLAGS=-Wall
++EXTRA_CFLAGS=-D_FILE_OFFSET_BITS=64
+
+ LIBS=
+
+@@ -27,10 +28,10 @@ LIBS=
+ all: aescrypt aescrypt_keygen
+
+ aescrypt: aescrypt.o aes.o sha256.o password.o keyfile.o
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $^
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $^
+
+ aescrypt_keygen: aescrypt_keygen.o password.o
+- $(CC) $(CFLAGS) $(LIBS) -o $@ $^
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $^
+
+ test:
+ @$(CC) -DTEST -o sha.test sha256.c
+@@ -48,15 +49,16 @@ testfile: aescrypt
+ cmp test.orig.txt test.txt
+
+ %.o: %.c %.h
+- $(CC) $(CFLAGS) -c $*.c
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -c $*.c
+
+ install: aescrypt
+- install -o root -g root -m 755 aescrypt /usr/bin
+- install -o root -g root -m 755 aescrypt_keygen /usr/bin
++ install -m 755 -d $(DESTDIR)/usr/bin
++ install -m 755 aescrypt $(DESTDIR)/usr/bin
++ install -m 755 aescrypt_keygen $(DESTDIR)/usr/bin
+
+ uninstall:
+- rm -f /usr/bin/aescrypt
+- rm -f /usr/bin/aescrypt_keygen
++ rm -f $(DESTDIR)/usr/bin/aescrypt
++ rm -f $(DESTDIR)/usr/bin/aescrypt_keygen
+
+ clean:
+ rm -f *.o aescrypt aescrypt_keygen test* *test
+--
+1.7.12.4
+
diff --git a/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch b/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch
new file mode 100644
index 000000000000..616e87e38d61
--- /dev/null
+++ b/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch
@@ -0,0 +1,40 @@
+From 337cc9367a3cb4450eee245c6ceb615d0f05499d Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 2 Feb 2013 01:18:08 +0200
+Subject: [PATCH 2/2] build: support disable iconv for static build
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ password.c | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/password.c b/password.c
+index 9a2c1f8..dee79da 100644
+--- a/password.c
++++ b/password.c
+@@ -232,6 +232,15 @@ int passwd_to_utf16(unsigned char *in_passwd,
+ size_t ic_inbytesleft,
+ ic_outbytesleft;
+
++#ifdef DISABLE_ICONV
++ /* support only latin */
++ int i;
++ for (i=0;i<length+1;i++) {
++ out_passwd[i*2] = in_passwd[i];
++ out_passwd[i*2+1] = 0;
++ }
++ return length*2;
++#else
+ /* Max length is specified in character, but this function deals
+ * with bytes. So, multiply by two since we are going to create a
+ * UTF-16 string.
+@@ -273,5 +282,6 @@ int passwd_to_utf16(unsigned char *in_passwd,
+ }
+ iconv_close(condesc);
+ return (max_length - ic_outbytesleft);
++#endif
+ }
+
+--
+1.7.12.4
+
diff --git a/app-crypt/aescrypt/metadata.xml b/app-crypt/aescrypt/metadata.xml
new file mode 100644
index 000000000000..f1c3d59fb213
--- /dev/null
+++ b/app-crypt/aescrypt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+</maintainer>
+</pkgmetadata>