summaryrefslogtreecommitdiff
path: root/app-crypt/aescrypt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-crypt/aescrypt/files
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/aescrypt/files')
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch62
-rw-r--r--app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch40
2 files changed, 0 insertions, 102 deletions
diff --git a/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch b/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch
deleted file mode 100644
index 8dac5b4e6f47..000000000000
--- a/app-crypt/aescrypt/files/aescrypt-3.0.6b-build.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From ab74ea544739ab044af1e9b398770d31add3b435 Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Sat, 2 Feb 2013 01:16:03 +0200
-Subject: [PATCH 1/2] build: respect CFLAGS, DESTDIR and permissions
-
-Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
----
- Makefile | 18 ++++++++++--------
- 1 file changed, 10 insertions(+), 8 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index ac661a8..abcdcc4 100644
---- a/Makefile
-+++ b/Makefile
-@@ -17,7 +17,8 @@ CC=gcc
-
- #The below line is for debugging
- #CFLAGS=-I. -ggdb -Wall -D_FILE_OFFSET_BITS=64
--CFLAGS=-Wall -D_FILE_OFFSET_BITS=64
-+CFLAGS=-Wall
-+EXTRA_CFLAGS=-D_FILE_OFFSET_BITS=64
-
- LIBS=
-
-@@ -27,10 +28,10 @@ LIBS=
- all: aescrypt aescrypt_keygen
-
- aescrypt: aescrypt.o aes.o sha256.o password.o keyfile.o
-- $(CC) $(CFLAGS) $(LIBS) -o $@ $^
-+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $^
-
- aescrypt_keygen: aescrypt_keygen.o password.o
-- $(CC) $(CFLAGS) $(LIBS) -o $@ $^
-+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(LIBS) $(LDFLAGS) -o $@ $^
-
- test:
- @$(CC) -DTEST -o sha.test sha256.c
-@@ -48,15 +49,16 @@ testfile: aescrypt
- cmp test.orig.txt test.txt
-
- %.o: %.c %.h
-- $(CC) $(CFLAGS) -c $*.c
-+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -c $*.c
-
- install: aescrypt
-- install -o root -g root -m 755 aescrypt /usr/bin
-- install -o root -g root -m 755 aescrypt_keygen /usr/bin
-+ install -m 755 -d $(DESTDIR)/usr/bin
-+ install -m 755 aescrypt $(DESTDIR)/usr/bin
-+ install -m 755 aescrypt_keygen $(DESTDIR)/usr/bin
-
- uninstall:
-- rm -f /usr/bin/aescrypt
-- rm -f /usr/bin/aescrypt_keygen
-+ rm -f $(DESTDIR)/usr/bin/aescrypt
-+ rm -f $(DESTDIR)/usr/bin/aescrypt_keygen
-
- clean:
- rm -f *.o aescrypt aescrypt_keygen test* *test
---
-1.7.12.4
-
diff --git a/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch b/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch
deleted file mode 100644
index 616e87e38d61..000000000000
--- a/app-crypt/aescrypt/files/aescrypt-3.0.6b-iconv.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 337cc9367a3cb4450eee245c6ceb615d0f05499d Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Sat, 2 Feb 2013 01:18:08 +0200
-Subject: [PATCH 2/2] build: support disable iconv for static build
-
-Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
----
- password.c | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
-diff --git a/password.c b/password.c
-index 9a2c1f8..dee79da 100644
---- a/password.c
-+++ b/password.c
-@@ -232,6 +232,15 @@ int passwd_to_utf16(unsigned char *in_passwd,
- size_t ic_inbytesleft,
- ic_outbytesleft;
-
-+#ifdef DISABLE_ICONV
-+ /* support only latin */
-+ int i;
-+ for (i=0;i<length+1;i++) {
-+ out_passwd[i*2] = in_passwd[i];
-+ out_passwd[i*2+1] = 0;
-+ }
-+ return length*2;
-+#else
- /* Max length is specified in character, but this function deals
- * with bytes. So, multiply by two since we are going to create a
- * UTF-16 string.
-@@ -273,5 +282,6 @@ int passwd_to_utf16(unsigned char *in_passwd,
- }
- iconv_close(condesc);
- return (max_length - ic_outbytesleft);
-+#endif
- }
-
---
-1.7.12.4
-