summaryrefslogtreecommitdiff
path: root/app-crypt/adcli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-09 15:26:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-09 15:26:14 +0000
commit116b320513d92b6d49648834e8d5a043cd757feb (patch)
tree1eef0875165c4402e6dc1db35681158aed9786ca /app-crypt/adcli
parentfc2c8b325a27d1dd0e181a50517601b4fde8aa7f (diff)
gentoo auto-resync : 09:11:2022 - 15:26:14
Diffstat (limited to 'app-crypt/adcli')
-rw-r--r--app-crypt/adcli/Manifest2
-rw-r--r--app-crypt/adcli/adcli-0.9.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/adcli/Manifest b/app-crypt/adcli/Manifest
index 3c9d7c3089e8..fda1127f4042 100644
--- a/app-crypt/adcli/Manifest
+++ b/app-crypt/adcli/Manifest
@@ -1,5 +1,7 @@
AUX adcli-0.9.1-glibc-2.34-resolv.patch 1160 BLAKE2B d32a1b3a02558a17c60b8804c9b8dfe50a4f11645150c9ca39cefc5205d1961834e9a051f8d9d15987b4969f47fef17296f1576d9a523be8e633d38d307565ed SHA512 8123f3b09b38d78c2caab0a6445bf04ea7c3d2badea0cb8b35200403f28fb43b0e3863bf00628c5f3986a30d437c483871fcb50139954ccbfa885d3e8f7c8b11
AUX adcli-0.9.1-library-include-endian.h-for-le32toh.patch 586 BLAKE2B c48b0dede264e9eb26038ef6c80480229d93d6cde351f0c1fc951ea1efc77d0a18da4d045e01953e99b8ff5280c4081fd2f9a4425c289a4ff01a1e207dc79804 SHA512 8aec26b0f21ddebcf2529ae9e4052c38150d06fe5f4a95f1f011e0af5ae0781b58d40a9b3515178f1986f465ea076516ec1dc9fa81c451fdcc7dd5fe4a9cc85e
DIST adcli-0.9.1.tar.bz2 89684 BLAKE2B deaf6d3a13ad29c77a35b9f9c195dd646f384ad7c9782c15b50b26efceabae268bbb287d488ec7ed8d783d92ce7d8399f05898d30201d0d7fab7c0369c22fce1 SHA512 7e41fb51bfcb8837f9e5f6fd1fceacece0762c237dbc0f58dd581e2be8841d7a613d57507aea4534a66a2bd10ef4d01c4e04885437038c71238739db6e357d6e
+DIST adcli-0.9.2.tar.bz2 93680 BLAKE2B b5958b276ee43a0ee54aa922f27ed266d4e9fbd1c86e0c007dac9fcf9cc022e1b3ba043b782fceb00066be2577390773dc99fb8d476a6b5e6523d44d008fb667 SHA512 ae8414a0af389b6845dd92d41446a80a9dc1734b874175323c0e491d99944eab442b95ae6d3a29fc69638d2e73bf8d2c369f6fa50e9ed3968527444b78606286
EBUILD adcli-0.9.1-r2.ebuild 795 BLAKE2B f00333f24261cd5628e358c0dc597b02f8fdb25274c4770332628bf57c71f296f68fbb26381756f229bbe43f8fee040cdf41864e73be2679b807a2f9c2938d36 SHA512 fab4109877430cfb7233cde305d083ca013b4d128c69ac8dc6cb6ebbf484da4906acff3fcda1447718397386c4b8cf617ce8848897109d1cfe9dd05071b21e68
+EBUILD adcli-0.9.2.ebuild 675 BLAKE2B cd29a60aa1c0e251e29bd7cbd9dd50d547bb17713e09cba4cdee463adb93036b33a8924cde9e22f7167c4c3a091450daba00fbd59d656698e84227af5581d382 SHA512 7c91122c29b743fdd5046164219178e21f35aa04df8f515ed7dac860a366f5d6ac74b9e449b32981662ed420718d7ec4d126b57ac678f9ee11060f24aec13da2
MISC metadata.xml 408 BLAKE2B ca526749c82fcd9214e0800e78fb5a15aac9a18fec9b62c92905b363bae37977242f147fab1763cf36f172314e072ac14a04f4e294e65972430451a74737561b SHA512 50b2b3a820ca02719e74d730220bdab838f0d00e2abaf1c64479cf6af493301d4fbbe71183c28fc717e604aa1c9fca36efc67e6045b35c3ff1473916538fe4a6
diff --git a/app-crypt/adcli/adcli-0.9.2.ebuild b/app-crypt/adcli/adcli-0.9.2.ebuild
new file mode 100644
index 000000000000..3c224b561e82
--- /dev/null
+++ b/app-crypt/adcli/adcli-0.9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Tool for performing actions on an Active Directory domain"
+HOMEPAGE="https://www.freedesktop.org/software/realmd/adcli/adcli.html"
+SRC_URI="https://gitlab.freedesktop.org/realmd/adcli/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ app-crypt/mit-krb5
+ net-nds/openldap:=[sasl]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ doc? (
+ app-text/docbook-xml-dtd:4.3
+ app-text/xmlto
+ dev-libs/libxslt
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc)
+}