summaryrefslogtreecommitdiff
path: root/app-crypt/acme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
commit482a48c0e1675b1e92663b8b5222bb7261aa7956 (patch)
treeb81e02db1810214fc690a762e3a9c687d0f0c5ab /app-crypt/acme
parent37bccfe5e76c5740c4ef5ba1179e9488d8404075 (diff)
gentoo auto-resync : 13:07:2024 - 12:26:41
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest4
-rw-r--r--app-crypt/acme/acme-2.10.0.ebuild15
-rw-r--r--app-crypt/acme/acme-9999.ebuild15
3 files changed, 22 insertions, 12 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index fcea2f7c7d45..2d8b0efd26f9 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,4 +1,4 @@
DIST certbot-2.10.0.gh.tar.gz 2322931 BLAKE2B cb84815ec2db2b4b365f2f2bdee1749263b540a1b67f9195280bdb122307337d294beb403bc05b236a94ed0782b0d093e2b8527a65cb69cac949fa627388e8bd SHA512 444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd
-EBUILD acme-2.10.0.ebuild 1505 BLAKE2B adad3e39f8383ddabc5c44c32b1e15bdc947240d4c19902ece9c5020c0224b8565ab9a8c9c9f6a3eb6bb1cac434feca8813c06488788dfd11094738f78c02062 SHA512 3f33ac1862f9a7fae75d94f3d7cc5b25a3ce67b3b3386adf16590d6bfce0115b87d15ac973bd44c8e1fc758345cd099cf681267a7aecd4209cde181ba020ec8a
-EBUILD acme-9999.ebuild 1509 BLAKE2B 7c3b706bb30d7df6cf4e5266da927d5ee8b9945a50c7ffc207b971c1932dfb5ef397bedc498cd489afc436af2a471a8016ebf7791f6e0d8187b96f128110fe54 SHA512 e446e337620c4fa03a2a15c352ebe2cfa819a624a179cb26f2a5e60557e8a9a007ba7d83c06ead880eae2333ac5f38b9a87d4a1d79f89c49bbb16af413aa3ca1
+EBUILD acme-2.10.0.ebuild 1531 BLAKE2B 15f0041fcccb610f9fc9b4ca24ebcf871b5577bdc82e266c7fb4efe929dc431bd4020ee903510399fea14972d0a20590ca3471d6ec7c5f02e6cd0e4c0e406372 SHA512 b63e983e64a5a65f5c5f19a579c57ee8269ae8840e3c2afd2c16b2d4bc57290425d49d7882de4b1afcf7a5bfaf51bdea524e4f93d127d13eb2452a38e3f65270
+EBUILD acme-9999.ebuild 1535 BLAKE2B 33a51a7dac9b7af72bcedeec816cbe5142a948f2d86c1843020c356c020a9b835a38fea1b557148c9b1b3727753d391c31e13a5533553e0c030c6d5fb93c5ce9 SHA512 1d88d4a3814ee9204b57d2f2623bdf7afc29d9c3cceece965802cfb03361e30bab6f4e8cf66bb31b41e3353e63d0f4383c1e17ab1b4789aaa196e2367e647193
MISC metadata.xml 401 BLAKE2B 30a2ac1f03749a8e3bb98723c57f47ab6bcf7bfa58c2b6e21c309fae279feca0d3612df6c2a1dafaf27b4f0781c583a140322feac1a1cf2c13e50861cad129ea SHA512 d8e725b71ca81ce4ca6565ed58271b283c25394448f0f48f726f232122577c33d5b2d726e117419b2fae99f9dae29a8080bb9564eccbca13368c83988cf3da01
diff --git a/app-crypt/acme/acme-2.10.0.ebuild b/app-crypt/acme/acme-2.10.0.ebuild
index c4eb5dcd71c8..92f4d9253ea9 100644
--- a/app-crypt/acme/acme-2.10.0.ebuild
+++ b/app-crypt/acme/acme-2.10.0.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -27,7 +27,8 @@ fi
DESCRIPTION="An implementation of the ACME protocol"
HOMEPAGE="
- https://github.com/certbot/certbot
+ https://github.com/certbot/certbot/
+ https://pypi.org/project/acme/
https://letsencrypt.org/
"
@@ -37,8 +38,6 @@ SLOT="0"
BDEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"
@@ -55,5 +54,11 @@ RDEPEND="
>=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
"
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 1bdc2aa52244..7cc340a48d80 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -27,7 +27,8 @@ fi
DESCRIPTION="An implementation of the ACME protocol"
HOMEPAGE="
- https://github.com/certbot/certbot
+ https://github.com/certbot/certbot/
+ https://pypi.org/project/acme/
https://letsencrypt.org/
"
@@ -37,8 +38,6 @@ SLOT="0"
BDEPEND="
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
"
@@ -55,5 +54,11 @@ RDEPEND="
>=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
"
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}