summaryrefslogtreecommitdiff
path: root/app-crypt/acme/acme-1.31.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 07:21:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 07:21:11 +0100
commit86b151cdc26e1566efef728aac4ebb2aabce776a (patch)
treecddf785c30aaa09d058e8944cea2581743b189dd /app-crypt/acme/acme-1.31.0.ebuild
parenta4f9ab81d6cbfc3ff649dd3577e3efa700b47387 (diff)
gentoo auto-resync : 06:10:2022 - 07:21:10
Diffstat (limited to 'app-crypt/acme/acme-1.31.0.ebuild')
-rw-r--r--app-crypt/acme/acme-1.31.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/acme/acme-1.31.0.ebuild b/app-crypt/acme/acme-1.31.0.ebuild
new file mode 100644
index 000000000000..a905a81b75cc
--- /dev/null
+++ b/app-crypt/acme/acme-1.31.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest