summaryrefslogtreecommitdiff
path: root/app-containers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-15 12:11:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-15 12:11:39 +0100
commit08e318096831eb3aae369910ba75e27f59367e2f (patch)
treeaa9169e99f961dcc73ed4731575da6c5d8291dc2 /app-containers
parente8aa09f74c8ba0c9e1c5ae3ab49f93b6a0820330 (diff)
gentoo auto-resync : 15:09:2024 - 12:11:38
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/Manifest.gzbin8716 -> 8883 bytes
-rw-r--r--app-containers/docker-pushrm/Manifest4
-rw-r--r--app-containers/docker-pushrm/docker-pushrm-1.9.0.ebuild36
-rw-r--r--app-containers/docker-pushrm/metadata.xml22
-rw-r--r--app-containers/earthly/Manifest6
-rw-r--r--app-containers/earthly/earthly-0.8.13.ebuild71
-rw-r--r--app-containers/earthly/earthly-0.8.14.ebuild71
7 files changed, 62 insertions, 148 deletions
diff --git a/app-containers/Manifest.gz b/app-containers/Manifest.gz
index 0e1a9b3aee17..e554bf1647f1 100644
--- a/app-containers/Manifest.gz
+++ b/app-containers/Manifest.gz
Binary files differ
diff --git a/app-containers/docker-pushrm/Manifest b/app-containers/docker-pushrm/Manifest
new file mode 100644
index 000000000000..8ab8d4f3ab99
--- /dev/null
+++ b/app-containers/docker-pushrm/Manifest
@@ -0,0 +1,4 @@
+DIST docker-pushrm-1.9.0-deps.tar.xz 121551972 BLAKE2B 2798ea5c23cfe300719ec99d1f76746dae379d9ea041e791f6b227c97678c2f0a017c3e4880a62cb6f40511c482997b1da4c4692c7ebad82435edbad30eaea2c SHA512 496f9d059951057f4a3f8d97ef7d50574e9634e29082dae471ce9f7139da40b730db744cbf420ae8da88592d62f4d52b1a24c30b877f1de639f7b5b52f2f6217
+DIST docker-pushrm-1.9.0.tar.gz 211628 BLAKE2B b8b470a97a0580596cfc90ce65ee289e32f49b2cb8a216138f534aac23c21f6007ef5b6d0bc2e9513a6800c7bda22e44ec0bb56ee3e7abe59961f4385928c98a SHA512 c9f3258b9d8660808a55f53ae30eca05d7725cb313a6c46018d7bbfd1feea28a2bfea2153700dfd43a7d4239683eb126f5daa2b29c88467d66620701b0244726
+EBUILD docker-pushrm-1.9.0.ebuild 694 BLAKE2B 82844c7228eb044ad1390ee57556fe5af07471a02ab67d0ec90c3d1a7b4fa49071f8936f6a84abd0255523ab561badd81ffa3e2d54ac49b650c57880e90cbddd SHA512 3004f48b2859c18b08a7841a011588f76cd21ff7137da6c86f7dd4b621474696d500fd881aa33b40bc3e7c38c21d00317e0fce491594e714e94f476aa05a0f98
+MISC metadata.xml 998 BLAKE2B 4e394ee397f4059fa25f405ea9e40ba3f707cbfb641dd680e872d0a2f8b5773e28e23a527d6ecf0f54c7ddf339b3c8fce157d852dc23b8d207cee48afc45dcd5 SHA512 8fe634c6b5c1703843da4e4d3e0f046956e0e58424129f86e5b1bea4aa9aaf850bbafbae737ed955349f9a2981f17ff58a58562e722037f83d405bacce445268
diff --git a/app-containers/docker-pushrm/docker-pushrm-1.9.0.ebuild b/app-containers/docker-pushrm/docker-pushrm-1.9.0.ebuild
new file mode 100644
index 000000000000..76bccc9ef6fc
--- /dev/null
+++ b/app-containers/docker-pushrm/docker-pushrm-1.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Docker CLI plugin to update container repository documentation"
+HOMEPAGE="https://github.com/docker/buildx"
+SRC_URI="
+ https://github.com/christian-korneck/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-containers/docker-cli
+"
+
+src_compile() {
+ local -a go_build_opts=(
+ -o ./bin/
+ )
+ ego build "${go_build_opts[@]}"
+}
+
+src_install() {
+ exeinto /usr/libexec/docker/cli-plugins
+ doexe "bin/${PN}"
+
+ einstalldocs
+}
diff --git a/app-containers/docker-pushrm/metadata.xml b/app-containers/docker-pushrm/metadata.xml
new file mode 100644
index 000000000000..2ee012065b84
--- /dev/null
+++ b/app-containers/docker-pushrm/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">christian-korneck/docker-pushrm</remote-id>
+ <bugs-to>https://github.com/christian-korneck/docker-pushrm/issues/</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ docker-pushrm is a Docker CLI plugin that adds a new docker pushrm
+ command to Docker. It pushes the README file from the current working
+ directory to a container registry server where it appears as repo
+ description in the web interface. It currently supports Docker Hub, Red
+ Hat Quay and Harbor v2. For most registry types docker-pushrm uses
+ authentication info from the Docker credentials store - so it "just
+ works" for registry servers that you're already logged into with Docker.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 99985d42981e..d08f72b19c8f 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,10 +1,4 @@
-DIST earthly-0.8.13-deps.tar.xz 163750220 BLAKE2B 995ed748f99b7d4c4ca90cdd1964c295270963e55462bfa3bdd830209a90303d67c91fed66e7d52984993ef58b1d060e140694fdc8931ca2181dd88701d8f6dd SHA512 ab3ee4fef9a87dab9009ffd4e31d00a256c8ad88096c8573a5a2fb782079392415752024821240da60549d260c9dcfe3d6f1457fb3fbc8cc8a1f2602bb875aee
-DIST earthly-0.8.13.tar.gz 8082676 BLAKE2B cf6d5c6d397951a60302e5492ad219d3d673cce9bf2e06696a3cd8719dcf1d755644413171c7db1b27c60d6cbe0d85facf2d6a5d150c26dc5530c07d1255b742 SHA512 f3abd814c0c57f485a37c83e322d9a8478236ae4220baf455330a6a28d98a8cb7806fb4cee9525c9b27c51bc0ed8780872f51ece7194059658defd54cce1a6b5
-DIST earthly-0.8.14-deps.tar.xz 163777848 BLAKE2B 0615db6d874a0d490666df6517581763315c44a67662d1c8c630d59983849c3a1c10bdee4d626f9ded02a58f7eb037e24cca6b22dfc7eadf79d4e735a33306c5 SHA512 ac062ae77e98ec36f9bba1a73430080d2f2c7bed3ad8c48af8bb1da4a6f006a4285fca8f4d85363652ec3db9df78e76befdfc838971684d704512d795d672414
-DIST earthly-0.8.14.tar.gz 8079338 BLAKE2B c3da74c39b77f671656ba51f7e8a82b77476650e986e5665e1df86fd1674e808b79edcc0b8f616891b6749ec034de45268fb48df519c5fdf54c1e3e583eab5a6 SHA512 566e6bdd6f026baa99bad33128e3a843ef20dacc15efdccaf19af648440c8ee7b445bed80f33102b9fc419d211dc6dea38a66655247549f1eaf17837c6687105
DIST earthly-0.8.15-deps.tar.xz 163782812 BLAKE2B 09a9cb196206e787a48c2c2082a066a31c0bd8dba8785e379bfb86ac56ccf4f8eb34195c8577b866bc1153657008e4fae142eb7a6e21d2791fe92e9cdfa76e2d SHA512 65afc0bd89b6a54bb3e4cc4d7f39522eddbb79266b25afb33ffc3c6571b57952bc2ceafe00ce196098d1c4185ab2672f8a80d9ecd4d6d07dc06a18ba39da3941
DIST earthly-0.8.15.tar.gz 8102499 BLAKE2B 92793722206ab8c2d5bb097f7da40392d1ed1f3399797bc217dab7fcc0f305cc91f5e9f8b997b6e5e187f25c0f1109d8aba2294fb79d4b3f26d6660d36827d5c SHA512 0d98f716a2e2a6cb522abb42894f6356c12ac2e398382207db08d204dc951f65c7be04be7473e060c30a052768c4b2b7e9273d206b4252fec26975e6e166ae2a
-EBUILD earthly-0.8.13.ebuild 1795 BLAKE2B 666b52a938305a2750189d2cfaa8b0bd5fc6cc7c6ef2b512bd905a68b3b4f512a7c8d1fe52c96c0be07af52a89aba9560d393671be807dba8ddf948822e1cf49 SHA512 730a049d3d9f7f01c64aec83e01fc59ad5dff18007ecea8598f7ba6583e183560b59c8d707b8577ebab0dd2661469623dac9a8a8b09bc5b7933b65151cfdfb72
-EBUILD earthly-0.8.14.ebuild 1795 BLAKE2B d040294440bbe07e05885f3bd681ec4b1cd2163336d16092355cbfcaf990b15a631ca71ebf7e0270b1912ffccf2072449fdce47fb1696a851668eaadc0484550 SHA512 c614ff1459d58cce2fcccd1aef9c4bcda798b6f91ab57d5534e232056beeb29c55616c934d434f3fc173d3442956523a6b9531a54546c9a31ad5bcd5aa123060
EBUILD earthly-0.8.15.ebuild 1795 BLAKE2B 3f9084aa29c884c9cf531eb50e66b32e46761d3fc0703b1b42d0e2aec684900df505ba5c0f4b391ef9bf44ea84e9b760386eadd6f92bafc14ab197cb3e9fc72f SHA512 4066a92575c91ca96214da2cd94d017aaede0d010490c4b4285990380930cc232f45484acdc7a40bd7e42aa99bf87beb1748345ca2b6e06ee0e2c0b91cddf839
MISC metadata.xml 927 BLAKE2B b7d5184df16f39603bf6df8b503e701d737fec188d1d97673e4ca59babd990c1b872784c91db04c74d9a08dbffa76f4e7530d8b021cbbe9ae51fd9966f709522 SHA512 f7f49eb583b2b5a9939c26e9eaff3917392525c3a94e5f8274c89b69e172547ad02fa4ed1b078e7d778f765659e1b9a7cf99d88042034cfbfbef54e685c8b6dd
diff --git a/app-containers/earthly/earthly-0.8.13.ebuild b/app-containers/earthly/earthly-0.8.13.ebuild
deleted file mode 100644
index ebee46234ccf..000000000000
--- a/app-containers/earthly/earthly-0.8.13.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
-if [[ "${PV}" == "0.8.13" ]] ; then
- COMMIT_SHA="251e0eada58646e71c562b803bc4b9adbcf07637"
-else
- die 'Could not detect "COMMIT_SHA", please update the ebuild.'
-fi
-
-inherit go-module
-
-DESCRIPTION="Build automation tool that executes in containers"
-HOMEPAGE="https://earthly.dev/
- https://github.com/earthly/earthly/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="
- || (
- app-containers/docker
- app-containers/podman
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-src_compile() {
- local -r go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
- local -r go_ldflags="
- -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
- -X main.GitSha=${COMMIT_SHA}
- -X main.Version=v${PV}
- "
- local -a -r go_buildargs=(
- -tags "${go_tags}"
- -ldflags "${go_ldflags}"
- -o ./bin/
- )
- ego build "${go_buildargs[@]}" ./cmd/...
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/earthly
- newexe bin/debugger earthly-debugger
-
- einstalldocs
-}
-
-pkg_postinst() {
- if has_version "app-containers/podman" ; then
- ewarn "Podman is supported but not recommended."
- ewarn "If issues arise, then please try running earthly with docker."
- fi
-
- if has_version "app-containers/podman[rootless]" ; then
- ewarn "Running podman in rootless mode is not supported because"
- ewarn "earthly/dind and earthly/buildkit require privileged access."
- ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
- fi
-}
diff --git a/app-containers/earthly/earthly-0.8.14.ebuild b/app-containers/earthly/earthly-0.8.14.ebuild
deleted file mode 100644
index c133e768eee1..000000000000
--- a/app-containers/earthly/earthly-0.8.14.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
-if [[ "${PV}" == "0.8.14" ]] ; then
- COMMIT_SHA="6b41f8409d7ffef0d25072c2c04250074b6e3c72"
-else
- die 'Could not detect "COMMIT_SHA", please update the ebuild.'
-fi
-
-inherit go-module
-
-DESCRIPTION="Build automation tool that executes in containers"
-HOMEPAGE="https://earthly.dev/
- https://github.com/earthly/earthly/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="
- || (
- app-containers/docker
- app-containers/podman
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-src_compile() {
- local -r go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
- local -r go_ldflags="
- -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
- -X main.GitSha=${COMMIT_SHA}
- -X main.Version=v${PV}
- "
- local -a -r go_buildargs=(
- -tags "${go_tags}"
- -ldflags "${go_ldflags}"
- -o ./bin/
- )
- ego build "${go_buildargs[@]}" ./cmd/...
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/earthly
- newexe bin/debugger earthly-debugger
-
- einstalldocs
-}
-
-pkg_postinst() {
- if has_version "app-containers/podman" ; then
- ewarn "Podman is supported but not recommended."
- ewarn "If issues arise, then please try running earthly with docker."
- fi
-
- if has_version "app-containers/podman[rootless]" ; then
- ewarn "Running podman in rootless mode is not supported because"
- ewarn "earthly/dind and earthly/buildkit require privileged access."
- ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
- fi
-}