summaryrefslogtreecommitdiff
path: root/app-containers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-05 06:31:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-05 06:31:58 +0000
commite4d9d6796d5018e338f0b27a3bc97716195bf0b8 (patch)
tree38d56da69a3b5d5ccc7d73796d38469f5d4e610c /app-containers
parent38efae7f3eb932ed41510139679efd5c1e2f5eda (diff)
gentoo auto-resync : 05:01:2025 - 06:31:57edge
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/Manifest.gzbin9228 -> 9225 bytes
-rw-r--r--app-containers/apptainer/Manifest2
-rw-r--r--app-containers/apptainer/apptainer-1.3.6.ebuild91
3 files changed, 93 insertions, 0 deletions
diff --git a/app-containers/Manifest.gz b/app-containers/Manifest.gz
index 3ab76c703656..54374b1e57f7 100644
--- a/app-containers/Manifest.gz
+++ b/app-containers/Manifest.gz
Binary files differ
diff --git a/app-containers/apptainer/Manifest b/app-containers/apptainer/Manifest
index c6cc6fedd740..9ed0cd1b8c34 100644
--- a/app-containers/apptainer/Manifest
+++ b/app-containers/apptainer/Manifest
@@ -1,4 +1,6 @@
AUX apptainer-1.0.2-trim_upstream_cflags.patch 1142 BLAKE2B 7238229b70a8ac37f3401a163d19dc705adb6a4ab6355e4eaa386ad5c639bfc1443cf61507112a53b66816399ca5fe2c32de964dd602ea16c5dfbf9003343f8c SHA512 1351ee000274567bb5a63aa740fbc43510d84ccad42c9af0c555943b99d93d86a2b036801c1681b93548a874bda1bab3304c2bf0da83bbca102a71e82574a032
DIST apptainer-1.3.2.tar.gz 17129103 BLAKE2B a2c15d408dc956a4bc8cb154dadfe0e60aa8b4216277ff4afd508058f9425722fb66200e7d4ab33cf5a73aee34761ac198e7b31439ab69dfaceebb9f768b58e6 SHA512 c3112c8254c995f83e3ae424ecf734e8ca9583c34cd8b0e56fdde2a7ef8d5145ac68a7a2c9575b071515a2cb681d11423fe57a5a3910750d3bc697c85c15585d
+DIST apptainer-1.3.6.tar.gz 17129602 BLAKE2B 2dd17c1a0601c7d191d4604f2c0e3fb5d8cc4e831dba7bf4cfcbfc359eba1bb3f255ab2c1a81ae844cbebfc6e96729911e5ac4a92195b30f74d77fafac12059f SHA512 e50b8cbdac544241a56d7dc662ad927fdcf9a0f245bab4be0bc35ba9658f9db7c851a95de500e32c0975a2f5e8bcf7f16628e963ebb945ca036de9e91bd8a4a9
EBUILD apptainer-1.3.2.ebuild 2462 BLAKE2B 97c52f554cc1d29249ccb1de44e26c62998441f1d37079caa702aa8cdacb39b740aac2626bb3acb0b04e5e58c50b45d0e4057001a86938200429882c7563e6df SHA512 760eff4dcee6a67202e2657f1e0126bb6c34bf724a4cc10497ef8f6331435c7bf19035e7fe30cdb500eb591149924b7e89a9f5b90c25204833102d072c1240d7
+EBUILD apptainer-1.3.6.ebuild 2437 BLAKE2B 1d75175d5ae711a39d91db42213f313fb65ec01b2f2cfc5653c246255edc5a0908bca75c0820f9f33e2c37e1478b706eb88ddfbb77d315ee614a75c56e96b035 SHA512 aa5b8465ad006b99196650c004c1b0301b8c565dd6dd765ba6a98dafe6bd3641d22869549a7007d739395ab63c5e5a06a5ab41629532251c40d0202bcbcf8d3e
MISC metadata.xml 376 BLAKE2B 0c0bcda53c7a1203fe5b32758e572d4f60270e4fdfc5a3779db54bf4ab7ea8fc3c958b53aaaa3e1c7c4c817e82bf95ccf52f122542b4c3f7f1b25fb84332ac7e SHA512 0364cb2a1537a41ad872de51eba33cba2407c6081b010acb3f404eb308fea863ad7c0f462c3fc1a424ff33577a0c7eea672eb7722a81c6b0a01475a4d0fc7727
diff --git a/app-containers/apptainer/apptainer-1.3.6.ebuild b/app-containers/apptainer/apptainer-1.3.6.ebuild
new file mode 100644
index 000000000000..1adfbf38c500
--- /dev/null
+++ b/app-containers/apptainer/apptainer-1.3.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="The container system for secure high-performance computing"
+HOMEPAGE="https://apptainer.org/"
+SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network suid systemd"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+DEPEND="app-crypt/gpgme
+ >=dev-lang/go-1.20.0
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ sys-fs/squashfs-tools
+ sys-libs/libseccomp
+ !suid? (
+ sys-fs/e2fsprogs[fuse]
+ sys-fs/squashfuse
+ )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~SQUASHFS"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-trim_upstream_cflags.patch
+)
+
+DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --runstatedir="${EPREFIX}"/run \
+ --localstatedir="${EPREFIX}"/var \
+ $(usex network "" "--without-network") \
+ $(use_with suid)
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C builddir install
+ keepdir /var/${PN}/mnt/session
+
+ if use systemd; then
+ sed -i -e '/systemd cgroups/ s/no/yes/' "${ED}"/etc/${PN}/${PN}.conf \
+ || die "Failed to enable systemd use in configuration"
+ else
+ sed -i -e '/systemd cgroups/ s/yes/no/' "${ED}"/etc/${PN}/${PN}.conf \
+ || die "Failed to disable systemd use in configuration"
+ fi
+
+ einstalldocs
+ if use examples; then
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ if ! use suid; then
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.1.0; then
+ ewarn "Since version 1.1.0 ${PN} no longer installs setuid-root components by default, relying on unprivileged user namespaces instead. For details, see https://apptainer.org/docs/admin/main/user_namespace.html"
+ ewarn "Make sure user namespaces (possibly except network ones for improved security) are enabled on your system, or re-enable installation of setuid root components by passing USE=suid to ${CATEGORY}/${PN}"
+ break
+ fi
+ done
+ fi
+}