summaryrefslogtreecommitdiff
path: root/app-containers/syft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
commit496936ff0f7db69d1f7317341230acb866e3c330 (patch)
tree1541e919cd45c0ab5bdee8f1ac1344508da3b3af /app-containers/syft
parentc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (diff)
gentoo auto-resync : 29:07:2022 - 21:08:17
Diffstat (limited to 'app-containers/syft')
-rw-r--r--app-containers/syft/Manifest1
-rw-r--r--app-containers/syft/syft-0.52.0-r1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
index 8d08c74df108..7fb3be61838b 100644
--- a/app-containers/syft/Manifest
+++ b/app-containers/syft/Manifest
@@ -1,4 +1,5 @@
DIST syft-0.52.0-deps.tar.xz 962322444 BLAKE2B 696dd14adf54c8ab51cc91d22028ce0ace3b6a5835fb8c3ce6d26080f0ce75d2a9ca332f2275a71706a2152519b01a71577827ac63c12ffb87ad1605ffd18b28 SHA512 b6897a12b8a15c8c2b4672e93ca03fe26a182ee87e48ac4bdd26057f544a6a45aa5ce6317a38e157b99a70830d4a0241f8b4cb15f8fffccaf195ac4c4ff64cd8
DIST syft-0.52.0.tar.gz 3726656 BLAKE2B de8492adde3bef944a9b853990ba5909aa14ccc223f42833fa2a49d1bd5772455bd3ab9ac3a8886b353dc79c6e93338e43e9c448623bd31c422155e0adb1f276 SHA512 2ffaaa154546061d1d61bf8f0b3d5cf10282dbbb08876cc9e87777a23efdba1fd462c395ee4cf14d334f49ae4575e2db5fe8b5fbe7439dd24ff22ec8efeb6501
+EBUILD syft-0.52.0-r1.ebuild 1017 BLAKE2B a4b66cc02469d967489b9f61af5712ba7475e11e8109256af241b4606a6762a9680d29b0d206bd4398851fa9ae61a99a1fa7f93b5947fc6a9fb7f293dd96adb8 SHA512 d79f5db1f6d39a494545defe4ddd386de74f53234ad2dadbfd7ad0e2cf3faadb93cd0fea2b3aca18ae703fead219b57be3b89baf1e90e92e55992b5eb94f314f
EBUILD syft-0.52.0.ebuild 531 BLAKE2B cc3863fc3db089b85095646c7de8eb1b8a74cbdd72e7e7eedd57e3082443ee2ac685a87094336530e23d9097fbb7ade8699fc54e98f0910c6a33bb1d935ef166 SHA512 c248c0cda550e2479736a22dd25777ce6cd11d97c4468db14a2b43f57e78c6780c957a0502e461af41b941c5056c947bc5026e7f2aa50420a7bffe82302c3356
MISC metadata.xml 243 BLAKE2B 63665ae2020bc799fa6ebd6e1fca6755be6498803fdbc17cc630f9f4ffa03fbd46a9ad396e70adc3bc1c32b0a746fe4bab1c6291f32e68e636251207bca9e95c SHA512 78eab20831018fcf4957171a83aaaca9ced53380e01f083c07450c30fa1adfc02dd50ff2fa9f491dd62802f6e779264add1c47a09ade0a35cda558c1d5529ad0
diff --git a/app-containers/syft/syft-0.52.0-r1.ebuild b/app-containers/syft/syft-0.52.0-r1.ebuild
new file mode 100644
index 000000000000..78e4ff1e79aa
--- /dev/null
+++ b/app-containers/syft/syft-0.52.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=ba9adb17ebb510a2a3bd2b641738b1d9235e1f3e
+
+DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# tests require a running docker daemon
+RESTRICT="test"
+
+src_compile() {
+ local BUILD_DATE
+ BUILD_DATE=$(date -u +%Y-%m-%dT%H:%M:%SZ)
+ ego build -o bin/syft -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/syft/internal/version.version=${PV}
+ -X github.com/anchore/syft/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/syft/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/syft/internal/version.gitDescription=v${PV}
+ " ./cmd/syft
+}
+
+src_install() {
+ dobin bin/*
+}